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Symptômes

Vous recevez l’un des messages d’erreur suivants lors de la création d’une intégration à l’aide de Integration Manager avec Microsoft Dynamics GP ou Microsoft Business Solutions - Grande recherche :

Message d’erreur 1

Élément « -8 » Non dans la collection

Message d’erreur 2

La classe ne prend pas en charge l’automation

Lorsque vous essayez d’ouvrir le Gestionnaire d’intégration, le message d’erreur suivant peut également s’ouvrir :

Erreur d’automatisation : Système d’exploitation in disponible

Lorsque vous installez le Gestionnaire d’intégration sur une station de travail client, vous recevez le message d’erreur suivant :

Erreur interne dans les TTGErrors : erreur d’automatisation. Le système d’exploitation ne peut pas exécuter %1.

Lorsque vous cliquez sur Détails,vous recevez le rapport d’erreurs suivant :

Nous n’avons pas pu créer l’objet IMProvider.ODBCProvider.

Lorsque vous cliquez sur Aide dans la barre de menus du Gestionnaire d’intégration, puis surÀpropos du Gestionnaire d’intégration, vous recevez le message d’erreur suivant :

La classe ne prend pas en charge l’automation ou ne prend pas en charge le numéro d’interface attendu : pile des appels
430



: frmAbout.Form_Load

Cette erreur se produit si vous avez installé Microsoft Office 2003.

Cause

Cette erreur est due à un conflit qui se produit Gestionnaire de contacts professionnels 2003 et Integration Manager sur le même ordinateur. Gestionnaire de contacts professionnels partage les mêmes fichiers et certaines clés de Registre que Le Gestionnaire d’intégration 9.0, 8.0 et 7.50. Les composants Integration Manager 7.0 étaient utilisés pour créer des Gestionnaire de contacts professionnels. Toutefois, un problème se produit lorsque Gestionnaire de contacts professionnels et Integration Manager 9.0, 8.0 ou 7.50 sont installés sur le même ordinateur. Le problème est que le moteur WINDOWS COM au niveau du système d’exploitation recherche l’emplacement d’un serveur COM dans le Registre.

Le Gestionnaire de contacts NoteBusiness est disponible uniquement Microsoft Office Petite Entreprise Édition 2003 et Microsoft Office Professional Edition 2003.

Résolution

Pour résoudre ce problème, utilisez la résolution 1 ou 2 selon que vous utilisez Gestionnaire de contacts professionnels. Si vous n’utilisez pas Gestionnaire de contacts professionnels, vous pouvez supprimer le composant à l’aide de la résolution 1. Si vous utilisez la Gestionnaire de contacts professionnels, vous devez utiliser la résolution 2.

Résolution 1 : supprimer les Gestionnaire de contacts professionnels

Si vous n’utilisez pas Gestionnaire de contacts professionnels, vous pouvez résoudre ce problème en supprimant le composant. Pour ce faire, vous devez utiliser l’ajout ou la suppression de programmes. Une fois les composants supprimés, vous devez réparer le Gestionnaire d’intégration. Pour supprimer BusinessContactManager et réparer Integration Manager, suivez ces étapes :

  1. Cliquez sur Démarrer,pointez sur Programmes,cliquez sur Panneau de gestion,double-cliquez sur Ajouter ou supprimer desprogrammes,cliquez Gestionnaire de contacts professionnelspuis sur Supprimer.

  2. Dans Ajouter ou supprimer des programmes,sélectionnez Gestionnaired’intégration,cliquez surModifier/Supprimer,puis sur Réparer.

  3. Si vous continuez à recevoir le message d’erreur, répétez cette procédure en cliquant sur Modifier à l’étape 2 au lieu de réparer. Sélectionnez ensuite l’installation de alladapters.

Résolution 2 : forcer le Registre à utiliser les fichiers de moteur COM corrects

Si vous utilisez Gestionnaire de contacts professionnels, vous pouvez résoudre ce problème en créant un IM.EXE. Fichier LOCAL pour forcer le Registre à utiliser les fichiers Windows moteur COM pour Integration Manager. Pour cela, procédez comme suit :

  1. Démarrez Bloc-notes, puis laissez le pavé vide.

  2. Cliquez sur Fichier, puis cliquez sur Enregistrer sous.

  3. Modifiez la valeur du champ Type de fichier en tant que fichier par Tous les fichiers.

  4. Dans le champ Nom de fichier, tapez IM.EXE. LOCAL. Enregistrez ensuite le fichier dans le même dossier que celui où le Gestionnaire d’intégration (IM.exe) est installé.

    Remarque Si un fichier a le même nom que l’application client, et si le nom du fichier a le . Extension locale, le moteur COM vérifie si le serveur COM se trouve dans l’annuaire local au lieu de le charger à partir du dossier dans le Registre.

  5. Copiez les CBOMLib.dll et CBOMLibX.dll fichiers dans le même dossier que le IM.exe et le IM.EXE. fichiers LOCAUX. Lorsque le fichier IM.exe est ouvert à partir de ce dossier, le fichier IM.exe utilise les copies locales des fichiers CBOMLib.dll et CBOMLibX.dll au lieu des fichiers identifiés dans le Registre.

    Remarque : Gestionnaire de contacts professionnels a été installé après le Gestionnaire d’intégration, le Registre pointe vers Gestionnaire de contacts professionnels copies de ces fichiers. Ces copies sont identiques à celles de Integration Manager 7.0.

Informations supplémentaires

Cet article était TechKnow numéro de document :34103 Le problème décrit dans la section Symptômes ne s’applique pas à


Microsoft Dynamics GP 10.0.

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