Applies ToHost Integration Server 2016

Symptoms

Microsoft BizTalk Adapter for DB2 intermittently doesn't connect to DB2 for i V7R2. This issue occurs when client-side connection pooling is enabled. When this occurs, the following message is logged in the Application event log:

Internal message: Failed to open connection.

Cause

This issue occurs because the Microsoft BizTalk Adapter for DB2 doesn't release connections from the client-side connection pool after the default time-out period.

More information

After this fix is installed, the Microsoft BizTalk Adapter for DB2 is updated to support a new send port and receive location configuration property that is named Connection Pool Timeout. This property instructs the adapter to clear inactive connections from the connection pool after a specified number of seconds. This property accepts an integer value. The default value is 60 seconds.

Resolution

This issue is fixed in Cumulative Update 2 for Host Integration Server 2016.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology Microsoft uses to describe software updates.

Potrebna vam je dodatna pomoć?

Želite dodatne mogućnosti?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.