A HAÉRZ függvényt használhatja a képlethibák ki- és kijavítására. A HAHIBA függvény egy Ön által megadott értéket ad vissza, ha egy képlet hibát ad vissza; ellenkező esetben a képlet eredményét adja eredményül.

Szintaxis

HAHIBA(érték; érték_ha_hiba)

A HAHIBA függvény szintaxisa az alábbi argumentumokat foglalja magában:

  • érték    Megadása kötelező. Argumentum, amelyet a függvény ellenőriz, hogy hibát eredményez-e.

  • value_if_error    Kötelező megadni. A visszatérési érték, ha a képlet hibát ad vissza. A program a következő hibatípusokat értékeli ki: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, vagy #NULL!.

Megjegyzések

  • Ha az value_if_error üres cella, akkor a HAÉRZ üres karakterláncként ("") kezeli.

  • Ha az érték tömbképlet, akkor a HAÉRZ függvény az értékben megadott tartomány minden egyes cellájára egy tömböt ad eredményül. Ezt szemlélteti az alább található második példa.

Példák

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja meg az F2, majd az Enter billentyűt.

Kvóta

Eladott egység

210

35

55

0

23

Képlet

Leírás

Eredmény

=HAHIBA(A2/B2;"Számítási hiba")

Hibát keres a képlet első argumentumában (210 osztva 35-tel); nem talál hibát, ezért a képlet eredményét adja vissza.

6

=HAHIBA(A3/B3;"Számítási hiba")

Hibát keres a képlet első argumentumában (55 osztva 0-val); 0-val való osztási hibát talál, ezért az érték_ha_hiba argumentum értékét adja eredményül.

Számítási hiba

=HAHIBA(A4/B4;"Számítási hiba")

Hibát keres a képlet első argumentumában ("" osztva 23-mal); nem talál hibát, ezért a képlet eredményét adja vissza.

0

2. példa

Kvóta

Eladott egység

Arány

210

35

6

55

0

Számítási hiba

23

0

Képlet

Leírás

Eredmény

=C2

Hibát keres a képlet első argumentumaként megadott tömbképlet első elemében (A2/B2, vagyis 210 osztva 35-tel); nem talál hibát, ezért a képlet eredményét adja vissza.

6

=C3

Hibát keres a képlet első argumentumaként megadott tömbképlet második elemében (A3/B3, vagyis 55 osztva 0-val); 0-val való osztási hibát talál, ezért az érték_ha_hiba argumentum értékét adja eredményül.

Számítási hiba

=C4

Hibát keres a képlet első argumentumaként megadott tömbképlet harmadik elemében (A4/B4, vagyis "" osztva 23-mal); nem talál hibát, ezért a képlet eredményét adja vissza.

0

Megjegyzés: Ha az Microsoft 365aktuális verziójával rendelkezik, akkor beírhatja a képletet a kimeneti tartomány bal felső cellájába, majd az ENTER billentyűt lenyomva megerősítheti a képlet dinamikus tömbképletként való megerősítését. Ellenkező esetben a képletet régi típusú tömbképletként kell beírnia úgy, hogy először kijelöli a kimeneti tartományt, beírja a képletet a kimeneti tartomány bal felső cellájába, majd a megerősítéshez lenyomja a CTRL+SHIFT+ENTER billentyűkombinációt. Az Excel a képlet elejére és végére beszúrja Ön helyett a kapcsos zárójeleket. A tömbképletekről további információt az Útmutatások és példák tömbképletek használatához című cikkben talál.

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük visszajelzését!

×