Az implicit metszet operátort az Excel képletnyelv érdemi frissítésének részeként vezettük be a dinamikus tömbök támogatására. A dinamikus tömbök jelentős új számítási képességeket és funkciókat hoznak az Excelbe.

Frissített képletnyelv

Az Excel frissített képletnyelve szinte teljesen megegyezik a régi nyelvvel, azzal a kivétellel, hogy a @ operátorral jelzi az implicit metszet lehetséges helyét, míg a régi nyelv ezt jelzés nélkül tette. Ennek eredményeképpen @ jeleket fedezhet fel bizonyos függvényekben, ha dinamikus tömb Excelben nyitja meg őket. Fontos megjegyezni, hogy a képletek kiszámítása továbbra is ugyanúgy fog folytatódni, ahogy eddig.  

Mi az implicit metszet?

Az implicit metszetlogika egyetlen értékre csökkent számos értéket. Az Excel ezt azért tette, hogy a képletet egyetlen érték visszaadására kényszerítse, mivel a cellák csak egyetlen értéket tartalmazhatnak. Ha a képlet egyetlen értéket adott vissza, akkor az implicit metszet nem tett semmit (bár technikailag végbement a háttérben). A folyamat elve a következő:

  • Ha az érték egyetlen elem, akkor az elemet adja vissza.

  • Ha az érték tartomány, akkor annak a cellának az értékét adja vissza, amely a képlettel azonos sorban vagy oszlopban található.

  • Ha az érték tömb, válassza a bal felső értéket.

A dinamikus tömbök megjelenésével az Excel már nincs korlátozva arra, hogy egyetlen értékeket adjon vissza a képletekből, ezért nincs többé szükség a csendes implicit metszetre. Ahol egy régi képlet nem látható módon implicit metszetet válthat ki, a dinamikus tömböt engedélyező Excel @ jellel mutatja, hogy hol történt volna.  

Miért pont @ szimbólum? 

A @ szimbólumot már használatban van a táblázathivatkozásokban az implicit metszet jelzésére. A =[@Column1] táblázatban vegye figyelembe az alábbi képletet. Itt a @ azt jelzi, hogy a képlet az implicit metszet használatával olvassa be az [Oszlop1] ugyanazon sorában lévő értéket.  

Eltávolítható a @-t? 

Gyakran megteheti. Attól függ, hogy a képletnek a @ jeltől jobbra lévő része mit ad vissza: 

  • Ha egyetlen értéket ad vissza (ez a leggyakoribb eset), akkor a @ eltávolítása nem hoz változást.

  • Ha tartományt vagy tömböt ad vissza, a @ eltávolításával az a szomszédos cellákba kerül át.

Ha eltávolít egy automatikusan hozzáadott @ karaktert, majd később megnyitja a munkafüzetet egy régebbi Excel-verzióban, akkor az egy régi tömbképletként fog megjelenni (kapcsos zárójelekkel {} közrefogva), azért, hogy a régebbi verzió ne váltson ki implicit metszetet.

Mikor adjuk hozzá a @ karaktert a régi képletekhez? 

Általánosságban elmondható, hogy a többcellás tartományokat vagy tömböket visszaadó függvényeket a @ előtaggal látja el a rendszer, ha az Excel régebbi verziójában írták őket. Fontos megjegyezni, hogy a képlet viselkedése nem változott – egyszerűen csak most már láthatja a korábban láthatatlan implicit metszetet. A többcellás tartományok visszaadására használható gyakori függvények: INDEX, ELTOLÁS és Felhasználó által definiált függvények (UFD).  Gyakori kivétel, ha egy tömböt vagy tartományt (például SZUM() vagy ÁTLAG()) elfogadó függvénybe van belefoglalva. 

További részletekért lásd: A tartományokat vagy tömböket visszaadó Excel-függvények.

Példák

Eredeti képlet

Az Excel dinamikus tömbjében látottak szerint 

Ismertetés

=SZUM(A1:A10) 

=SZUM(A1:A10) 

Nincs változás – Nem fordulhat elő implicit metszet, mivel a SZUM függvény tartományokat vagy tömböket vár. 

=A1+A2 

=A1+A2 

Nincs változás – Nem fordulhat elő implicit metszet. 

=A1:A10 

=@A1:A10 

Implicit metszet fordul elő, és az Excel visszaadja a képlet sorához tartozó értéket.

=INDEX(A1:A10,B1) 

=@INDEX(A1:A10,B1) 

Implicit metszetoperátor fordulhat elő. Az INDEX függvény akkor ad vissza tömböt vagy tartományt, ha a második vagy harmadik argumentuma 0.  

=ELTOLÁS(A1:A2,1,1) 

=@ELTOLÁS(A1:A2,1,1) 

Implicit metszetoperátor fordulhat elő. Az ELTOLÁS függvény többcellás tartományt is visszaadhat. Amikor ez történik, az implicit metszet aktiválódik. 

=MYUDF() 

=@MYUDF() 

Implicit metszetoperátor fordulhat elő. A felhasználó által definiált függvények tömböt is visszaadhatnak. Ha ez történik, az eredeti képlet kiváltja az implicit metszetet. 

Az @ operátor használata új képletekben

Ha olyan képletet hoz létre vagy szerkeszt egy dinamikus tömbben az Excelben, amely tartalmazza a @ operátort, előfordulhat, hogy _xlfn.SINGLE() formában jelenik meg az Excel pre-dinamikus tömbben.

Ez egy vegyes képlet véglegesítése esetén fordul elő. A vegyes képlet olyan képlet, amely a tömb számításán és az implicit metszeten egyaránt alapul – ezt az Excel pre-dinamikus tömbje nem támogatja. A pre-dinamikus tömb csak olyan képleteket támogatott, amelyek i) implicit metszetet vagy ii) tömbszámítást végeztek teljes egészében.

Ha a dinamikus tömböt engedélyező Excel "vegyes képlet" létrehozását észleli, felajánlja a képlet olyan változatát, amely implicit metszetet tartalmaz teljes egészében. Például ha ezt írja be: =A1:A10+@A1:A10, akkor a következő párbeszédpanel jelenik meg:

Párbeszédpanel, amely azt kérdeti, hogy az =@A1:A10 + @A1:A10 függvényt szeretné-e inkább használni.

Ha a párbeszédpanel által javasolt képletet elveti, a program az =A1:A10+@A1:A10 vegyes képletet fogja véglegesíteni. Ha később megnyitja ezt a képletet az Excel pre-dinamikus tömbjében, a következő képlet jelenik meg :=A1:A10+_xlfn.SINGLE(A1:A10) úgy, hogy a vegyes képletben a @ érték egyszerű _xlfn.SINGLE() formában jelenik meg. Amikor ezt a képletet az Excel pre-dinamikus tömbje értékeli, az Excel visszaad egy új #NÉV értéket! hibaértéket adja vissza. 

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Lásd még

SZŰRŐ függvény

VÉLETLENTÖMB függvény

SORSZÁMLISTA függvény

SORBA.RENDEZ függvény

RENDEZÉS.ALAP.SZERINT függvény

EGYEDI függvény

#KITÖLTÉS! hibák az Excelben

Dinamikus tömbök és kibontott tömb viselkedése

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?

Mi befolyásolta a felhasználói élményét?

Szeretne további visszajelzéssel élni? (Nem kötelező)

Köszönjük visszajelzését!

×