Amikor a Microsoft Excel megnyitáskor sérült munkafüzetet észlel, automatikusan elindítja a fájlhelyreállítási módot, és megkísérli helyreállítani a munkafüzetet. Ha nem indul el a fájl-helyreállítási üzemmód, próbálkozzon ezzel a manuális folyamattal a munkafüzet helyreállításához:

  1. Kattintson a Fájl > Megnyitás parancsra.

  2. Kattintson arra a helyre és mappára, amely a sérült munkafüzetet tartalmazza.

  3. A Megnyitás párbeszédpanelen jelölje ki a sérült munkafüzetet.

  4. Kattintson a Megnyitás gomb melletti nyílra, majd a Megnyitás és javítás menüpontra.

    A Megnyitás és javítás parancs

  5. Ha a lehető legtöbb munkafüzetadatot helyre kell állítania, válassza a Javítás gombra.

    Ha a Javítás nem tudja helyreállítani az adatokat, az Adatok kinyerása gombra választva kinyerhet értékeket és képleteket a munkafüzetből.

Ha sem az automatikus, sem a manuális javítás nem működik, van néhány olyan helyreállítási módszer, amely segíthet az adatok mentésében. Ha nem veszíti el munkáját, megelőző lépéseket is kell tennie, ha automatikusan biztonsági másolatot készít a munkafüzetről, vagy időről időre létrehoz egy helyreállítási fájlt.

Adatok visszaállítása sérült munkafüzetből

Az adatok helyreállításához válasszon az alábbi módszerek közül. Ha nem jár sikerrel, próbálkozzon egy másik módszerrel. Külső szoftvermegoldásokkal is próbálkozhat a munkafüzet helyreállításához.

Fontos: Ha lemezhiba vagy hálózati hiba miatt nem lehet megnyitni egy munkafüzetet, az alábbi helyreállítási lehetőségek kipróbálása előtt helyezze át a munkafüzetet egy másik merevlemezre vagy helyi lemezre.

Adatok helyreállítása az Excelben megnyitott munkafüzetben

  • A munkafüzet utolsó mentett verziójának visszaállítása    Ha a munkafüzet munka közben, de a módosítások mentése előtt megsérül, visszaállíthatja a munkafüzetet az utolsó mentett verzióra:

    1. Kattintson a Fájl > Megnyitás parancsra.

    2. Kattintson duplán annak a munkafüzetnek a nevére, amelyet meg szeretne nyitni az Excelben.

    3. Kattintson az Igen gombra a munkafüzet újbóli megnyitásához.

      A munkafüzet megnyílik anélkül, hogy bármilyen módosítást végrehajtott volna, ami a munkafüzet sérülését okozhatta.

Adatok helyreállítása, ha nem tudja megnyitni a munkafüzetet az Excelben

  • Kézi újraszámítás beállítása az Excelben    Próbálkozzon a számítási beállítás automatikusról kézire módosításával. A program ekkor nem számítja újra a munkafüzetet, így előfordulhat, hogy sikerül megnyitnia.

    1. Kattintson a Fájl menü Új parancsára.

    2. Az Új alattkattintson az Üres munkafüzet elemre.

    3. Kattintson a Fájl fülre, majd a Beállítások elemre.

    4. A Képletek kategória Számítási beállítások kategóriájában válasszaaKézi lehetőséget, majd kattintson az OK gombra.

    5. Kattintson a Fájl > Megnyitás parancsra.

    6. Keresse meg a sérült munkafüzetet, és kattintson rá duplán a megnyitásához.

  • A sérült munkafüzet csatolása külső hivatkozásokkal    Ha csak adatokat, képleteket vagy számított értékeket nem akar kinyerni a munkafüzetből, próbáljon külső hivatkozásokkal hivatkozni a sérült munkafüzetre.

    1. Kattintson a Fájl > Megnyitás parancsra.

    2. Menjen a sérült munkafüzetet tartalmazó mappába.

    3. Kattintson a jobb gombbal a sérült munkafüzet fájlnevére, kattintson a Másolás parancsra, majd kattintson a Mégse parancsra.

    4. Kattintson a Fájl menü Új parancsára.

    5. Az Új alattkattintson az Üres munkafüzet elemre.

    6. Az új munkafüzet A1 cellájába írja be az =Fájlnév! A1, ahol a Fájlnév a sérült munkafüzet neve, amit a 3. lépésben másolt, majd nyomja le az Enter billentyűt.

      Megjegyzés:  Csak a munkafüzet nevét kell beírnia, a fájlnévkiterjesztést nem.

    7. Ha megjelenik az Értékek frissítése párbeszédpanel, jelölje ki a sérült munkafüzetet, és kattintson az OK gombra.

    8. Ha megjelenik a Lap kiválasztása párbeszédpanel, akkor válassza ki a megfelelő munkalapot, és kattintson az OK gombra.

    9. Jelölje ki az A1 cellát.

    10. Kattintson a Kezdőlap > Másolás parancsra,vagy nyomja le a Ctrl+C billentyűkombinációt.

    11. Jelöljön ki egy olyan területet az A1 cellában kezdve, amely megközelítőleg akkora méretű, mint a sérült munkafüzet adatait tartalmazó cellatartomány.

    12. Kattintson a Kezdőlap > beillesztése gombra,vagy nyomja le a Ctrl+V billentyűkombinációt.

    13. Miközben a cellatartomány továbbra is ki van jelölve, kattintson ismét a Kezdőlap >Másolás parancsra, vagy nyomja le a Ctrl+C billentyűkombinációt.

    14. Kattintson a Kezdőlap > a Beillesztés gomb alatti nyílra,majd az Értékek beillesztésealatt kattintson az Értékek elemre.

      Az értékek beillesztésével eltávolítja a sérült munkafüzetre mutató hivatkozásokat, és csak az adatokat hagyja meg.

  • Az adatok kinyerése a sérült munkafüzetből makróval    Ha egy diagram a sérült munkafüzethez van csatolva, próbáljon meg egy makrót használni a diagram forrásadatának kinyeréhez.

    1. Másolja a vágólapra a következő makrókódot, és illessze be egy modullapra:

      Sub GetChartValues()

      Dim NumberOfRows As Egész szám

      Dim X As Object

      Counter = 2

      ' Az adatsorok számának kiszámítása.

      NumberOfRows = UBound(ActiveChart.SeriesCollection(1). Értékek)

      Munkalapok("Diagramadatok"). Cellák(1;1) = "X értékek"

      ' Írja be az x tengely értékeit a munkalapra.

      Munkalapokkal("Diagramadatok")

      . Range(. Cellák(2;1); _

      . Cells(NumberOfRows + 1, 1)) = _

      Application.Transpose(ActiveChart.SeriesCollection(1). XValues)

      Vége:

      ' Végigjátszja a diagram összes adatsorát, és írja be az értékeket a

      ' a munkalapon.

      Az ActiveChart.SeriesCollection nézetben minden x x

      Munkalapok("Diagramadatok"). Cells(1; Counter) = X.Name

      Munkalapokkal("Diagramadatok")

      . Range(. Cellák(2; számláló), _

      . Cells(NumberOfRows + 1, Counter)) = _

      Application.Transpose(X.Values)

      Vége:

      Counter = Counter + 1

      Tovább

      End Sub

    2. Munkalap beszúrása vagy törlése a munkafüzetbe: kattintson a jobb gombbal a munkalap fülére, és nevezze át Diagramadatok névre.

    3. Jelölje ki a diagramot, amelyből ki szeretné nyerni a háttéradatokat.

      Megjegyzés: A diagram munkalapra beillesztve vagy külön diagramon lehet.

    4. Futtassa a makrót.

    5. A diagram adatai a ChartData munkalapon adatokat tartalmaznak.

Vissza a lap tetejére

Munkafüzet biztonsági példányának mentése automatikusan

Ha biztonsági másolatot készít a munkafüzetről, akkor mindig hozzáférhet az adataihoz, ha a munkafüzet véletlenül törlődik, vagy ha megsérül.

  1. Kattintson a Fájl > Mentés másként parancsra.

  2. Kattintson a Számítógép, majd a Tallózás gombra.

    Tallózás gomb

  3. A Mentés másként párbeszédpanelen kattintson az Eszközök elem melletti nyílra,majd az Általános beállítások parancsra.

    Az Eszközök menü Beállítások pontja

  4. Az Általános beállítások párbeszédpanelen jelölje be a Mindig készítsen biztonsági másolatot jelölőnégyzetet.

    Biztonsági másolat is készül jelölőnégyzet az Általános beállítások párbeszédpanelen

Vissza a lap tetejére

Helyreállítási fájl automatikus létrehozása meghatározott időközönként

A munkafüzet helyreállítási fájlja abban is segít, hogy hozzáférjen az adataihoz, ha a munkafüzet véletlenül törlődik, vagy ha megsérül.

  1. Kattintson a Fájl fülre, majd a Beállítások elemre.

  2. A Mentés kategóriában, a Munkafüzetek mentésecsoportban jelölje be az Automatikus újramentő adatok mentése jelölőnégyzetet, majd adjon meg néhány percet. (Az alapértelmezett érték 10.)

    Automatikus helyreállítási beállítás az Excel Beállítások párbeszédpanelének Mentés lapján

  3. Adja meg az Automatikus helyreállítási mappa mezőben, hogy hová szeretné menteni a helyreállítási fájlt.

  4. Győződjön meg arról, hogy az Automatikus mentés letiltása csak erre a munkafüzetre jelölőnégyzet nincs bejelölve.

Vissza a lap tetejére

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük visszajelzését!

×