Tartalom
×
Képletek és függvények
Képletek és függvények

SZUM függvény

A SZUM függvény értékeket ad össze. Összeadhat egyedi értékeket, cellahivatkozásokat, tartományokat vagy akár a három kombinációját is.

Például:

  • =SZUM(A2:A10) Összeadja az A2:10 cellák értékeit.

  • =SZUM(A2:A10; C2:C10) Összeadja az A2:10 cellákban és a C2:C10 cellákban lévő értékeket.

Ez a böngésző nem támogatja a videók lejátszását.

SZUM(szám1;[szám2];...)

Argumentum neve

Leírás

szám1:   

Kötelező

Az összeadás első tagja. A szám lehet például a 4, lehet egy cellahivatkozás, például B6 vagy egy cellatartomány, például B2:B8.

szám2-255   

Nem kötelező

Az összeadás második tagja. Ily módon megadhat legfeljebb 255 további számot.

Ebben a szakaszban megismerhet néhány ajánlott eljárást a SZUM függvény használatára vonatkozóan. Az eljárások többségének a más függvényekkel való munka során is hasznát veheti.

Az =1+2 vagy =A+B módszer – Még ha az „=1+2+3” vagy az „=A1+B1+C2” képlet egyszerűen beírhatónak és pontosnak is tűnik, ez a módszer több szempontból is problematikus:

  1. Elírások – Gondoljon bele, hogy mi lenne, ha sokkal több vagy nagyobb értékeket kellene beírnia, például:

    • =14598,93+65437,90+78496,23

    Nem könnyű ilyen esetben ellenőrizni az értékek helyességét. Sokkal egyszerűbb, ha elhelyezi ezeket az értékeket egy-egy cellában, és a SZUM függvénnyel adja őket össze. A cellában elhelyezett értékeket emellett formázhatja is, és így sokkal olvashatóbbá teheti őket, mintha közvetlenül a képletben szerepelnének.

    A képletekben fixen kódolt értékek helyett használja a SZUM függvényt.  A D5 cellában szereplő képlet a következő: =SZUM(D2:D4)
  2. #ÉRTÉK! hiba – Ha szövegre hivatkozik számok helyett.

    Ha például az alábbi képletet használja:

    • =A1+B1+C1 vagy =A1+A2+A3

    Nem megfelelő képletszerkesztés példája.  A képlet a D2 cellában =A2+B2+C2

    A képlete #ÉRTÉK! hibát adhat, ha a hivatkozott cellákban akár egyetlen nem szám (vagyis szöveges) érték is szerepel. A SZUM függvény ezzel szemben figyelmen kívül hagyja a szöveges értékeket, és csak a számértékeket adja össze.

    Helyes képletszerkesztés.  Az =A2+B2+C2 helyett a D2 cellában szereplő képlet a következő: =SZUM(A2:C2)
  3. #HIV! hiba – Ha sorokat vagy oszlopokat töröl.

    Oszlop törlésével okozott #HIV! hiba.  A képlet a következőre változott: =A2+#HIV!+B2

    Ha töröl egy sort vagy oszlopot, a képlet nem fog frissülni a törölt elem kizárásához, és ezért #HIV! hibát ad, míg a SZUM függvény automatikusan képes igazodni az ilyen változásokhoz.

    A SZUM függvény automatikusan módosul a beszúrt vagy törölt soroknak és oszlopoknak megfelelően
  4. Nem frissülő hivatkozások sorok vagy oszlopok beszúrásakor

    =A+B+C képletek nem frissülnek, ha sorokat vesz fel

    Ha beszúr egy sort vagy oszlopot, a képlet nem fog frissülni a hozzáadott sor vagy oszlop belefoglalásához, míg a SZUM függvény automatikusan igazodik az ilyen változásokhoz (kivéve, ha a változás a képletben hivatkozott tartományon kívül történik). Ezt fontos észben tartani, mert ha azt feltételezi, hogy a képlet frissül, akkor előfordulhat, hogy észre sem veszi, amikor hiányos eredményt kap.

    A példa egy oszlop beszúrásakor a =SZUM(A2:C2) képletről automatikusan a =SZUM(A2:D2) képletre bővülő SZUM képletet szemléltet
  5. SZUM egyéni cellahivatkozásokkal vagy tartományokkal

    Vessen egy pillantást az alábbi képletre:

    • =SZUM(A1;A2;A3;B1;B2;B3)

    Ez a képlet ugyanannyi hibalehetőséget rejt sorok hozzáadásakor vagy törlésekor, ugyanazon okból kifolyólag. Biztonságosabb, ha tartományokat használ:

    • =SZUM(A1:A3;B1:B3)

    Ezek frissülnek sorok hozzáadásakor és törlésekor.

  1. Csak összeadni, kivonni, szorozni vagy osztani szeretnék számokat Tekintse meg a Matematikai alapműveletek az Excelben című videósorozatunkat, vagy olvassa el Az Excel használata számológépként című témakört.

  2. Hogyan jeleníthetek meg több vagy kevesebb tizedesjegyet? Jelölje ki a szóban forgó cellát vagy tartományt, a Ctrl+1 billentyűkombinációval nyissa meg a Cellák formázása párbeszédpanelt, és válassza a megfelelő formátumot a Szám lapon. Ezzel jelezheti a kívánt tizedeshelyek számát.

  3. Hogyan adhatok hozzá és vonhatok ki időértékeket? Időértékeket több különböző módon adhat össze vagy vonhat ki. Ha például a 8 és 12 óra közötti különbséget szeretné megkapni bérszámfejtési célokból, a következő képletet kell használnia: =("12:00"-"8:00")*24, amely kivonja a záró időpontból a kezdő időpontot. Vegye figyelembe, hogy az Excel az időértékeket a nap részeként számítja ki, ezért az órák összegének megkapásához 24-gyel való szorzás szükséges. Az első példában a =((B2-A2)+(D2-C2))*24 képletet használjuk a kezdéstől a befejezésig tartó órák összegének ebédszünet nélküli kiszámításához (összesen 8,5 óra).

    Ha csak órákat és perceket ad hozzá, és így szeretné megjeleníteni őket, akkor egyszerű összeadást végezhet a 24-gyel való szorzás nélkül. Ezért a második példában a =SZUM(A6:C6) képletet használjuk, mivel csak a hozzárendelt feladatok összes órájának és percének a számára van szükségünk (5:36, illetve 5 óra, 36 perc).

    Idő számítása

    További információ: Időértékek összegzése és kivonása.

  4. Hogyan számíthatom ki dátumok különbségét? Az időpontokhoz hasonlóan a dátumokat is összeadhatja és kivonhatja egymásból. Az alábbi példa kiszámítja, hogy hány napnyi különbség van két dátum között. A képlet itt egyszerűen =B2-A2. A legfontosabb szempont a dátumok és az időpontok számításával kapcsolatban, hogy a befejező dátummal vagy időponttal kell kezdeni, és abból kell kivonni a kezdő dátumot vagy időpontot.

    Dátumok közötti különbségek számítása

    A dátumokkal való munkáról bővebben a következő témakörben olvashat: Két dátum közötti különbség kiszámítása.

  5. Hogyan adhatom össze csak a látható cellákat? Néha, amikor manuálisan rejt el sorokat, vagy az AutoSzűrő használatával jelenít meg csak bizonyos adatokat, csak a látható cellákat is összegezni szeretné. Ehhez a RÉSZÖSSZEG függvényt használhatja. Ha összegsort használ egy Excel-táblázatban, a program az összegeket tartalmazó legördülő listában Ön által kiválasztott függvényt írja be automatikusan részösszegként. Erről bővebben az Adatok összegzése Excel-táblázatban című témakörben olvashat.

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Lásd még

További információ a SZUM függvényről

A SZUMHA függvény csak a megadott feltételnek megfelelő értékeket adja össze

A SZUMHATÖBB függvény csak a több feltételnek megfelelő értékeket adja össze

A DARABTELI függvény csak a megadott feltételnek megfelelő értékeket számolja meg

A DARABHATÖBB függvény csak a megadott összes feltételnek megfelelő értékeket számolja meg

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

Képletekben lévő hibák keresése és javítása

Matematikai és trigonometriai függvények

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?

Mi befolyásolta a felhasználói élményét?

Szeretne további visszajelzéssel élni? (Nem kötelező)

Köszönjük visszajelzését!

×