Tömbképletbeírásakor leggyakrabban egy cellatartományt kell használnia a munkalapon, de nem kell. A kapcsos zárójelek között tömbállandókat , a kapcsoszárójelek között a szerkesztőlécen beírandó értékeket is felhasználhatja: {}. Ezután nevet ad az állandónak, hogy könnyebben használható legyen.

A tömbképletekben és magukban is használhat állandókat.

  1. A tömbképletbe írjon be egy nyitó kapcsos zárójelet, a kívánt értékeket és egy záró kapcsos zárójelet. Példa: =SZUM(A1:E1*{1,2,3,4,5})

    Az állandó a kapcsos zárójelek ({)} alatt van, és igen, ezeket valóban kézzel kell begépelni.

  2. Írja be a képlet többi részét, és nyomja le a Ctrl+Shift+Enter billentyűkombinációt.

    A képlet a következőre hasonlít: {=SZUM(A1:E1*{1,2,3,4,5})}, és az eredmény így néz ki:


    SZUM képletbe ágyazott tömbállandó

    A képlet megszorozza az A1 és a B1 cellát 2-vel, így nem kell 1,2,3,4,5-öt a munkalap celláiba tenni.

Értékek beírása oszlopba állandó használatával

Ha egyetlen oszlopba (például a C oszlop három cellába) ír be értékeket, a következőt kell megadnia:

  1. Jelölje ki a használni kívánt cellákat.

  2. Írjon be egy egyenlőségjelet és az állandót. Az állandó értékeit pontosvessző helyett pontosvesszővel válassza el, és ha szöveget ír be, akkor idézőjelek közé kell tenni. Például: ={"1. negyedév";" 2. negyedév";" 3. negyedév"}

  3. Nyomja le a CTRL+SHIFT+ENTER billentyűkombinációt. Az állandó így néz ki:

    Szövegből álló függőleges tömbállandó

    Ebbe a ebbe a kifejezésbe a gyökérmakerek kifejezésében egydimenziós függőleges állandó áll.

Értékek beírása sorba állandó használatával

Ha gyorsan egyetlen sorba (például F1, G1 vagy H1 cellákba) ír be értékeket, a következőt kell megadnia:

  1. Jelölje ki a használni kívánt cellákat.

  2. Írjon be egy egyenlőségjelet és egy állandót, de ezúttal pontosvessző helyett vesszővel válassza el az értékeket. Például: ={1,2,3,4,5}

  3. Nyomja le a Ctrl+Shift+Enter billentyűkombinációt, és az állandó így néz ki:

    Egydimenziós vízszintes tömbállandó

    Ebbe a ebbe a szögbe ékesedő vízszintes állandókból áll.

Értékek beírása több oszlopba és sorba állandó használatával

  1. Jelölje ki a kívánt cellákat.

    Győződjön meg arról, hogy a kiválasztott sorok és oszlopok száma megegyezik az állandóban lévő értékek számával. Ha például az állandó adatokat fog írni négy oszlopba és három sorba, jelölje ki a kívánt számú oszlopot és sort.

  2. Írjon be egy egyenlőségjelet és az állandót. Ebben az esetben az egyes sorok értékeit vesszővel válassza el egymástól, és minden sor végén használjon pontosvesszőt. Például:

    ={1\2\3\4;5\6\7\8;9\10\11\12}

  3. Nyomja le a Ctrl+Shift+Enter billentyűkombinációt, és:

    Kétdimenziós tömbállandó

    Ebbe a ebbe a kétdimenziós állandóba oszlopok és sorok töltnek be. Ha arra kíváncsi, hogy nem tud háromdimenziós állandót létrehozni, ami azt jelenti, hogy nem ágyazhat egy állandót egy másikba.

Állandó használata képletben

Most, hogy már ismeri a tömbállandókat, az alábbi működő példát mutatjuk be.

  • Írja be (vagy másolja és illessze be) a képletet egy üres cellába, majd nyomja le a Ctrl+Shift+Enter billentyűkombinációt:

    =SZUM(A1:E1*{1\2\3\4\5})

    Az A3 cellában megjelenik a 85 érték.

    Mi történt? Az A1 cellában lévő értéket megszorozza 1-vel, a B2 cella értékét 2-vel, és így tovább, majd a SZUM függvény hozzáadja ezeket az eredményeket. A képletet megadhatja a következő képlettel is: =SZUM(A1*1,B1*2,C1*3,D1*4,E1*5)

Szükség esetén mindkét értékhalmazt megadhatja tömbállandóként:

=SZUM({3\4\5\6\7}*{1\2\3\4\5})

Ehhez másolja a képletet a vágólapra, jelöljön ki egy üres cellát, illessze be a képletet a szerkesztőlécre, és nyomja le a Ctrl+Shift+Enter billentyűkombinációt. Ugyanaz az eredmény látható.

Megjegyzések: Keresse meg az alábbi problémákat, ha az állandók nem működnek:

  • Ügyeljen arra, hogy az értékeket a megfelelő karakterrel válassza el egymástól. Ha kihagy egy vesszőt vagy egy pontosvesszőt, vagy rossz helyre tesz egyet, előfordulhat, hogy a tömbállandó nem megfelelő, vagy figyelmeztetés jelenik meg.

  • Nem kizárt, hogy a kijelölt cellatartomány nem felel meg az állandóban lévő elemek számának. Ha például kijelöl egy oszlopban hat cellát egy ötcellás állandóval való használatra, a #N/A hiba jelenik meg az üres cellában. Ha nem jelöl ki elegendő cellát, Excel kihagyja azokat az értékeket, amelyekhez nem tartozik cella.

  • További információ a tömbképletekről:

Vissza a lap tetejére

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?

Mi befolyásolta a felhasználói élményét?

Szeretne további visszajelzéssel élni? (Nem kötelező)

Köszönjük visszajelzését!

×