Jelenségek
Amikor megpróbálja elindítani a Microsoft Dynamics AX 4.0-ügyfélprogramot, a következő hibaüzenet jelenik meg:
Nem sikerült létrehozni a kapcsolatot
A probléma oka
A problémának az alábbi okai lehetnek:
-
Az Application Object Server (AOS) szolgáltatás nem fut. Lásd az 1. felbontást a "Megoldás" szakaszban.
-
A Microsoft Dynamics AX-ügyfél nincs beállítva a megfelelő TCP/IP-port használatára. Lásd a "Megoldás" című szakasz 2. felbontását.
-
Az AOS szolgáltatás verziója nem egyezik meg a Microsoft Dynamics AX-ügyfél verziójával. Lásd a "Felbontás" szakasz 3. felbontását.
-
Az ügyfél munkaállomásának nincs hálózati hozzáférése. Vagy az ügyfél munkaállomása nem tud csatlakozni az AOS-kiszolgálóhoz. Lásd a 4. felbontást a "Megoldás" szakaszban.
-
A Microsoft Dynamics AX-ügyfél tűzfalhoz vagy több tartományhoz kapcsolódik. Lásd az 5. felbontást a "Megoldás" szakaszban.
-
A helyi házirend nem biztosít közvetlenül az ugyanazon hálózatban található AOS-ügyfelek számára "Hozzáférés a számítógépről a számítógépről" engedélyt. Lásd a "Felbontás" szakasz 6. felbontását.
Megoldás
A probléma megoldásához használja a megfelelő megoldást.
1. felbontás
A probléma megoldásához indítsa el az AOS szolgáltatást. Ezt a következőképpen teheti meg:
-
Kattintson a Startgombra, mutasson a Minden program, majd a Felügyeleti eszközök pontra,és kattintson a Szolgáltatások elemre.
-
Keresse meg a Microsoft Dynamics AOS (Application Object Server) szolgáltatást.
-
Ha a szolgáltatás nem fut, kattintson a jobb gombbal a szolgáltatásra, majd kattintson a Start gombra.
Megjegyzés: Az AOS szolgáltatás neve a következő formátumot használja:Dynamics Server$ példányszámAOS-példány neve
2. felbontás
A probléma megoldásához ellenőrizze, hogy a Microsoft Dynamics AX Server Configuration segédprogram a megfelelő TCP/IP-portot használja-e. Ezután ellenőrizze, hogy a megfelelő port van-e használva a Microsoft Dynamics AX-ügyfélhez. Ezt a következőképpen teheti meg:
-
Kattintson a Startgombra, mutasson a Minden program, majd a Felügyeleti eszközök pontra,majd kattintson a Microsoft Dynamics AX Server Configuration Utility elemre.
-
Kattintson az AOS-kiszolgáló megfelelő példányára, majd a megfelelő konfigurációra.
-
Kattintson az Application Object Server (Alkalmazásobjektum-kiszolgáló) fülre.
-
Ellenőrizze, hogy helyes-e a portszám a TCP-/IP-port mezőben, majd kattintson az OK gombra.
-
Kattintson a Startgombra, mutasson a Minden program, a Felügyeleti eszközök pontra,majd kattintson a Microsoft Dynamics AX configuration Utility elemre.
-
Kattintson a Kapcsolat fülre.
-
Jegyezze fel a TCP/IP-port számát. Ha az AOS-kiszolgáló neve és portszáma helytelen, írja be a helyes AOS-kiszolgálónevet. Ezután írja be a 4. lépésben ellenőrzött portszámot.
-
Kattintson az OK gombra.
3. felbontás
A probléma megoldásához ellenőrizze, hogy az AOS-szolgáltatás verziója megegyezik-e a Microsoft Dynamics AX ügyfélprogram verziójával. Ehhez kövesse az alábbi lépéseket:
-
Keresse meg a Microsoft Dynamics AX-ügyfél verzióját. Ezt a következőképpen teheti meg:
-
A Súgó menüben kattintson A Microsoft Dynamics AX szolgáltatásról elemre.
-
Figyelje meg a kernel verzióját és az alkalmazás verzióját.
-
-
Keresse meg az AOS szolgáltatás verzióját. Ezt a következőképpen teheti meg:
-
Keresse meg Ax32Serv.exe fájlt az AOS-kiszolgálón.
Megjegyzés: Alapértelmezés szerint Ax32Serv.exe fájl a következő mappában található:C:\Microsoft Dynamics AX\40\Server\AX40SP1\Bin
-
Kattintson a jobb gombbal a Ax32Serv.exe, majd kattintson a Tulajdonságok parancsra.
-
A Tulajdonságok párbeszédpanelen kattintson a Részletek elemre.
-
A Részletek lapon figyelje meg az AOS szolgáltatás verzióját a Fájlverzió mezőben.
-
4. felbontás
A probléma a következő lépésekkel hárítható el:
-
Kattintson a Start menü Futtatás parancsára, írja be a cmd parancsot a Megnyitás mezőbe, majd kattintson az OK gombra.
-
A parancssorban futtassa az alábbi parancsot.
ping <computer name>
Ha a parancs nem sikerül, vagy ha a parancs nem a megfelelő értékeket adja vissza, az ügyfél munkaállomásának nincs hálózati hozzáférése.
5. felbontás
A probléma megoldásához kövesse az alábbi lépéseket.
Megjegyzés: Az alábbi lépések övéhez a Domain Admins Group tagnak kell lennie.-
Kattintson a Startgombra, mutasson a Felügyeletieszközök , majd a Helyi biztonsági Gépház pontra, mutasson a Helyi házirendek pontra, majd kattintson a Felhasználói jogok hozzárendelése elemre az AOS-rendszerben.
-
Kattintson A számítógép elérése a hálózatról elemre.
-
Jelölje be a Házirend-beállítások megadása jelölőnégyzetet.
-
Vegye fel az AOS-hez csatlakoztatni kívánt felhasználókat, és vegye fel az AOS-hez csatlakoztatni kívánt felhasználói csoportokat.