Tabel AsyncOperationBase dan WorkflowLogBase tumbuh sangat besar dan masalah kinerja terjadi ketika Anda menggunakan banyak alur kerja di Microsoft Dynamics CRM 4.0

Berlaku Untuk
Dynamics CRM 4.0

Gejala

Anda menggunakan banyak alur kerja di Microsoft Dynamics CRM 4.0. Tabel AsyncOperationBase dan WorkflowLogBase tumbuh sangat besar, dan masalah kinerja terjadi.

Penyebab

Masalah ini terjadi karena, ketika aturan alur kerja ditembakkan, contoh alur kerja dan catatan alur kerja dibuat dalam tabel AsyncOperationBase dan WorkflowLogBase database MSCRM. Namun, ketika contoh alur kerja selesai, catatan alur kerja tetap ada dalam database. Oleh karena itu, tabel AsyncOperationBase dan WorkflowLogBase terus bertambah. Pada akhirnya, kinerja menurun.

Catatan Properti AsyncOperationType untuk rekaman ini diatur ke 10.

Resolusi

Masalah ini telah diperbaiki dalam rollup pembaruan kumulatif terbaru untuk Microsoft Dynamics CRM 4.0.
  Untuk informasi selengkapnya, klik nomor artikel berikut ini untuk menampilkan artikel di Pangkalan Pengetahuan Microsoft:

949256 Microsoft Dynamics CRM pembaruan dan hotfix 4.0

Penting Bagian ini, metode, atau tugas berisi langkah-langkah yang memberi tahu Anda cara mengubah registri. Namun, masalah serius mungkin terjadi jika Anda salah mengubah registri. Oleh karena itu, pastikan Anda mengikuti langkah-langkah ini dengan hati-hati. Untuk perlindungan tambahan, cadangkan registri sebelum Anda mengubahnya. Kemudian, registri dapat dipulihkan jika terjadi masalah. Untuk informasi selengkapnya tentang cara mencadangkan dan memulihkan registri, klik nomor artikel berikut ini untuk menampilkan artikel di Pangkalan Pengetahuan Microsoft:

322756 Cara mencadangkan dan memulihkan registri di Windows

Setelah Anda menginstal hotfix, agar kami mengaktifkan hotfix ini untuk Anda, masuk ke bagian "Perbaiki untuk saya". Jika Anda lebih suka mengaktifkan hotfix sendiri, masuk ke bagian "Biarkan saya memperbaikinya sendiri".

Perbaiki untuk saya

            
Untuk mengaktifkan hotfix secara otomatis, klik tombol atau tautan Perbaiki . Lalu klik Jalankan dalam kotak dialog Unduhan File , dan ikuti langkah-langkah dalam panduan Perbaiki .

            
            
Catatan

  • Panduan ini mungkin hanya dalam bahasa Inggris. Namun, perbaikan otomatis juga berfungsi untuk windows versi bahasa lain.
  • Jika Anda tidak berada di komputer yang mengalami masalah, simpan solusi Fix it ke flash drive atau CD lalu jalankan di komputer yang bermasalah.

Lalu, masuk ke bagian "Apakah ini memperbaiki masalah?".

Biarkan saya memperbaikinya sendiri

Untuk mengaktifkan hotfix ini, ikuti langkah-langkah ini:

  1. Klik Mulai, klik Jalankan, ketik regedit, lalu klik
    Baik, oke.

  2. Di Editor Registri, temukan subkey berikut:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

  3. Tentukan apakah entri registri DWORD yang bernama AsyncRemoveCompletedWorkflows ada. Data nilai entri registri AsyncRemoveCompletedWorkflows harus 1.

  4. Jika entri registri AsyncRemoveCompletedWorkflows tidak ada, tambahkan entri. Untuk melakukannya, ikuti langkah-langkah berikut:

    1. Klik kanan MSCRM, arahkan ke
      Baru, klik Nilai DWORD, lalu ketik
       AsyncRemoveCompletedWorkflows di
      Kotak nama .

    2. Klik ganda
      AsyncRemoveCompletedWorkflows, lalu ketik
       1 dalam kotak Data nilai .

    3. Klik Mulai, klik
      Jalankan, ketik iisreset, lalu klik
      Baik, oke.

      Catatan Jika nilai dalam kotak Data nilai untuk nilai DWORD AsyncRemoveCompletedWorkflows kembali ke 0, Microsoft Dynamics CRM akan terus mempertahankan catatan Alur Kerja dalam database meskipun tugas sudah selesai.

Catatan Hotfix ini proaktif saja. Oleh karena itu, ketika hotfix diinstal dan diaktifkan, hanya catatan alur kerja baru yang dihapus secara otomatis. Jika tabel AsyncOperationBase dan WorkflowLogBase sudah besar karena catatan alur kerja ini, Anda harus melakukan pembersihan tabel ini menggunakan skrip pembersihan Microsoft SQL Server yang disertakan dalam artikel Pangkalan Pengetahuan Microsoft berikut ini:

968520 Kinerja lambat jika tabel AsyncOperationBase menjadi terlalu besar dalam Microsoft Dynamics CRM 4,0

Apakah masalah ini telah diperbaiki?

  • Periksa apakah masalah telah diperbaiki. Jika masalah telah diperbaiki, Anda telah selesai dengan bagian ini. Jika masalah belum diperbaiki, Anda dapat menghubungi dukungan.
  • Kami akan menghargai tanggapan Anda. Untuk memberikan umpan balik atau melaporkan masalah dengan solusi ini, silakan tinggalkan komentar di blog "Perbaiki untuk saya" atau kirimkan pesan email kepada kami.

Informasi Selengkapnya

Untuk informasi selengkapnya tentang terminologi pembaruan perangkat lunak, klik nomor artikel berikut ini untuk menampilkan artikel di Pangkalan Pengetahuan Microsoft:

824684 Deskripsi terminologi standar yang digunakan untuk menjelaskan pembaruan perangkat lunak Microsoft Untuk informasi selengkapnya tentang hotfix perangkat lunak CRM Solusi Microsoft Business dan pembaruan terminologi paket, klik nomor artikel berikut ini untuk menampilkan artikel di Pangkalan Pengetahuan Microsoft:

887283 hotfix perangkat lunak CRM Solusi Microsoft Business dan memperbarui standar penamaan paket