Gejala

Ketika Anda mencoba menginstal Microsoft .NET Framework 4.7 di komputer yang menjalankan Windows 7 Paket Layanan 1 (SP1), Windows Server 2008 R2 SP1, atau Windows Server 2012, penyetelan diblokir dan tidak dapat dilanjutkan.

.netFramework

Masalah ini terjadi saat komputer tidak memiliki pembaruan D3DComplier (D3DCompiler_47.dll) yang terinstal.

Penyebab

.NET Framework 4.7 di Windows 7 SP1, Windows Server 2008 R2 SP1, dan Windows Server 2012 memiliki ketergantungan baru pada %windir%\system32\D3DCompiler_47.dll file untuk WPF. File ini harus terinstal sebelum produk .NET Framework 4.7 dapat diinstal.

Penyelesaian Masalah

Untuk mengatasi masalah ini, instal pembaruan d3dcompiler dari tautan berikut sebelum Anda menginstal .NET Framework 4.7. Pembaruan ini juga tersedia di Katalog Pembaruan Microsoft dan melalui Windows Update.

  • Pada Windows 7 SP1 x86, gunakanĀ tautan ini.

  • Pada Windows 7 SP1 atau Windows Server 2008 R2 x64, gunakan tautan ini.

  • Pada Windows Server 2012 x64, gunakan tautan ini.

Status

Microsoft telah mengonfirmasi bahwa ini adalah masalah dalam produk Microsoft yang terdaftar dalam bagian "Berlaku untuk".

Perlu bantuan lainnya?

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung Microsoft Insider

Apakah informasi ini bermanfaat?

Seberapa puaskah Anda dengan kualitas terjemahannya?

Apa yang memengaruhi pengalaman Anda?

Ada umpan balik tambahan? (Opsional)

Terima kasih atas umpan balik Anda!

×