Sintomi
Quando si tenta di aggiornare i dati in una cartella di lavoro di Microsoft Excel che si collega a un database di Microsoft Access, è possibile che venga visualizzato il messaggio di errore seguente:
Impossibile trovare l'ISAM installabile
Questo problema si verifica se la cartella di lavoro è stata aperta e aggiornata in precedenza in una versione più recente di Excel.
Causa
Quando una cartella di lavoro di Excel collegata a un database di Access viene aperta in una versione successiva di Excel, i parametri possono essere aggiunti alla stringa di connessione. Se la versione precedente di Excel non riconosce questi parametri, viene attivato il messaggio di errore.
Risoluzione
Per risolvere il problema, eliminare i nuovi parametri dalla stringa di connessione. A tal fine, attenersi alla seguente procedura:
-
Aprire la cartella di lavoro di Excel.
-
Sulla barra multifunzione dati fare clic sul pulsante connessioni .
-
Nella finestra di dialogo Connessioni cartella di lavoro selezionare la connessione al database di Access e quindi fare clic su Proprietà.
-
Nella finestra di dialogo Proprietà connessione fare clic sulla scheda definizione .
-
Eliminare i parametri seguenti dalla stringa di connessione:
Jet OLEDB: bypassare la convalida UserInfo = false; Jet OLEDB: Limited DB Caching = false; Jet OLEDB: bypassare la convalida di ChoiceField = false
-
Nella finestra di dialogo Proprietà connessione fare clic su OK. A questo punto i dati devono essere aggiornati.
-
Nella finestra di dialogo Connessioni cartella di lavoro fare clic su Chiudie quindi salvare la cartella di lavoro aggiornata.
Ulteriori informazioni
Se si aggiorna e si salva la cartella di lavoro in una versione più recente di Excel, il problema verrà ripresentato.