È possibile utilizzare la funzione SE.ERRORE per individuare e gestire gli errori in una formula. SE.ERRORE restituisce un valore specificato dall'utente se la formula restituisce un errore. In caso contrario, restituisce il risultato della formula.

Sintassi

SE.ERRORE(valore, valore_se_errore)

Gli argomenti della sintassi della funzione SE.ERRORE sono i seguenti:

  • valore    Obbligatorio. Argomento in cui viene verificata la presenza di un errore.

  • valore_se_errore    Obbligatorio. Valore da restituire se la formula fornisce come risultato un errore. Vengono valutati i tipi di errore seguenti: #N/D, #VALORE!, #RIF!, #DIV/0!, #NUM!, #NOME? o #NULLO!.

Osservazioni

  • Se valore o valore_se_errore è una cella vuota, viene considerato da SE.ERRORE come un valore stringa vuoto ("").

  • Se valore è una formula in forma di matrice, SE.ERRORE restituirà una matrice di risultati per ogni cella nell'intervallo specificato nel valore. Vedere il secondo esempio riportato di seguito.

Esempi

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO.

Quota

Unità vendute

210

35

55

0

23

Formula

Descrizione

Risultato

=SE.ERRORE(A2/B2; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento (210 diviso 35), non trova errori e quindi restituisce i risultati della formula.

6

=SE.ERRORE(A3/B3; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento (55 diviso 0), trova un errore di divisione per 0 e quindi restituisce valore_se_errore.

Errore nel calcolo

=SE.ERRORE(A4/B4; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento ("" diviso 23), non trova errori e quindi restituisce i risultati della formula.

0

Esempio 2

Quota

Unità vendute

Rapporto

210

35

6

55

0

Errore nel calcolo

23

0

Formula

Descrizione

Risultato

=C2

Verifica la presenza di un errore nella formula nel primo argomento nel primo elemento della matrice (A2/B2 o 210 diviso 35), non trova errori e quindi restituisce il risultato della formula.

6

=C3

Verifica la presenza di un errore nella formula nel primo argomento nel secondo elemento della matrice (A3/B3 o 55 diviso 0), trova un errore di divisione per 0 e quindi restituisce valore_se_errore.

Errore nel calcolo

=C4

Verifica la presenza di un errore nella formula nel primo argomento nel terzo elemento della matrice (A4/B4 o "" diviso 23), non trova errori e quindi restituisce il risultato della formula.

0

Nota: se si ha una versione corrente di Microsoft 365, è possibile immettere la formula nella cella superiore sinistra dell'intervallo di output, quindi premere INVIO per confermare la formula come formula di matrice dinamica. In caso contrario, è necessario inserire la formula come formula di matrice legacy selezionando prima l'intervallo di output, inserire la formula nella cella superiore sinistra dell'intervallo di output, quindi premere CTRL+MAIUSC+INVIO per confermarla. Excel inserisce automaticamente parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule di matrice: indicazioni ed esempi.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Office Insider

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×