Quando si hanno a che fare con funzioni di matrice fuoriuscite, ad esempio SEQUENZA,è possibile fare riferimento all'intero intervallo di riversamento posizionando l'operatore di intervallo fuoriuscito (#) dopo l'intervallo. Nell'esempio seguente è presente =SEQUENZA(10) nella cella A2, che si riversa in A2:A11. Nella cella C2 è presente la formula =SOMMA(A2#), che equivale a =SOMMA(A2:A11), poiché A2:A11 è l'intervallo di riversamento della formula in A2. Restituisce 55, la somma di tutti i valori nell'intervallo di matrice fuoriuscito.

Se l'intervallo di riversamento aumenta o si contrae, ad esempio modificando la formula in A2 in =SEQUENZA(20), la formula SOMMA lo rifletterà automaticamente. Se si tratta di un intervallo normale, è necessario immettere =SOMMA(A2:A11) e aggiornarlo manualmente se l'intervallo di riversamento cambia. Spesso si potrebbe non rendersi conto se un intervallo è cambiato, quindi questo può rimuovere molte ipotesi.

Operatore di intervallo fuoriuscito per fare riferimento a interi intervalli di matrice fuoriusciti con =SOMMA(A2#).

Ecco un altro esempio di uso dell'operatore di intervallo fuoriuscito in diverse formule, in cui si crea un elenco univoco da un elenco di nomi, si ordina l'elenco e quindi si filtrano i nomi di lunghezza superiore a 3 caratteri. Abbiamo =ORDINA(C2#) nella cella E2 e =FILTRO(C2#,LUNGHEZZA(C2#)>3) nella cella G2.

Operatore di intervallo fuoriuscito (#) per fare riferimento a un intero intervallo di matrice fuoriuscito con =FILTRO(C2#,LUNGHEZZA(C2#)>3)

Limitazioni note

L'operatore di intervallo fuoriuscito non supporta riferimenti a cartelle di lavoro chiuse. Restituirà invece un #REF! . L'apertura della cartella di lavoro a cui si fa riferimento risolve il problema.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

Funzione FILTRO

Funzione MATR.CASUALE

Funzione SEQUENCE

Funzione SORT

Funzione DATI.ORDINA.PER

Funzione UNICI

Errori #SPILL! in Excel

Matrici dinamiche e il comportamento di matrice espansa

Operatore di intersezione implicita: @

Serve aiuto?

Amplia le tue competenze

Esplora i corsi di formazione >

Ottieni in anticipo le nuove caratteristiche

Partecipa a Microsoft Insider >

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×