Gli operatori specificano il tipo di calcolo da eseguire sugli elementi di una formula, ad esempio addizione, sottrazione, moltiplicazione o divisione. In questo articolo verrà indicato l'ordine predefinito in cui gli operatori agiranno in base agli elementi di un calcolo. Si imparerà anche a modificare questo ordine usando le parentesi.

Tipi di operatore

Esistono quattro tipi diversi di operatore di calcolo, ovvero aritmetici, di confronto, di concatenazione testo e di riferimento.

Per eseguire operazioni matematiche di base, ad esempio addizione, sottrazione o moltiplicazione o per combinare numeri, e produrre risultati numerici, usare gli operatori aritmetici in questa tabella.

Operatore aritmetico

Significato

Esempio

+ (segno di addizione)

Addizione

=3+3

– (segno meno)

Sottrazione
Negazione

=3–1
=–1

Un asterisco (*)

Moltiplicazione

=3*3

/ (segno di divisione)

Divisione

=3/3

% (segno di percentuale)

Percentuale

=20%

^ (accento circonflesso)

Elevamento a potenza

=

Con gli operatori nella tabella seguente, è possibile confrontare due valori. Quando due valori vengono confrontati usando questi operatori, il risultato è un valore logico VERO o FALSO.

Operatore di confronto

Significato

Esempio

= (segno di uguale)

Uguale a

=A1=B1

> (segno di maggiore)

Maggiore di

=A1>B1

< (segno di minore)

Minore di

=A1<B1

>= (segno di maggiore o uguale a)

Maggiore di o uguale a

=A1>=B1

<= (segno di minore o uguale a)

Minore o uguale a

=A1<=B1

<> (segno di diverso da)

Diverso da

=A1<>B1

Usare la e commerciale (&) per unire o concatenare una o più stringhe di testo per produrre una singola porzione di testo.

Operatore di testo

Significato

Esempio

& (e commerciale)

Connette, o concatena, due valori per produrre un valore di testo continuo.

="Nord"&"vento"

Combinare intervalli di celle per i calcoli con questi operatori.

Operatore di riferimento

Significato

Esempio

: (due punti)

Operatore di intervallo, genera un riferimento a tutte le celle comprese tra due riferimenti, inclusi i due riferimenti stessi

=SOMMA(B5:B15)

; (punto e virgola)

Operatore di unione, che combina più riferimenti in un unico riferimento.

=SOMMA(B5:B15,D5:D15)

(spazio)

Operatore di intersezione, che produce un riferimento alle celle comuni ai due riferimenti.

=SOMMA(B7:D7 C6:C8)

# (cancelletto)

Il simbolo # viene usato in diversi contesti:

  • Usato come parte di un nome di errore.

  • Usato per indicare spazio insufficiente per il rendering. Nella maggior parte dei casi, è possibile allargare la colonna finché il contenuto non viene visualizzato correttamente.

  • Operatore di intervallo fuoriuscito, usato per fare riferimento a un intero intervallo in una formula di matrice dinamica.

  • Errori #VALORE!

  • #####

  • =SOMMA(A2#)

@ (at)

Operatore di riferimento, usato per indicare l'intersezione implicita in una formula. 

=@A1:A10

=SOMMA(Tabella1[@[gennaio]:[dicembre]])

Ordine di esecuzione delle operazioni nelle formule

In alcuni casi, l'ordine in cui viene eseguito il calcolo può influire sul valore restituito della formula, quindi è importante comprendere l'ordine e come è possibile modificare l'ordine per ottenere i risultati previsti.

Le formule calcolano i valori in un ordine specifico. Una formula in Excel inizia sempre con un segno di uguale (=). Il segno di uguale indica Excel che i caratteri che seguono costituiscono una formula. Dopo questo segno di uguale, può essere presente una serie di elementi da calcolo ,ovvero gli operandi, separati da operatori di calcolo. Excel calcola la formula da sinistra a destra, in base a un ordine specifico per ogni operatore nella formula.

Se in una formula si combinano diversi operatori, Excel esegue le operazioni nell'ordine indicato nella tabella seguente. Se una formula contiene operatori dotati della stessa precedenza, come quelli di moltiplicazione e divisione, essi verranno calcolati da sinistra a destra.

Operatore

Descrizione

: (due punti)

(spazio singolo)

; (punto e virgola)

Operatori di riferimento

Negazione (–1)

%

Percentuale

^

Elevamento a potenza

* e /

Moltiplicazione e divisione

+ e –

Addizione e sottrazione

&

Concatenazione di stringhe

=
< >
<=
>=
<>

Confronto

Per modificare l'ordine del calcolo, racchiudere tra parentesi la parte della formula che si desidera calcolare prima. Ad esempio, la formula seguente restituisce il valore 11, perché Excel la moltiplicazione prima dell'addizione. La formula moltiplica prima 2 per 3 e quindi aggiunge 5 al risultato.

=5+2*3

Se invece si usano parentesi per modificare la sintassi, Excel somma 5 e 2 e quindi moltiplica il risultato per 3 per produrre 21.

=(5+2)*3

Nell'esempio seguente le parentesi che racchiudono la prima parte della formula costringono Excel a calcolare prima B4+25 e quindi dividere il risultato per la somma dei valori nelle celle D5, E5 e F5.

=(B4+25)/SOMMA(D5:F5)

Guardare questo video sull'ordine degli operatori in Excel per saperne di più.

Come Excel i valori nelle formule

Quando si immette una formula, Excel tipi specifici di valori per ogni operatore. Se si immette un tipo di valore diverso da quello previsto, Excel convertire il valore.

La formula

Produce

Spiegazione

= "1"+"2"

3

Quando si usa un segno più (+), Excel i numeri nella formula. Anche se le virgolette significano che "1" e "2" sono valori di testo, Excel converte automaticamente i valori di testo in numeri.

= 1+"$4,00"

5

Quando una formula prevede un numero, Excel converte il testo se è in un formato che in genere verrebbe accettato per un numero.

= "1/6/2001"-"1/5/2001"

31

Excel interpreta il testo come una data nel formato mm/gg/a, converte le date in numeri seriali e quindi calcola la differenza tra di esse.

=RT.SQ ("8+1")

Errori #VALORE!

Excel non è possibile convertire il testo in un numero perché il testo "8+1" non può essere convertito in un numero. È possibile usare "9" o "8"+"1" invece di "8+1" per convertire il testo in un numero e restituire il risultato di 3.

= "A"&VERO

ATRUE

Quando è previsto testo, Excel i numeri e i valori logici, ad esempio VERO e FALSO, in testo.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Quanto ti soddisfa la qualità della traduzione?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×