Accedi a Microsoft
Accedi o crea un account.
Salve,
Select a different account.
Hai più account
Scegli l'account con cui vuoi accedere.

Molte aziende , come le banche, i ristoranti e le società di servizi postali, sanno quali saranno i requisiti di lavoro nei diversi giorni della settimana e hanno bisogno di un metodo per pianificare in modo efficiente la propria forza lavoro. È possibile usare il Excel Risolutore per creare una pianificazione del personale in base a tali requisiti.

Pianificare la forza lavoro per soddisfare le esigenze di lavoro (esempio)

L'esempio seguente illustra come usare il Risolutore per calcolare i requisiti di personale.

I processi bancari contoso controllano 7 giorni alla settimana. Il numero di dipendenti necessari ogni giorno per elaborare i controlli è indicato nella riga 14 del foglio Excel foglio di lavoro illustrato di seguito. Ad esempio, il martedì sono necessari 13 lavoratori, 15 il mercoledì e così via. Tutti i dipendenti della banca lavorano 5 giorni consecutivi. Qual è il numero minimo di dipendenti che la banca può avere e che soddisfa ancora i requisiti di manodopera?

Dati usati nell'esempio

  1. Per iniziare, identificare la cella obiettivo, modificare le celle e i vincoli per il modello risolutore.

    Nota: La cella obiettivo è detta cella di destinazione in Excel 2007.

    • Cella Obiettivo: ridurre al minimo il numero totale di dipendenti.

    • Celle variabili: numero di dipendenti che iniziano a lavorare (il primo di cinque giorni consecutivi) ogni giorno della settimana. Ogni cella che cambia deve essere un numero intero non negativo.

    • Vincoli: per ogni giorno della settimana, il numero di dipendenti che lavorano deve essere maggiore o uguale al numero di dipendenti necessari. (Numero di dipendenti che lavorano) >=(Dipendenti necessari)

  2. Per configurare il modello, è necessario tenere traccia del numero di dipendenti che lavorano ogni giorno. Iniziare immettendo i valori di valutazione per il numero di dipendenti che iniziano il turno di cinque giorni ogni giorno nell'intervallo di celle A5:A11. Ad esempio, in A5 immettere 1 per indicare che 1 dipendente inizia a lavorare il lunedì e lavora dal lunedì al venerdì. Immettere i dipendenti obbligatori di ogni giorno nell'intervallo C14:I14.

  3. Per tenere traccia del numero di dipendenti che lavorano ogni giorno, immettere 1 o 0 in ogni cella dell'intervallo C5:I11. Il valore 1 in una cella indica che i dipendenti che hanno iniziato a lavorare il giorno indicato nella riga della cella stanno lavorando al giorno associato alla colonna della cella. Ad esempio, l'1 nella cella G5 indica che i dipendenti che hanno iniziato a lavorare il lunedì stanno lavorando il venerdì; lo 0 nella cella H5 indica che i dipendenti che hanno iniziato a lavorare il lunedì non lavorano il sabato.

  4. Per calcolare il numero di dipendenti che lavorano ogni giorno, copiare la formula =MATR.SOMMA.PRODOTTO($A$5:$A$11,C5:C11) da C12 a D12:I12. Ad esempio, nella cella C12 questa formula restituisce =A5+A8+A9+A10+A11, che equivale a (Numero a partire dal lunedì)+ (Numero a partire dal giovedì)+(Numero a partire dal venerdì)+(Numeroa partire dal sabato)+ (Numero a partire da domenica). Questo totale è il numero di persone che lavorano il lunedì.

  5. Dopo aver calcolato il numero totale di dipendenti nella cella A3 con la formula =SOMMA(A5:A11), è possibile immettere il modello nel Risolutore come illustrato di seguito.

    Finestra di dialogo Parametri risolutore

  6. Nella cella obiettivo (A3) si vuole ridurre al minimo il numero totale di dipendenti. Il vincolo C12:I12>=C14:I14 assicura che il numero di dipendenti che lavorano ogni giorno sia almeno uguale al numero necessario per quel giorno. Il vincolo A5:A11=integer assicura che il numero di dipendenti che iniziano a lavorare ogni giorno sia un numero intero. Per aggiungere questo vincolo, fare clic su Aggiungi nella finestra di dialogo Parametri risolutore e immettere il vincolo nella finestra di dialogo Aggiungi vincolo (illustrata di seguito).

    Finestra di dialogo Modifica vincoli

  7. È anche possibile selezionare le opzioni Presuppongi modello lineare e Presuppongi non negativo per le celle che cambiano facendo clic su Opzioni nella finestra di dialogo Parametri risolutore e quindi selezionando le caselle di controllo nella finestra di dialogo Opzioni risolutore.

  8. Fare clic su Risolvi. Verrà visualizzato il numero ottimale di dipendenti per ogni giorno.

    In questo esempio è necessario un totale di 20 dipendenti. Un dipendente inizia il lunedì, tre iniziano il martedì, quattro il giovedì, uno il venerdì, due il sabato e nove il lunedì.

    Si noti che questo modello è lineare perché la cella obiettivo viene creata aggiungendo celle variabili e il vincolo viene creato confrontando il risultato ottenuto aggiungendo il prodotto di ogni cella che cambia per una costante (1 o 0) al numero di lavoratori richiesto.

Inizio pagina

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

Caricare il componente aggiuntivo Risolutore in Excel

Ottenere i modelli di pianificazione Microsoft

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Office Insider

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×