KB2345451 - Aggiornamento cumulativo 4 per SQL Server 2008 R2

Si applica a
SQL Server 2008 R2 Datacenter SQL Server 2008 R2 Developer SQL Server 2008 R2 Enterprise SQL Server 2008 R2 Express SQL Server 2008 R2 Express with Advanced Services SQL Server 2008 R2 Standard SQL Server 2008 R2 Standard Edition for Small Business SQL Server 2008 R2 Web SQL Server 2008 R2 Workgroup

INTRODUZIONE

L'aggiornamento cumulativo 4 contiene correzioni rapide per i problemi di Microsoft SQL Server 2008 R2 che sono stati risolti dopo il rilascio di SQL Server 2008 R2.

Nota: la build di questo pacchetto di aggiornamento cumulativo è nota anche come build 10.50.1746.0.

È consigliabile testare gli hotfix prima di distribuirli in un ambiente di produzione. Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione precedente della correzione di SQL Server 2008 R2. Si consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

981356 Le build SQL Server 2008 R2 rilasciate dopo il rilascio di SQL Server 2008 R2

Note importanti sul pacchetto di aggiornamento cumulativo

  • Gli aggiornamenti rapidi inclusi in questo pacchetto di aggiornamento cumulativo sono inclusi in SQL Server 2008 R2 Service Pack 1 (SP1).
  • Gli hotfix per SQL Server 2008 R2 sono ora multilingue. Di conseguenza, è disponibile un solo pacchetto di aggiornamenti rapidi cumulativo per tutte le lingue.
  • Un pacchetto di hotfix cumulativo include tutti i pacchetti di componenti. Il pacchetto di aggiornamento cumulativo aggiorna solo i componenti installati nel sistema.

Altre informazioni

Come ottenere l'aggiornamento cumulativo 4 per SQL Server 2008 R2

Un pacchetto di aggiornamento cumulativo supportato è ora disponibile da Microsoft. Tuttavia, ha lo scopo di correggere solo i problemi descritti in questo articolo. Applicalo solo ai sistemi che riscontrano questi problemi specifici. Questo pacchetto di aggiornamento cumulativo potrebbe essere sottoposto a ulteriori test. Pertanto, se nessuno di questi problemi è gravemente colpito, è consigliabile attendere il successivo Service Pack di SQL Server 2008 R2 contenente gli aggiornamenti rapidi inclusi in questo pacchetto di aggiornamento cumulativo.

Se l'aggiornamento cumulativo è disponibile per il download, all'inizio di questo articolo della Knowledge Base è presente una sezione "Download dell'aggiornamento rapido disponibile". Se questa sezione non viene visualizzata, contattare il servizio supporto tecnico Microsoft per ottenere il pacchetto di aggiornamento cumulativo.

Nota: se si verificano ulteriori problemi o è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di servizio separata. I normali costi di supporto verranno applicati alle domande e ai problemi di supporto aggiuntivi che non rientrano in questo specifico pacchetto di aggiornamento cumulativo. Per un elenco completo dei numeri di telefono del servizio clienti e del supporto tecnico Microsoft o per creare una richiesta di servizio separata, visita il seguente sito Web Microsoft:

/contactus/?ws=support

Aggiornamenti rapidi per SQL Server 2008 inclusi nell'aggiornamento cumulativo 4 per SQL Server 2008 R2

  Gli articoli della Microsoft Knowledge Base che illustrano questi hotfix verranno rilasciati non appena saranno disponibili.

  Per ulteriori informazioni sui bug di SQL Server, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:

Numero di bug VSTS Numero articolo della Knowledge Base Descrizione
549034 nessuno Il processo di acquisizione CDC può riscontrare la condizione di asserzione seguente quando CDC è abilitato nelle tabelle di database con colonne XML o di altro tipo di dati BLOB:

Asserzione: File: <nome del file>
line=<numero di> riga asserzione non riuscita = 'fNoWriters' -AND-
line=<numero di> riga asserzione non riuscita = 'fNoReaderWriterConflict'
548984 980570 FIX: Messaggio di errore "Errore di indice fulltext durante la compressione o la decompressione" quando si ricompila l'indice di ricerca full-text in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
548986 980832 FIX: Messaggio di errore "Un controllo dell'asserzione del sistema non è riuscito" quando si esegue una query Transaction-SQL in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
451119 980849 FIX: Si verifica un'alta latenza per gli agenti di distribuzione peer-to-peer in Microsoft SQL Server 2005, Microsoft SQL Server 2008 o Microsoft SQL Server 2008 R2
548988 981120 FIX: Messaggio di errore quando si abilita TDE in un database con l'isolamento snapshot abilitato in SQL Server 2008 o in SQL Server 2008 R2
548990 982034 FIX: La caratteristica di conversione non funziona quando si esegue un'azione di raggruppamento in una tabella pivot di Excel che usa SSAS 2008 o SSAS 2008 R2 come origine dati
548996 982854 FIX: "Memoria di sistema insufficiente nel pool di risorse 'interno' per eseguire questa query" messaggio di errore quando si esegue una query full-text che usa parole composte in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
548998 982857 FIX: Messaggio di errore quando si configura una replica transazionale per un database in SQL Server 2008 o in SQL Server 2008 R2
549014 983577 FIX: Il processo di esportazione non termina mai quando si esporta un report che contiene elementi tablix annidati in Microsoft SQL Server Reporting Services 2008 alle estensioni supportate dai renderer di interruzione di pagina
442541 2022254 SQL Server può segnalare l'errore 18272 durante le operazioni di ripristino
549019 2028406 FIX: Gli spazi vuoti tra alcuni elementi vengono generati in modo non corretto in un report di SQL Server 2008 o SQL Server 2008 R2
549021 2028755 FIX: Quando si esegue una query LIKE con caratteri jolly e regole di confronto Latin1_General_100_CS_AS, viene restituito un risultato non corretto in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
549040 2200755 FIX: Messaggio di errore quando si esegue una query MDX in SSAS 2008 o in SSAS 2008 R2
549042 2220252 FIX: Un report di SQL Server 2005 che usa la funzionalità di attivazione/disattivazione visibilità viene eseguito in modo non corretto in SQL Server 2008 o in SQL Server 2008 R2
547877 2222998 FIX: Viene restituita una stima di cardinalità non corretta quando si esegue una query in SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2
549032 2248999 FIX: Si verifica un danneggiamento dell'indice quando si aggiorna una visualizzazione in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
549044 2255410 Una query restituisce risultati incoerenti prima che la cache dei dati venga riscaldata in SSAS 2008 o in SSAS 2008 R2
561761 2261403 FIX: L'oggetto prestazioni "SQL Server:SSIS Pipeline 10.0" non viene visualizzato nell'elenco "Oggetto prestazioni" quando un altro utente accede ad alcuni contatori della pipeline SSIS in SQL Server 2008 o in SQL Server 2008 R2
549030 2264562 FIX: Una query full-text che usa il predicato CONTAINS o FREETEXT insieme all'operatore "OR" richiede molto tempo per essere eseguita in SQL Server 2008 o in SQL Server 2008 R2
561767 2276330 FIX: La funzione "CHANGETABLE" è lenta in SQL Server 2008 e in SQL Server 2008 R2
519628 2276495 FIX: "Errore file system" si verifica quando si tenta di eseguire un'operazione di aggiornamento del processo in una dimensione in Microsoft SQL Server 2008 R2 Analysis Services
561769 2276717 FIX: Codice di errore 1456 quando si aggiunge un server di controllo a una nuova sessione di mirroring del database con lo stesso nome di una sessione di mirroring del database esistente in Microsoft SQL Server 2005, Microsoft SQL Server 2008 e Microsoft SQL Server 2008 R2
561772 2278042 FIX: Una trasformazione di colonna derivata può generare risultati non corretti in SSIS 2008 o in SSIS 2008 R2 quando una colonna viene derivata sia in modalità di sola lettura che in quella di lettura/scrittura
524544 2284503 FIX: Si verificano due problemi quando si utilizza Microsoft SQL Server 2008 R2 Master Data Services (MDS)
528558 2291551 FIX: Si verifica un errore quando si tenta di configurare un database del server di report remoto usando Reporting Services Gestione configurazione nell'edizione Datacenter di SQL Server 2008 R2 Reporting Services
526900 2291705 FIX: gli assembly AMO, ADOMD.NET e XMLA per Microsoft SQL Server 2008 R2 hanno dipendenze non corrette dall'assembly Microsoft.SharePoint.dll e dall'assembly Microsoft.AnalysisServices.SharePoint.Integration.dll
536667 2293053 FIX: L'ID dell'intestazione di colonna contiene erroneamente informazioni sul prefisso quando si utilizza il controllo "ReportViewer" di Visual Studio 2010 per eseguire un report in locale
547891 2295869 FIX: Un deadlock non risolto si verifica quando un database viene ripristinato in SQL Server 2005 SP3 o in SQL Server 2008 R2
534262 2297308 FIX: "Un precedente tentativo di configurazione di filestream è stato incompleto" e una violazione di accesso si verificano quando si esegue la configurazione post-installazione della funzionalità FILESTREAM in un cluster di failover di SQL Server 2008 o SQL Server 2008 R2
534101 2300689 FIX: Non è possibile ripristinare un backup di un database in un'altra istanza di SQL Server se si disabilita Transparent Data Encryption prima di creare il backup in SQL Server 2008 o in SQL Server 2008 R2
544205 2344694 FIX: Alcune funzioni di rilevamento modifiche e DMV non funzionano correttamente dopo un failover di mirroring automatico del database si verifica in SQL Server 2008 R2
536267 2359606 FIX: Il messaggio di errore "System.OverflowException: il valore era troppo grande o troppo piccolo per un Int32" viene visualizzato quando si tenta di generare un report in Microsoft SQL Server 2008 R2 Reporting Services
561798 2380361 FIX: Messaggio di errore quando si esegue la stored procedure "sp_createstats" in SQL Server 2008 o in SQL Server 2008 R2 se la tabella contiene una colonna calcolata non deterministica
561800 2380435 FIX: Il piano di query per una stored procedure non viene memorizzato nella cache se la stored procedure utilizza una variabile BLOB e la variabile viene utilizzata in una funzione stringa in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
561804 2384766 FIX: La proprietà ANSI_NULLS di una visualizzazione indicizzata viene impostata su FALSE dopo la replica della visualizzazione indicizzata nel database di sottoscrizione in SQL Server 2008 o in SQL Server 2008 R2
561806 2387686 FIX: Il messaggio di errore "Si è verificato un errore di sintassi MOF" quando si tenta di installare SQL Server 2008 o SQL Server 2008 R2
549656 2397020 FIX: "Accesso negato. Il messaggio di errore [0x80070005]" viene visualizzato in SSCM quando si tenta di modificare la password di un account di SQL Server 2008 R2 in Windows Vista o in una versione successiva di Windows
548720 2401453 FIX:"Ricerca non riuscita: impossibile recuperare i dati per questa richiesta" quando si cercano alcuni oggetti di database di SQL Azure nella scheda "Dettagli Esplora oggetti" di SQL Server 2008 R2 Management Studio
554322 2407088 FIX: L'errore "Sys.ArgumentNullException" si verifica quando si apre un report drill-through in una web part Visualizzatore report se si utilizza la modalità integrata SharePoint in SQL Server 2008 R2 Reporting Services
555924 2410425 FIX: Viene visualizzata un'eccezione quando si tenta di creare un database MDS in SQL Server 2008 R2 MDS se una tabella di database non MDS è denominata "tblSystem"
555933 2412136 FIX: Nella griglia Esplora entità vengono visualizzate poche righe in un sito Web MDS di SQL Server 2008 R2 se si utilizza una risoluzione dello schermo bassa
560368 2421014 FIX: messaggio di errore "Si è verificato un errore grave nel comando corrente" quando si usa la funzione Freetexttable o Containstable in una visualizzazione indicizzata in una query di tabella comune in SQL Server 2008 R2
554345 2428397 FIX: Il messaggio di errore "Tipo non corrispondente" viene visualizzato quando si tenta di eliminare un database PowerPivot incorporato da un'istanza di SQL Server 2008 R2 Analysis Services installata nella modalità di integrazione di SharePoint
558922 2431362 FIX: Messaggio di errore quando si tenta di creare una query denominata in un progetto che usa Microsoft SQL Server 2008 R2 Parallel Data Warehouse come origine dati: Parola chiave non supportata

Informazioni sul pacchetto di aggiornamento cumulativo

Informazioni sul riavvio

  Potrebbe essere necessario riavviare il computer dopo l'applicazione dell'aggiornamento cumulativo.

Informazioni del Registro di sistema

  Per usare uno degli aggiornamenti rapidi inclusi in questo pacchetto, non è necessario apportare modifiche al Registro di sistema.

Come disinstallare il pacchetto di aggiornamento cumulativo

  Per disinstallare il pacchetto di aggiornamento cumulativo, procedere come segue:

  1. Nel Pannello di controllo aprire il
    Aggiungi o rimuovi programmi
      elemento.

  2. Fare clic su
    Cambiare o rimuovere programmi
      .

  3. Per visualizzare tutti gli aggiornamenti per l'installazione di SQL Server 2008 R2, fare clic per selezionare
    Mostra Aggiornamenti
      .

  4. Disinstallare il pacchetto di hotfix cumulativo.

Riferimenti

  Per ulteriori informazioni sul modello di servizio incrementale per SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

935897
  Un modello di servizio incrementale è disponibile dal team di SQL Server per fornire correzioni rapide per i problemi segnalati

  Per ulteriori informazioni sullo schema di denominazione per gli aggiornamenti di SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

822499
  Nuovo schema di denominazione per i pacchetti di aggiornamento software di Microsoft SQL Server
   Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

824684
  Descrizione della terminologia standard usata per descrivere gli aggiornamenti software Microsoft