Sintomo
Il tag di record selezionato è vuoto o visualizza "Nessun nome" anche se il valore selezionato viene visualizzato correttamente nell'elenco dei risultati del controllo di ricerca.
Per esempio
Causa
Il testo visualizzato nei tag non è correlato al modo in cui l'elemento viene visualizzato nell'elenco dei risultati. Il testo del tag è il campo principale di un'entità. Per impostazione predefinita, il campo primario è "Nome". Per l'entità utente è "Nome completo". Il campo principale è un campo obbligatorio nell'interfaccia utente, ma potrebbe essere vuoto.
-
Il record contiene un valore per il campo primario, quindi è probabile che la colonna non sia presente nella visualizzazione. Controllare la visualizzazione di cui viene eseguito il rendering per assicurarsi che il campo principale sia presente e nella posizione più a sinistra.
Ad esempio, controllare la colonna principale della visualizzazione Ricerca account
-
Il record non ha un valore per il relativo campo primario. Potrebbe essere correlato a una migrazione non completa del database.
Attenuazione
Soluzione per ogni causa
-
Se la colonna non è presente nella visualizzazione. Aggiungere la colonna nella visualizzazione.
Fare clic su "Aggiungi colonne" per aggiungere la colonna principale
La colonna principale è in genere il nome o il nome completo dell'entità utente.