Avviso

Rivisto 08/06/2021

L'8 giugno 2021 questo aggiornamento è stato rilasciato per sostituire un aggiornamento precedente per risolvere un errore che potrebbe verificarsi durante l'installazione. Se è già stata installata una versione precedente di questo aggiornamento, non è richiesta alcuna azione. Per ottenere la versione più recente di questi aggiornamenti, vedere la sezione "Come ottenere e installare l'aggiornamento" del singolo articolo sull'aggiornamento.  I collegamenti a ogni articolo sono disponibili nella sezione "Altre informazioni sull'aggiornamento" di questo articolo.

Il 9 marzo 2021 questo aggiornamento è stato rilasciato per sostituire un aggiornamento precedente per risolvere un errore "Un certificato richiesto non rientra nel periodo di validità" che può verificarsi durante l'installazione.

Si applica a:

Microsoft .NET Framework 2.0 Microsoft .NET Framework 3.0 Microsoft .NET Framework 4.5.2 Microsoft .NET Framework 4.6

IMPORTANTE Verificare di aver installato gli aggiornamenti necessari elencati nella sezione Come ottenere questo aggiornamentoprima di installare questo aggiornamento.

IMPORTANTE I file CAB di analisi di WSUS continueranno a essere disponibili per Windows Server 2008 SP2. Se si dispone di un sottoinsieme di dispositivi che eseguono questo sistema operativo senza ESU, questi potrebbero essere visualizzati come non conformi nei set di strumenti di gestione delle patch e conformità.

IMPORTANTE I clienti che hanno acquistato l'aggiornamento della sicurezza estesa (ESU) per le versioni locali di questo sistema operativo devono seguire le procedure descritte in KB4522133 per continuare a ricevere gli aggiornamenti della sicurezza dopo la fine del supporto esteso il 14 gennaio 2020. Per altre informazioni su ESU e sulle edizioni supportate, vedere KB4497181.

IMPORTANTE A partire da agosto 2019, gli aggiornamenti a .NET Framework 4.6 e successive, per Windows Server 2008 SP2 richiedono il supporto per la firma del codice SHA-2. Assicurarsi di avere tutti gli aggiornamenti più recenti Windows prima di applicare questo aggiornamento per evitare problemi di installazione. Per informazioni più dettagliate sugli aggiornamenti del supporto della firma del codice SHA-2, vedere KB 4474419.

IMPORTANTE Tutti gli aggiornamenti per .NET Framework 4.7.2, 4.7.1, 4.7, 4.6.2, 4.6.1 e 4.6 richiedono l'installazione dell'aggiornamento di d3dcompiler_47.dll. È consigliabile installare l'aggiornamento d3dcompiler_47.dll prima di applicare questo aggiornamento. Per altre informazioni sul d3dcompiler_47.dll, vedere KB 4019990.

IMPORTANTE Se si installa un Language Pack dopo l'installazione di questo aggiornamento, è necessario reinstallare questo aggiornamento. È quindi consigliabile installare i Language Pack necessari prima di installare questo aggiornamento. Per altre informazioni, vedere Aggiungere Language Pack a Windows.

Riepilogo

Miglioramenti alla sicurezza

Esiste una vulnerabilità di divulgazione delle informazioni quando .NET Framework gestisce in modo improprio gli oggetti in memoria. Un utente malintenzionato che ha sfruttato correttamente la vulnerabilità potrebbe divulgare il contenuto della memoria di un sistema interessato. Per sfruttare la vulnerabilità, un utente malintenzionato autenticato dovrebbe eseguire un'applicazione appositamente predisposta. L'aggiornamento risolve la vulnerabilità correggendo il modo in .NET Framework gestisce gli oggetti in memoria.  

Per altre informazioni sulle vulnerabilità, vedere le vulnerabilità comuni ed esposizioni (CVE) seguenti.

Per un elenco dei miglioramenti rilasciati con questo aggiornamento, vedere i collegamenti agli articoli nella sezione Informazioni aggiuntive di questo articolo.

Problemi noti in alcune parti di questo aggiornamento

Sintomo

Questo aggiornamento non viene installato e restituisce uno o entrambi i messaggi di errore seguenti:

  • -2146762495

  • Un certificato obbligatorio non rientra nel periodo di validità durante la verifica rispetto all'orologio di sistema corrente o al timestamp nel file firmato.

  • La funzione di revoca non è stata in grado di controllare la revoca perché il server di revoca era offline.

Soluzione alternativa

Questo problema è stato corretto dall'ultima versione delle parti interessate in questo aggiornamento.

Se è già stata installata una versione precedente delle parti interessate, non è richiesta alcuna azione.

Altre informazioni su questo aggiornamento

Gli articoli seguenti contengono altre informazioni sull'aggiornamento in relazione alle singole versioni del prodotto.

  • 4578951 Descrizione dell'aggiornamento cumulativo qualitativo e della sicurezza per .NET Framework 2.0 e 3.0 per Windows Server 2008 SP2 (KB4578951)

  • 4578955 Descrizione dell'aggiornamento cumulativo qualitativo e della sicurezza per .NET Framework 4.5.2 per Windows 7 SP1 e Windows Server 2008 R2 SP1 e Windows Server 2008 SP2 (KB4578955)

  • 4578963 Descrizione dell'aggiornamento cumulativo qualitativo e della sicurezza per .NET Framework 4.6 per Windows 7 SP1 e Windows Server 2008 R2 SP1 e Windows Server 2008 SP2 (KB4578963)

Informazioni sulla protezione e la sicurezza

Serve aiuto?

Amplia le tue competenze

Esplora i corsi di formazione >

Ottieni in anticipo le nuove caratteristiche

Partecipa a Microsoft Insider >

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×