Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

L'icona del Cestino non viene visualizzata sul desktop in Windows Vista o Windows XP. Di conseguenza, è impossibile utilizzare il Cestino per eseguire attività quali il ripristino di un file che è stato eliminato. In questo articolo viene spiegato come ripristinare l'icona del Cestino.

Risoluzione

Per correggere il problema in Windows Vista, attenersi alla seguente procedura:

  1. Fare clic sul pulsante Start, quindi scegliere Pannello di controllo.

  2. Fare clic su Aspetto e personalizzazione, selezionare Personalizzazione, quindi fare clic su Cambia icone sul desktop.

  3. Fare clic per selezionare la casella di controllo Cestino, quindi scegliere OK.

Passaggi successivi

Verificare se il problema è stato risolto. Se il problema è risolto, è possibile interrompere la lettura dell'articolo. Se il problema persiste, è possibile provare la procedura descritta nella sezione "Soluzione alternativa".

Per risolvere il problema in Windows XP, utilizzare uno dei metodi descritti di seguito.

Metodo 1: utilizzare il programma con cui è stata rimossa l'icona del Cestino per ripristinarla.


Nota: se è stato utilizzato il programma TweakUI per nascondere l'icona del Cestino, attenersi alla seguente procedura per ripristinare l'icona sul desktop. Se non è stato utilizzato il programma TweakUI, vedere i metodi 2 o 3.

Importante: in questa sezione, metodo o attività è illustrata la procedura di modifica del Registro di sistema. L'errata modifica del Registro di sistema può causare seri problemi. Pertanto, attenersi scrupolosamente alla procedura indicata. Per una maggiore sicurezza, eseguire una copia di backup del Registro di sistema, prima di modificarlo, in modo da poterlo poi ripristinare in caso di problemi. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare
    regedit e quindi scegliere OK.

  2. Se si utilizza il menu Start standard di Windows XP

    1. Individuare la seguente chiave del Registro di sistema:

      HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel

    2. Nel riquadro di destra fare clic con il pulsante destro del mouse sul valore DWORD, quindi scegliere Modifica:

      {645FF040-5081-101B-9F08-00AA002F954E}

    3. Nella casella Dati valore digitare:
      0 e quindi scegliere OK. Se si utilizza l'utilità TweakUI per nascondere l'icona del Cestino, il valore viene impostato su 1.

    Se si utilizza il menu Start classico di Windows XP

    1. Individuare la seguente chiave del Registro di sistema:

      HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu

    2. Nel riquadro di destra fare clic con il pulsante destro del mouse sul valore DWORD, quindi scegliere Modifica:

      {645FF040-5081-101B-9F08-00AA002F954E}

    3. Nella casella Dati valore digitare:
      0 e quindi scegliere OK. Se si utilizza l'utilità TweakUI per nascondere l'icona del Cestino, il valore viene impostato su 1.

  3. Fare clic su Esci per chiudere l'editor del Registro di sistema.

Passaggi successivi
  • Verificare se il problema è stato risolto. Se il problema è risolto, è possibile interrompere la lettura dell'articolo. Se il problema persiste, è possibile provare la procedura descritta nella sezione "Soluzione alternativa".

Metodo 2: Modificare il Registro di sistema per ripristinare il Cestino


Nota: se l'amministratore del sistema ha utilizzato un'impostazione di Criteri di gruppo per nascondere il Cestino (o "Tutte le icone") sul desktop, vedere il metodo 3.

Importante: in questa sezione, metodo o attività è illustrata la procedura di modifica del Registro di sistema. L'errata modifica del Registro di sistema può causare seri problemi. Pertanto, attenersi scrupolosamente alla procedura indicata. Per una maggiore sicurezza, eseguire una copia di backup del Registro di sistema, prima di modificarlo, in modo da poterlo poi ripristinare in caso di problemi. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows
Per modificare il Registro di sistema al fine di far comparire l'icona del Cestino sul desktop, attenersi alla seguente procedura:

  1. Fare clic sul pulsante Start, quindi scegliere Esegui.

  2. Nella casella Apri, digitare
    regedit e quindi scegliere OK.

  3. Individuare la seguente chiave del Registro di sistema:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace

  4. Fare clic con il pulsante destro del mouse sulla chiave identificata al passaggio 3 e scegliere Nuovo, quindi scegliere Chiave.

  5. Digitare {645FF040-5081-101B-9F08-00AA002F954E}, quindi premere INVIO.

  6. Fare clic sulla nuova chiave
    {645FF040-5081-101B-9F08-00AA002F954E} creata al passaggio 5.

  7. Nel riquadro di destra fare doppio clic sulla voce
    (Predefinito).

  8. Nella finestra di dialogo Modifica stringa digitare
    Cestino nella casella Dati valore, quindi scegliere OK.

  9. Chiudere l'editor del Registro di sistema.

Passaggi successivi

Verificare se il problema è stato risolto. Se il problema è risolto, è possibile interrompere la lettura dell'articolo. Se il problema persiste, è possibile provare la procedura descritta nella sezione "Soluzione alternativa".

Metodo 3: utilizzare l'Editor criteri di gruppo per ripristinare il Cestino

Se l'amministratore del sistema ha utilizzato un'impostazione di Criteri di gruppo per nascondere il Cestino o "Tutte le icone" sul desktop, per ripristinare l'icona del Cestino è necessario rivolgersi all'amministratore. L'amministratore di sistema può utilizzare l'Editor criteri di gruppo, GPEDIT.msc, oppure rimuovere manualmente le informazioni dal Registro di sistema create mediante l'Editor criteri di gruppo, per ripristinare l'icona Cestino sul desktop.


Nota: le procedure seguenti si applicano esclusivamente a Windows XP Professional. Se il sistema in uso non è Windows XP Professional, è possibile provare la procedura descritta nella sezione "Soluzione alternativa".

Importante: in questa sezione, metodo o attività è illustrata la procedura di modifica del Registro di sistema. L'errata modifica del Registro di sistema può causare seri problemi. Pertanto, attenersi scrupolosamente alla procedura indicata. Per una maggiore sicurezza, eseguire una copia di backup del Registro di sistema, prima di modificarlo, in modo da poterlo poi ripristinare in caso di problemi. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows

  • Per utilizzare l'Editor criteri di gruppo per ripristinare il Cestino:

    1. Fare clic sul pulsante Start, scegliere Esegui, digitare GPEDIT.MSC nella casella Apri, quindi scegliere OK.

    2. In Configurazione utente fare clic su
      Modelli amministrativi e quindi fare doppio clic su
      Desktop.

    3. Fare doppio clic su Rimuovi l'icona del Cestino dal desktop.

    4. Fare clic sulla scheda Impostazioni, quindi su
      Non configurato e scegliere OK.

  • Per utilizzare l'editor del Registro di sistema per ripristinare il Cestino:

    1. Fare clic sul pulsante Start, scegliere Esegui, digitare
      regedit e quindi scegliere OK.

    2. Individuare la seguente chiave del Registro di sistema:

      HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum

    3. Fare clic sulla chiave del Registro di sistema individuata al passaggio 3, quindi nel riquadro destro, fare clic sul valore DWORD del Registro di sistema:

      {645FF040-5081-101B-9F08-00AA002F954E}

    4. Nel menu Modifica fare clic su
      Elimina, quindi scegliere .

    5. Chiudere l'editor del Registro di sistema.

Passaggi successivi

Verificare se il problema è stato risolto. Se il problema è risolto, è possibile interrompere la lettura dell'articolo. Se il problema persiste, è possibile provare la procedura descritta nella sezione "Soluzione alternativa".

Soluzione alternativa

Se non è possibile ripristinare il Cestino utilizzano i metodi elencati in questo articolo, risolvere il problema creando un collegamento al Cestino. Per eseguire questa operazione, attenersi alla procedura seguente:

  1. Fare clic sul pulsante Start, quindi scegliere Risorse del computer.

  2. Scegliere Opzioni cartella dal menu Strumenti.

  3. Fare clic sulla scheda Visualizza, quindi deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato).

  4. Fare clic su nel messaggio di avviso visualizzato, quindi fare clic su OK per chiudere la finestra di dialogo Opzioni cartella.

  5. Scegliere Cartelle sulla barra degli strumenti.

    Nota: se la voce Cartelle non è presente sulla barra delle applicazioni, scegliere Barre degli strumenti nel menu Visualizza, quindi selezionare Pulsanti standard.

  6. Nel riquadro di spostamento sinistro, in Cartelle, individuare la cartella Cestino, quindi trascinarla sul desktop.

  7. Scegliere Opzioni cartella dal menu Strumenti.

  8. Fare clic sulla scheda Visualizza, quindi selezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Scegliere OK.

Nota: questa procedura non consente di creare nuovamente l'icona originale. Tuttavia, questa procedura consente di ripristinare la maggior parte delle funzionalità del Cestino. È incluso quanto segue:

  • Eliminazione di un file trascinandolo sull'icona Cestino sul desktop.

  • Recupero di un file eliminato facendo doppio clic sull'icona del
    Cestino sul desktop, facendo clic con il pulsante destro del mouse sul file da recuperare e quindi facendo clic su Ripristina.

  • Svuotamento del Cestino facendo clic con il pulsante destro del mouse sull'icona Cestino sul desktop e scegliendo Svuota Cestino.

Nota: se si utilizza questa procedura per risolvere il problema, non sarà possibile fare clic con il pulsante destro del mouse sul collegamento rapido al Cestino per accedere alle proprietà del Cestino. Per impostare le proprietà del Cestino, attenersi alla procedura seguente:

  1. Fare doppio clic sul collegamento Cestino sul desktop. Verrà aperta la cartella Cestino.

  2. Nell'angolo superiore sinistro della cartella Cestino, fare clic con il pulsante destro del mouse sull'icona del Cestino, quindi scegliere
    Proprietà.


Se questa procedura non consente di risolvere il problema, è possibile contattare il supporto tecnico.

Causa

Questo problema può essere dovuto a diverse cause:

  • È stato utilizzato un programma di terze parti per nascondere il Cestino.

  • È stato utilizzato il programma TweakUI per nascondere il Cestino.

  • Sono state cancellate le informazioni del Registro di sistema relative al Cestino.

  • È stata utilizzata un'impostazione dei Criteri di gruppo per nascondere il Cestino.

    Nota: Windows XP Home Edition non supporta Criteri di gruppo.

Riferimenti

Per assistenza con le attività di manutenzione del sistema comuni in Windows Vista, visitare la pagina Web Microsoft indicata di seguito:

Risolvere i problemi relativi alle attività di manutenzione del sistema comuni

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×