Sintomi
Considerare lo scenario descritto di seguito:
-
In Microsoft Commerce Server catalogo Manager 2009, si crea un variante prodotto aggiungendo una proprietà variant a un prodotto. Il prezzo di listino del prodotto variant è diverso dal prezzo di elenco originale del prodotto.
-
Utilizzare il formato del tipo di esportazione completa per esportare il catalogo in un file XML.
-
Importare il file XML esportato nel catalogo utilizzando il formato tipo di sostituzione .
-
Si modifica l'associazione di categoria del prodotto. A tale scopo, aggiungere e quindi selezionare una categoria nella scheda Associazioni di categoria .
In questo scenario, il prezzo di listino del prodotto appena aggiunto variant viene reimpostato il prezzo di listino originale del prodotto. Nota Il problema si verifica anche se si utilizza l'API di Commerce Server per eseguire tali azioni.
Causa
Il problema si verifica perché il file XML di catalogo prodotto variant esportato non contiene le proprietà di prezzo e prezzo di listino originale. Quando si importa il file XML di catalogo utilizzando il formato tipo sostituire , proprietà di prezzo del prodotto originale vengono utilizzate per compilare le proprietà mancanti nella variante prodotto.
Risoluzione
Informazioni sull'hotfix
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix. Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix. Nota Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.
Note sull'installazione
Se si utilizza Commerce Server 2009 modello Pack per SharePoint 2010, scaricare e installare il pacchetto di hotfix che è l'etichetta "CS2009TP_KB2532193". Se si utilizza Microsoft Commerce Server 2009 RTM, scaricare e installare il pacchetto di hotfix che è l'etichetta "CS2009RTM_KB2532193".
Requisiti
Nell'elenco seguente contiene i prerequisiti per il pacchetto di hotfix:
-
Microsoft Commerce Server 2009
Necessità di riavvio
Non è necessario riavviare il computer dopo avere applicato questo hotfix. Tuttavia, è necessario riavviare Internet Information Services (IIS) e l'applicazione di Commerce Server catalogo importazione Host COM+ dopo avere applicato questo hotfix. Per riavviare IIS, aprire un prompt dei comandi, digitare il comando seguente e premere INVIO:
IISRESET /RESTART. Nota Questa procedura si arresta e riavvia tutti i servizi IIS in esecuzione.
Informazioni sulla sostituzione
Questo hotfix non sostituisce alcun altro hotfix precedentemente rilasciato.
Informazioni sui file
La versione globale di questo hotfix viene utilizzato un pacchetto di Microsoft Windows Installer per installare l'aggiornamento rapido. Le date e ore per questi file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated) nella tabella seguente. Quando si visualizzano le informazioni sul file, la data viene convertita in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di data e ora nel Pannello di controllo.
Per Microsoft Commerce Server 2009 modello Pack per SharePoint 2010
|
Nome file |
Versione file |
Dimensione file |
Date |
Ora |
Piattaforma |
|---|---|---|---|---|---|
|
Cspatchhelper.exe |
6.0.4171.513 |
16,224 |
12-Apr-2011 |
14:22 |
x86 |
|
Microsoft.catalogserver.dll |
6.0.4171.513 |
763,760 |
12-Apr-2011 |
14:22 |
x86 |
|
Microsoft.commerceserver.runtime.dll |
6.0.4171.513 |
849,792 |
12-Apr-2011 |
14:22 |
x86 |
|
Microsoft.commerceserver.catalog.dll |
6.0.4171.513 |
960,384 |
12-Apr-2011 |
13:58 |
x86 |
Di Commerce Server 2009
|
Nome file |
Versione file |
Dimensione file |
Date |
Ora |
Piattaforma |
|---|---|---|---|---|---|
|
Cs2009hotfixhelper.exe |
6.0.4171.46 |
12,136 |
06-Apr-2011 |
12:03 |
x86 |
|
Microsoft.catalogserver.dll |
6.0.4171.46 |
763,760 |
06-Apr-2011 |
12:03 |
x86 |
|
Microsoft.commerceserver.runtime.dll |
6.0.4171.46 |
849,792 |
06-Apr-2011 |
12:03 |
x86 |
|
Microsoft.commerceserver.catalog.dll |
6.0.4171.46 |
960,384 |
06-Apr-2011 |
11:42 |
x86 |
Stato
Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".