In questo articolo si applica a Microsoft Dynamics NAV per tutti i paesi e tutte le lingue.
Sintomi
Quando si copia un valore di cella da un foglio di lavoro di Excel in Microsoft Dynamics NAV 5.0 Service Pack 1 (SP1), i due caratteri speciali vengono aggiunti alla fine del valore. Questi caratteri speciali sono segni di rettangolo come caratteri di avanzamento riga.
Nota: Se si esegue Microsoft Dynamics NAV e Microsoft Excel in un computer basato su Windows 7, questi due caratteri non sono visibili. Se si esegue Microsoft Dynamics NAV e Microsoft Excel in un computer basato su Windows Server 2003, i caratteri sono visibili.
Questi caratteri vengono aggiunti ai campi in Microsoft Dynamics NAV. Pertanto, è necessario eliminare manualmente i caratteri speciali.
Causa
Questo problema si verifica perché il ritorno a capo (CR) carattere (ASCII 13) o riga (LF) carattere (ASCII 10) di avanzamento viene aggiunto il valore di una cella copiato da un foglio di lavoro di Excel a un'applicazione. Il client personalizzato (RTC) utilizza il controllo di testo, in base al controllo di testo standard di .NET. Se il controllo di testo .NET presenta la proprietà Multiline impostata su "No", quando si incolla un testo di controllo che contiene il carattere di CR o il carattere di nuova riga, viene copiato solo il testo prima i caratteri. Se il controllo di testo multilinea proprietà è impostato su "True", "nuova riga" può essere utilizzato. Per ulteriori informazioni, visitare il seguente sito Web Microsoft:
Proprietà TextBoxBase.Multiline
Microsoft Dynamics NAV deve implementare un client classico, un'elaborazione speciale per il metodo Incolla dei controlli di modifica di testo. La "nuova riga" caratteri devono essere rimossi dalla fine della riga.
Risoluzione
Informazioni sull'hotfix
Un hotfix supportato è disponibile da Microsoft. È una "download dell'Hotfix disponibile" nella parte superiore di questo articolo della Knowledge Base. Se si è verificato un problema il download, installare questa correzione, o hanno altre domande di supporto tecnico, contattare il partner o, se iscritto un piano di supporto direttamente con Microsoft, è possibile contattare il supporto tecnico per Microsoft Dynamics e creare una nuova richiesta di supporto. A tale scopo, visitare il seguente sito Web Microsoft:
https://mbs.microsoft.com/support/newst art.aspxÈ inoltre possibile contattare il supporto tecnico per Microsoft Dynamics telefonicamente tramite questi collegamenti per i numeri di telefono specifico paese. A tale scopo, visitare uno dei seguenti siti Web Microsoft:
Partner
https://mbs.microsoft.com/customersource/support/information/SupportIn formation/global_support_contacts_eng.htmIn casi particolari, le spese normalmente addebitate per le chiamate potrebbero essere annullate qualora un aggiornamento del supporto tecnico di Microsoft Dynamics e prodotti correlati di supporto determina che uno specifico aggiornamento risolverà il problema. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.
Come ottenere l'hotfix di Microsoft Dynamics NAV o aggiornare i file
Dopo aver richiesto un hotfix Microsoft Dynamics NAV, un collegamento ipertestuale verrà inviato all'utente un messaggio di posta elettronica.
Messaggio di posta elettronica conterrà un collegamento ipertestuale e una password. È possibile utilizzare il collegamento ipertestuale per scaricare l'hotfix di Microsoft Dynamics NAV o i file di aggiornamento. Quando si fa clic sul collegamento ipertestuale, verrà aperta la finestra di dialogo Download File – avviso di protezione . Quindi, viene chiesto di eseguire, salvare o annullare il download.
Se si sceglie di eseguire, i file di avviare il download e il processo di estrazione. È necessario specificare una cartella per i nuovi file e quindi specificare la password.
Se si sceglie Salva, è necessario specificare un percorso per salvare i file compressi. Quando si apre il file salvato, viene chiesto di specificare un percorso per i file. Quindi, è necessario fornire la password riportata nel messaggio di posta elettronica.
Se si sceglie Annulla, il download viene interrotto.
Come installare un hotfix Microsoft Dynamics NAV o un file di aggiornamento
Gli aggiornamenti e aggiornamenti rapidi di Microsoft Dynamics NAV piattaforma vengono resi disponibili come singoli file. Per installare un hotfix Microsoft Dynamics NAV o un aggiornamento, è necessario sostituire i file di installazione esistenti di Microsoft Dynamics NAV con l'aggiornamento rapido o i file di aggiornamento. A tale scopo, attenersi alla seguente procedura.
Passaggio 1: Sostituire il file di installazione Client di Microsoft Dynamics NAV
Nell'installazione Client di Microsoft Dynamics NAV, sostituire i seguenti file utilizzando l'aggiornamento rapido o il file di aggiornamento.
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
---|---|---|---|---|---|
Dbm.dll |
5.0.32009.0 |
434,176 |
09-Dec-2010 |
19:53 |
x86 |
Fin.exe |
5.0.32009.0 |
10,747,904 |
09-Dec-2010 |
19:31 |
x86 |
Finhlink.exe |
5.0.32009.0 |
339.968 |
09-Dec-2010 |
19:44 |
x86 |
Finsql.exe |
5.0.32009.0 |
10,809,344 |
09-Dec-2010 |
20:17 |
x86 |
Nc_netb.dll |
5.0.32009.0 |
102,400 |
09-Dec-2010 |
19:54 |
x86 |
Nc_tcp.dll |
5.0.32009.0 |
102,400 |
09-Dec-2010 |
19:54 |
x86 |
Nc_tcps.dll |
5.0.32009.0 |
147,456 |
09-Dec-2010 |
19:55 |
x86 |
Ndbcs.dll |
5.0.32009.0 |
1,286,144 |
09-Dec-2010 |
20:20 |
x86 |
Slave.exe |
5.0.32009.0 |
151,552 |
09-Dec-2010 |
19:44 |
x86 |
Per sostituire i file esistenti di Microsoft Dynamics NAV, attenersi alla seguente procedura:
-
Chiudere Microsoft Dynamics NAV.
-
Individuare la directory di installazione Client di Microsoft Dynamics NAV. Il Client di Microsoft Dynamics NAV viene in genere installato nella seguente directory:
C:\Program Files\Microsoft Dynamics NAV\CSIDE Client\
-
Copiare i file scaricati.
-
Incollare i file scaricati nella directory di installazione Client di Microsoft Dynamics NAV.
-
Quando richiesto, fare clic su Sì per sovrascrivere i file nella directory di installazione.
Passaggio 2: Sostituire il file di installazione di Microsoft Dynamics NAV Application Server
Se si dispone di Microsoft Dynamics NAV Application Server è installato, l'installazione di Microsoft Dynamics NAV Application Server, sostituire i seguenti file utilizzando l'aggiornamento rapido o il file di aggiornamento.
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
---|---|---|---|---|---|
Dbm.dll |
5.0.32009.0 |
434,176 |
09-Dec-2010 |
19:53 |
x86 |
Nas.exe |
5.0.32009.0 |
1,859,584 |
09-Dec-2010 |
19:41 |
x86 |
Nassql.exe |
5.0.32009.0 |
1,916,928 |
09-Dec-2010 |
20:19 |
x86 |
Ndbcs.dll |
5.0.32009.0 |
1,286,144 |
09-Dec-2010 |
20:20 |
x86 |
Slave.exe |
5.0.32009.0 |
151,552 |
09-Dec-2010 |
19:44 |
x86 |
Per sostituire i file, attenersi alla seguente procedura.
-
Arrestare il Server di applicazioni di Microsoft Dynamics NAV.
-
Individuare la directory di installazione di Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server viene in genere installato nella seguente directory:
C:\Program Files\Microsoft Dynamics NAV\Application server
-
Copiare i file scaricati.
-
Incollare i file scaricati nella directory di installazione di Microsoft Dynamics NAV Application Server.
-
Quando richiesto, fare clic su Sì per sovrascrivere i file nella directory di installazione.
-
Avvio di Microsoft Dynamics NAV Application Server.
Passaggio 3: Sostituire il file di installazione del driver ODBC di Microsoft Dynamics NAV
Se hai installato il driver ODBC di Microsoft Dynamics NAV, sostituire i seguenti file nell'installazione del driver ODBC di Microsoft Dynamics NAV.
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cfront.dll |
5.0.32009.0 |
1,294,336 |
09-Dec-2010 |
19:55 |
x86 |
Dbm.dll |
5.0.32009.0 |
434,176 |
09-Dec-2010 |
19:53 |
x86 |
Nc_netb.dll |
5.0.32009.0 |
102,400 |
09-Dec-2010 |
19:54 |
x86 |
Nc_tcp.dll |
5.0.32009.0 |
102,400 |
09-Dec-2010 |
19:54 |
x86 |
Nc_tcps.dll |
5.0.32009.0 |
147,456 |
09-Dec-2010 |
19:55 |
x86 |
Nodbc.dll |
5.0.32009.0 |
2,650,112 |
09-Dec-2010 |
19:35 |
x86 |
Nodbc.xml |
Non applicabile |
1,209 |
07-Apr-2008 |
01:09 |
Non applicabile |
Nodbccfg.cfg |
5.0.32009.0 |
614,400 |
09-Dec-2010 |
19:36 |
Non applicabile |
Nodbccfg.xml |
Non applicabile |
2,472 |
07-Apr-2008 |
01:09 |
Non applicabile |
Slave.exe |
5.0.32009.0 |
151,552 |
09-Dec-2010 |
19:44 |
x86 |
Per sostituire i file, attenersi alla seguente procedura.
-
Individuare la directory di installazione del driver ODBC di Microsoft Dynamics NAV. Il driver ODBC di Microsoft Dynamics NAV viene in genere installato nella seguente directory:
C:\Program Files\Common Files\Dynamics NAV\NODBC\
-
Copiare i file scaricati.
-
Incollare i file scaricati nella directory di installazione del driver ODBC di Microsoft Dynamics NAV.
-
Quando richiesto, fare clic su Sì per sovrascrivere i file nella directory di installazione.
Prerequisiti
È necessario disporre di Microsoft Dynamics NAV 5.0 Service Pack 1 per applicare questo hotfix.
Soluzione alternativa
Per risolvere, modificare la cella e contrassegnare la cella come "Solo testo".
Stato
Microsoft ha confermato che si tratta di un bug nei prodotti Microsoft elencati nella sezione "Si applica a".
Ulteriori informazioni
Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
Nota: Si tratta di un articolo a "Pubblicazione Veloce" creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento sono fornite così come sono in risposta a problemi urgenti. Per la velocità in rendendo disponibili, i materiali possono includere errori tipografici e possono essere modificati in qualsiasi momento senza preavviso. Per altre considerazioni, vedere Condizioni di utilizzo .