Applies ToExchange Server 2019 Exchange Server 2016

Sintomi 

Dopo aver installato l'aggiornamento della sicurezza di Microsoft Exchange Server novembre 2024 (versione 1 o 2), si verificano problemi quando Exchange Server elabora i file e le informazioni correlate al calendario, ad esempio allegati con estensione ical o .ics. In questo caso, non è possibile visualizzare in anteprima i file o aggiungerli al calendario.

Il problema si verifica quando si usa Outlook sul Web (OWA) e il client di posta di Exchange Active Sync (EAS) in un dispositivo mobile. Inoltre, il problema potrebbe influire sul servizio trasporto di Exchange quando si elaborano messaggi di posta elettronica che contengono allegati con estensione ical o .ics. 

Se Exchange Server non elabora le informazioni del calendario, genera voci del registro eventi, ad esempio uno degli esempi seguenti: 

w3wp#MSExchangeOWAAppPool,M.Exchange.Net, M.E.E.ExIanaTimeZoneProvider+Cache.AddTimeZone, M.E.ExchangeSystem.InvalidTimeZoneException 

Microsoft.Exchange.ExchangeSystem.InvalidTimeZoneException: Time zone id already exists 

Causa

Questo problema si verifica perché Exchange Server usa una voce duplicata nel file IanaTimeZoneMappings.xml

Soluzione alternativa 

Per rimuovere le voci duplicate, usare una delle soluzioni alternative seguenti. ​​​​​​​

Metodo 1

Seguire i passaggi descritti in Remove-DuplicateEntriesFromIanaMappings.​​​​​​​​​​

Metodo 2

  1. Salvare il file IanaTimeZoneMappings.xml che si trova nella cartella seguente: <ExchangeInstallationPath>\Microsoft\Exchange Server\V15\Bin 

  2. Apri il file usando blocco note o un altro editor di testo e cerca la voce seguente (viene visualizzata due volte): <Map IANA="Asia/Bishkek" Win="Central Asia Standard Time" />

  3. Eliminare una delle due voci e quindi salvare il file.

  4. Aprire una finestra di PowerShell con privilegi elevati e quindi eseguire i comandi seguenti:

    Restart-Service -Name W3SVC, WAS -Force 

    Restart-Service -Name MSExchangeTransport 

Stato

Microsoft ha confermato che questo problema interessa i prodotti elencati nella sezione "Si applica a". Microsoft sta lavorando attivamente alla risoluzione del problema in un aggiornamento futuro.

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