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Quando si passa alle pagine del portale aziendale per Microsoft Dynamics GP 2010 che dispongono di web part per visualizzare report, grafici o KPI di Microsoft SQL Server Reporting Services (SSRS), è possibile che venga visualizzato uno o più messaggi di errore: Errore

1:

La richiesta non è riuscita con stato HTTP 401: Non autorizzato.

Errore 2:

Impossibile trovare l'elemento '/%dbname%/%series%/Charts and KPIs/%report%'. (rsItemNotFound)

Errore 3:

Le autorizzazioni concesse all'utente 'dominio\utente' non sono sufficienti per eseguire questa operazione. (raAccessDenied)


Errore 4:

Si è verificato un errore durante l'elaborazione del report. (rsProcessingAborted)
Impossibile creare una connessione all'origine dati 'DataSourceGPCompany'. (rsErrorOpeningConnection)
Accesso non riuscito per l'utente 'dominio\utente'.


Errore 5:

Si è verificato un errore durante l'elaborazione del report. (rsProcessingAborted)
Impossibile creare una connessione all'origine dati 'DataSourceGPCompany'. (rsErrorOpeningConnection)
Impossibile aprire il database '%dbname%' richiesto dall'account di accesso. Accesso non riuscito per l'utente 'dominio/utente'.


Errore 6:

Si è verificato un errore durante l'elaborazione del report. (rsProcessingAborted)
Impossibile creare una connessione all'origine dati 'DataSourceGPCompany'. (rsErrorOpeningConnection)
L'autorizzazione EXECUTE è stata negata per l'oggetto '%objectname%', il database '%dbname%', lo schema 'dbo'.



Sintomi

Causa 1: esistono diverse possibili cause di questo errore.

Causa 2: i report SSRS per Microsoft Dynamics GP 2010 non sono stati distribuiti.

Causa 3: l'utente di dominio che tenta di eseguire il report non ha accesso al report in SSRS.

Causa 4: l SQL Server di accesso non è stato creato per l'utente del dominio che prova a eseguire il report.  

Causa 5: l'utente del dominio che esegue il report non ha accesso ai database aziendali di Microsoft Dynamics GP 2010. 

Causa 6: l'utente del dominio non è stato mappato ai ruoli di database appropriati nel sistema e nei database aziendali di Microsoft Dynamics GP.

NOTA: se si riceve semplicemente un messaggio di errore generico, è probabile che gli errori remoti siano disabilitati in SSRS per impostazione predefinita. Per abilitare questa funzionalità, eseguire le operazioni seguenti:

1. Accedere al server in cui è installato SSRS. 

2. Fare clic su Start, scegliere Tutti i programmi, selezionare Microsoft SQL Server 2008 (o 2008 R2) e quindi fare clic su SQL Server Management Studio. Connettersi all'istanza di Reporting Services.

3. Fare clic con il pulsante destro del mouse sul nome dell'istanza in Esplora oggetti a sinistra e scegliere Proprietà.

4. Selezionare la scheda Avanzate a sinistra.

5. Nella sezione Sicurezza impostare EnableRemoteErrors su True.

6. Fare clic su OK per salvare la modifica. Non è necessario riavviare il servizio per completare questa modifica.

Causa

Soluzione 1: Vedere l'articolo seguente per la

risoluzione:

2608328 Quando si fa clic sul Centro dirigenti nel portale aziendale, nelle web part di SQL Server Reporting Services viene visualizzato l'errore "Richiesta non riuscita con stato HTTP 401: Non autorizzato".

Soluzione 2: vedere la guida SQL Server Reporting Services per informazioni sulla distribuzione dei report di

Microsoft SQL Server Reporting Services per Microsoft Dynamics GP. È possibile scaricare la guida di SQL Server Reporting Services al collegamento seguente:

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=18981Risoluzione 3: Se si usa SSRS in modalità nativa, usare il sito Gestione report per aggiungere o verificare



l'accesso dell'utente ai report. Se i report SSRS sono stati distribuiti in modalità integrata SharePoint, usare la sicurezza di SharePoint per verificare che l'utente abbia accesso al sito della raccolta report. Per altre informazioni sulle autorizzazioni SSRS, vedere il capitolo 7 della guida di SQL Server Reportings Services al collegamento seguente:

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=18981Resolution 4: Vedere la procedura seguente per creare un account di accesso SQL Server per un utente di



dominio:

1. Accedere al server in cui SQL Server è installato. 

2. Fare clic su Start, scegliere Tutti i programmi, selezionare Microsoft SQL Server 2008 (o 2008 R2) e quindi fare clic su SQL Server Management Studio.

3. Connettersi all'istanza di SQL Server in cui si trovano i database di Microsoft Dynamics GP.

4. Fare clic per espandere Sicurezza, fare clic per espandere Account di accesso in Esplora oggetti. 

5. Fare clic con il pulsante destro del mouse sulla cartella Accessi e scegliere Nuovo account di accesso...

6. Nel campo Nome account di accesso specificare l'utente di dominio dal messaggio di errore nel formato nomedominio\nomeutente

7. Fare clic sulla scheda Mapping utenti a sinistra per assegnare all'utente l'accesso ai database di Microsoft Dynamics GP appropriati. Per informazioni dettagliate sull'assegnazione di ruoli e società, vedere il capitolo 7 della guida SQL Server Reporting Service Guide.

Soluzione 5: per verificare l'assegnazione del database SQL Server'account di accesso specificato nell'errore, è possibile

usare la procedura seguente:

1. Accedere al server in cui SQL Server è installato. 

2. Fare clic su Start, scegliere Tutti i programmi, selezionare Microsoft SQL Server 2008 (o 2008 R2) e quindi fare clic su SQL Server Management Studio.

3. Connettersi all'istanza di SQL Server in cui si trovano i database di Microsoft Dynamics GP.

4. Fare clic per espandere Sicurezza, fare clic per espandere Account di accesso in Esplora oggetti.

5. Fare clic con il pulsante destro SQL Server'account di accesso per l'utente di dominio specificato nel messaggio di errore e scegliere Proprietà.

6. Fare clic sulla scheda Mapping utenti a sinistra.

7. Tutti gli account di accesso che devono eseguire i report SSRS di Microsoft Dynamics GP devono essere mappati al database di sistema (DYNAMICS) e a qualsiasi database aziendale per cui intendono creare report. Per altre informazioni sulla sicurezza degli utenti, vedere il capitolo 7 della guida SQL Server Reporting Services di seguito.

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=18981

8. Fare clic su OK e fare in modo che l'utente eserciti di nuovo il report.

Soluzione 6: per modificare l'assegnazione del ruolo del database per SQL Server account di accesso, è possibile

esaminare quanto segue:

1. Accedere al server in cui SQL Server è installato.

2. Fare clic su Start, scegliere Tutti i programmi, selezionare Microsoft SQL Server 2008 (o 2008 R2) e quindi fare clic su SQL Server Management Studio.

3. Connettersi all'istanza di SQL Server in cui si trovano i database di Microsoft Dynamics GP.

4. Fare clic per espandere Sicurezza, fare clic per espandere Account di accesso in Esplora oggetti.

5. Fare clic con il pulsante destro SQL Server'account di accesso per l'utente di dominio specificato nel messaggio di errore e scegliere Proprietà.

6. Fare clic sulla scheda Mapping utenti a sinistra.

7. Fare clic su uno dei database di Microsoft Dynamics GP a cui l'account di accesso ha accesso,ad esempio DYNAMICS o TWO.

8. Esaminare la selezione nella sezione 'Appartenenza ai ruoli del database per 'xxxxx' nella parte inferiore del database per ogni database. Elenco dei ruoli del database che forniscono l'accesso ai report SSRS disponibili nel file MDGP11R2_SRS_Report_Roles.pdf a pagina 50 della guida di SQL Server Reporting Services. Fare clic sul collegamento seguente per scaricare la guida SQL Server Reporting Services:

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=18981

9. Fare clic su OK ed eseguire di nuovo il report.

Risoluzione

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