Sintomi
I seguenti problemi si verificano in Microsoft Visual Studio 2008 Team Foundation Server (TFS).
Sintomo 1
Quando si installa Visual Studio 2008 Team Foundation Server utilizzando un account locale, viene visualizzato un messaggio di errore "Errore 28002" nel Registro di installazione. Inoltre, TF213000 messaggi di errore analoghi messaggi riportati di seguito vengono visualizzati nel registro eventi dell'applicazione:
Messaggio di errore 1
Microsoft Visual Studio 2008 Team Foundation Server - ENU: * * * log degli errori evento * * *: 28002.An: errore si è verificato un errore sconosciuto.
Messaggio di errore 2
Messaggio dettagliato: TF213000: Impossibile aggiungere un account utente richiesto durante l'installazione o ripristino di Team Foundation Server. Installazione o ripristino non riuscito con il seguente messaggio di eccezione: COMException (0x80004005): errore non specificato
Sintomo 2
Quando si tenta di aggiungere un account locale di Visual Studio 2008 Team Foundation Server, viene visualizzato uno o più dei seguenti messaggi di errore:
Messaggio di errore 1
TF30291: Si è verificato un problema sul server di causa sconosciuta. Il registro eventi di Team Foundation Server per informazioni dettagliate, vedere.
Messaggio di errore 2
Team Foundation Server non è riuscito a risolvere l'utente o il gruppo 'nome account locale. L'utente o il gruppo potrebbe essere un membro di un dominio diverso o il server potrebbe non avere accesso a quel dominio. Verificare l'appartenenza al dominio del server e alle relazioni di trust di dominio.
Messaggio di errore 3
TF50361: Argomento factorValue è di lunghezza zero, deve essere presente almeno un elemento di SID. Nome parametro: factorValue
Causa
Causa 1
Questo problema si verifica perché l'installazione non può recuperare l'identità di un account locale.
Risoluzione
Informazioni sull'hotfix
Un hotfix supportato è ora disponibile da Microsoft. Tuttavia, destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicarlo solo ai sistemi in cui si verificano questo problema specifico.
Per risolvere questo problema, contattare il supporto tecnico clienti Microsoft per ottenere l'hotfix. Per un elenco completo dei numeri di telefono supporto tecnico clienti Microsoft e informazioni sui costi dell'assistenza, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: In casi particolari, le spese normalmente addebitate per le chiamate di supporto potrebbero essere annullate qualora un addetto al supporto Microsoft determina che uno specifico aggiornamento risolverà il problema. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.
Prerequisiti
È necessario disporre di Visual Studio 2008 Team Foundation Server Service Pack 1 per applicare questo hotfix.
Richiesta di riavvio
Dopo avere applicato questo hotfix, non è necessario riavviare il computer se non viene utilizzata alcuna istanza di relativa.
Informazioni sulla sostituzione dell'aggiornamento rapido
Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.
Informazioni sui file
La versione globale di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
---|---|---|---|---|---|
Microsoft.teamfoundation.s erver.dll |
9.0.30729.4036 |
376,832 |
06-Feb-2009 |
08:42 |
x86 |
Ll Microsoft.TeamFoundation.Server.Resources.d |
9.0.30729.4036 |
106,496 |
06-Feb-2009 |
08:42 |
x86 |
Ll Microsoft.TeamFoundation.Server.Resources.d |
9.0.30729.4036 |
110,592 |
06-Feb-2009 |
08:42 |
x86 |
Ll Microsoft.TeamFoundation.Server.Resources.d |
9.0.30729.4036 |
118,784 |
06-Feb-2009 |
08:42 |
x86 |
Ll Microsoft.TeamFoundation.Server.Resources.d |
9.0.30729.4036 |
81,920 |
06-Feb-2009 |
08:42 |
x86 |
Ll Microsoft.TeamFoundation.Server.Resources.d |
9.0.30729.4036 |
94,208 |
06-Feb-2009 |
08:42 |
x86 |
Ll Microsoft.TeamFoundation.Server.Resources.d |
9.0.30729.4036 |
98,304 |
06-Feb-2009 |
08:42 |
x86 |
Stato
Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".
Ulteriori informazioni
Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft