Applies ToBizTalk Server Developer 2010 BizTalk Server Enterprise 2010 BizTalk Server Standard 2010 BizTalk Server 2013 Branch BizTalk Server 2013 Developer BizTalk Server 2013 Enterprise BizTalk Server 2013 Standard

Sintomi

Si supponga di utilizzare Microsoft BizTalk Server 2010 o 2013. Quando si utilizza un componente della pipeline personalizzato per chiamare il servizio di trasformazione Enterprise Service Bus (ESB) per trasformare messaggi ESB Toolkit 2.1, la proprietà di contesto DocumentSpecName è impostata in modo non corretto nel messaggio di output e viene visualizzato il seguente messaggio di errore:

Nome registro: applicazioneOrigine: BizTalk ServerID evento: 5720Categoria di attività: BizTalk ServerLivello: erroreDescrizione: tale errore durante l'esecuzione della pipeline di trasmissione: "ESBTransform.SendPipeline1, ESBTransform, versione = 1.0.0.0, Culture = neutral, PublicKeyToken = ca09cc62b15919a7" origine: "assembler file Flat" porta di trasmissione: "<SendPortName >" URI: "<SendPortURI>" motivo: il tipo di documento "http://ESBTransform.FlatFileSchema1#TargetRoot" non corrisponde a nessuno degli schemi forniti.

Causa

Il problema si verifica perché ESB Transformation Service non è impostata la proprietà DocumentSpecName di contesto del messaggio di output per il tipo di schema di destinazione dopo la trasformazione.

Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico.Se l'hotfix è disponibile per il download, vi è una sezione "Hotfix Download disponibile" nella parte superiore di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta al servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix Download disponibile" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Informazioni sull'aggiornamento cumulativo

Questo problema è stato corretto nell'aggiornamento cumulativo di BizTalk Server 2013 seguente:

Prerequisiti

Per applicare questo hotfix, è necessario disporre di BizTalk ESB Toolkit 2.1 installato.

Richiesta di riavvio

Non è necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Microsoft.Practices.ESB.Itinerary.Services.dll

2.1.1.0

24576

13-Oct-2014

13:11

x86

Ulteriori informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, vedere Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.