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Raccomandazione aggiornato

Dopo avere applicato la correzione nella sezione "Risoluzione", il servizio Enterprise Single Sign-On (ENTSSO) si verifica una perdita di memoria. Pertanto, si consiglia di installare la correzione successiva .

Sintomi

Si consideri lo scenario seguente:

  • È stato installato il componente di Enterprise Single Sign-On (SSO) versione 5 che è incluso in Microsoft BizTalk Server 2013 R2 o Host Integration Server 2013.

  • In uno dei seguenti scenari, ripristinare la chiave del segreto master da un file di backup:

    • Quando si installa un cluster Enterprise SSO

    • Durante il ripristino di emergenza SSO enterprise

    • Quando si sta promuovendo un server Enterprise SSO per il Master Secret Server MSS)

    • Durante la migrazione da versioni precedenti di Enterprise SSO

    • Durante un aggiornamento sul posto da una versione precedente di Enterprise SSO

    • Quando si eseguono più Enterprise SSO V5 ripristino e backup sequenze

Dopo aver ripristinato la chiave master secret in uno di questi scenari, Enterprise SSO Impossibile decrittografare i dati contenuti nel database SSO Enterprise. In questa situazione, Enterprise SSO registrato il seguente evento nel registro applicazione:

ID evento: 10536
Origine: ENTSSO
Livello: avviso
Funzione di controllo SSO: ID di rilevamento GetConfigInfo ({11111111-6055-4cda-89CD-389E8A2B1640}): Computer Client b084f15b-43fd-474e-a075-398943753c91: nome del computer (nome eseguibile: PID) utente Client: nomeutente nome applicazione: il nome dell'applicazione il codice di errore: errore 0x80090005, i dati non validi.

Inoltre, potrebbe essere registrato il seguente errore popup quando si apre lo snap-in MMC di amministrazione BizTalk Server:

Amministrazione di BizTalk Server
Dati non validi.
(WinMgmt)
Pulsanti:
Ok

Causa

Enterprise SSO V5 aggiunge un timestamp per la chiave master secret per limitare la durata della chiave. Inoltre, è stato aggiunto un controllo per determinare se la chiave del segreto master include un timestamp. Il problema descritto nella sezione "Sintomi" si verifica perché il servizio Enterprise SSO determina erroneamente che il timestamp è manca quando viene ripristinata la chiave master secret. Poiché per la chiave del segreto master ripristinata è stato aggiunto un indicatore di data e ora, la chiave ripristinata non corrisponde la chiave utilizzata per crittografare i dati nel database SSO Enterprise. Pertanto, non possono essere decrittografati i dati e i messaggi di errore descritti in precedenza in questo modo viene attivata.

Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Per tutti i sistemi Enterprise SSO V5 per evitare questo problema e per tutti i sistemi che già si verificano questo problema, applicare questo hotfix. Questo hotfix non richiede alcuna azione aggiuntiva per prevenire e risolvere il problema.

Se l'hotfix è disponibile per il download, vi è una sezione "Hotfix Download disponibile" nella parte superiore di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta al servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=support

Nota: Il modulo "Hotfix Download disponibile" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario disporre di V5 Enterprise Single Sign-On (9.0.2096) installato.

Informazioni sul riavvio

Potrebbe essere necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.

versione a 32 bit (x86)

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Infocache.dll

9.0.2187.0

130,536

01-Oct-2014

22:00

x86

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

113,128

01-Oct-2014

22:00

x86

versione a 64 bit (x64)

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Infocache.dll

9.0.2187.0

130,536

01-Oct-2014

22:00

x86

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

113,128

01-Oct-2014

22:00

x86

Infocache.dll

9.0.2187.0

151,528

01-Oct-2014

22:00

x64

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

124,392

01-Oct-2014

22:00

x64


Nota a causa di dipendenze tra file, la correzione più recente contenente i file può contenere anche file aggiuntivi.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

È possibile applicare questo aggiornamento a qualsiasi Server di SSO Enterprise che si verifica il problema senza richiedere modifiche aggiuntive. Inoltre, questo aggiornamento da applicare a tutti i sistemi Enterprise SSO V5 per evitare il problema quando si esegue un'operazione di ripristino di chiave del segreto master.

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