Sintomi
Quando si esegue Microsoft BizTalk Accelerator 2010 per codice SWIFT (A4SWIFT) su un server che esegue Microsoft BizTalk Server 2010, i seguenti messaggi di errore potrebbero essere registrati nel registro applicazione:
Data
ora Avviso servername.fqdn servizio EventBus BAM 5 errore di esecuzione batch. Informazioni sull'eccezione: Impossibile avviare TDDS esecuzione batch dei flussi. SQLServer: nome_server, Database: BAMPrimaryImport.Parameter non è valido.
Dataora Errore 6 BAM EventBus Service servername.fqdn errore evento Execute. Si sono verificati errori durante l'esecuzione di eventi, vedere TDDS_FailedTrackingData tabella per ulteriori dettagli. SQLServer: nome_server, Database: BAMPrimaryImport.
Nota: Questo problema si verifica durante l'elaborazione di un riconoscimento (ACK) o un messaggio di riconoscimento negativo (NACK).
Causa
Questo problema si verifica perché alcuni parametri importanti, ad esempio ErrorNack, sessione, TimeSente sequenza, non sono definiti nel file di definizione di FrrActivities.xml.
Risoluzione
Prima di applicare questa correzione, è necessario eseguire il seguente comando da un prompt dei comandi con privilegi elevato:
C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking\bm.exe" remove-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Accelerator for SWIFT\BAMTracking\FrrActivities.xml
Dopo avere applicato questa correzione, è necessario eseguire il seguente comando da un prompt dei comandi con privilegi elevato:
C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking\bm.exe" deploy-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Accelerator for SWIFT\BAMTracking\FrrActivities.xml"
Informazioni sull'hotfix
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.
Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.
Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.
Prerequisiti
Per applicare questo hotfix, è necessario disporre di BizTalk Server 2010 installato.
Informazioni sul riavvio
Non è necessario riavviare il computer dopo avere applicato questo hotfix.
Informazioni sulla sostituzione
Questo hotfix non sostituisce eventuali hotfix precedentemente rilasciato.
La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
Piattaforma |
---|---|---|---|---|---|
Frractivities.xml |
Non applicabile |
10,689 |
18-Jul-2013 |
21:34 |
Non applicabile |
Stato
Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".
Ulteriori informazioni
Per ulteriori informazioni, vedere informazioni sugli aggiornamenti rapidi di BizTalk e cumulativo supporto per gli aggiornamenti.