Sintomi
Quando si modifica una colonna indicizzata in un elenco da una singola risposta per consentire più risposte, si verifica un errore:
"Il tipo di questa colonna non può essere modificato perché è attualmente in corso l'indicizzazione"
Questo è il comportamento previsto. Tuttavia, dopo aver eseguito questa operazione, tornare all'elenco mostrerà che i metadati per la colonna non sono più visibili.
Causa
Se si scelgono più selezioni per una colonna/campo, la possibilità di indicizzare la colonna non sarà disponibile (in base alla progettazione).
Risoluzione
Soluzione alternativa
-
Dopo aver riprodotto il problema, i metadati nella colonna "assegnato a" risultano mancanti.
-
Passare alla pagina impostazioni | Impostazioni elenco e fare clic su "colonne indicizzate"
-
"Assegnato a" è ancora impostato su indicizzato, quindi deseleziona e fai clic su "OK".
-
Tornare all'elenco (notare che la colonna "assegnata a" non contiene ancora metadati).
-
Quindi tornare a' impostazioni | Impostazioni elenco ' | scegliere la colonna "assegnata a" e il pulsante "Sì" per "Consenti selezione multipla".
-
Tornare all'elenco e notare che i metadati sono tornati per la colonna ' assegnato a'.
-
Ora gli utenti possono scegliere: lascia questo valore come campo multivalore o impostalo di nuovo su un singolo valore e quindi Aggiungi di nuovo come colonna indicizzata.