Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Si consideri lo scenario seguente:

  • Il servizio TN3270 Server cerca un certificato SSL da un provider di infrastruttura a chiave pubblica (PKI).

  • Il certificato SSL è un nome comune richiesto.

In questo scenario, il servizio Server TN3270 non trova il certificato SSL. Pertanto, non è possibile implementare il certificato SSL.

Quando si esamina una traccia Servizio TN3270 Server che viene acquisita mediante l'utilità analisi SNA, si possono vedere le seguenti righe di analisi:

Look for server auth cert with subject containing CN 'Sernername.Company.Com' Find a certificate with required subject CN Find Certificate in Store failed, error 0x80092004 Search 0 exhausted Find a certificate with required subject CN Find Certificate in Store failed, error 0x80092004 Search 1 exhausted Failed to get certificate from the store

Causa

Questo problema si verifica perché il nome comune del certificato emesso utilizza la codifica CERT_RDN_UTF8_STRING. Se la codifica CERT_RDN_PRINTABLE_STRING viene invece utilizzata, tutto funziona correttamente.

Risoluzione

Informazioni sull'hotfix



Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.
Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/default.aspx?scid=fh; [LN]; CNTACTMS

Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

È necessario disporre di pacchetto di aggiornamento cumulativo 10 per Microsoft Host Integration Server 2010 per applicare questo hotfix. Per ulteriori informazioni su come ottenere il pacchetto di aggiornamento cumulativo, fare clic sul numero seguente per visualizzare l'articolo della Microsoft Knowledge Base:

2917398 aggiornamento cumulativo 10 per Host Integration Server 2010

Ulteriori informazioni

Dopo avere applicato l'hotfix, il servizio TN3270 Server tenta di entrambe le codifiche durante la ricerca del certificato.

Informazioni sull'aggiornamento cumulativo

La correzione di questo problema è incluso nel pacchetto di aggiornamento cumulativo 3 per Host Integration Server 2013. Per ulteriori informazioni su come ottenere l'aggiornamento cumulativo pacchetto di aggiornamento, vedere 3 per Host Integration Server 2013 pacchetto di aggiornamento cumulativo.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×