Si applica a
Exchange Server 2016 Enterprise Edition Exchange Server 2016 Standard Edition Exchange Server 2013 Enterprise Edition Exchange Server 2013 Standard Edition

Sintomi

Si supponga di usare il cmdlet New-OWAVirtualDirectory o New-ECPVirtualdirectory per ricreare la directory virtuale "owa" o "ECP" in un server cassette postali di Microsoft Exchange Server 2013 o Microsoft Exchange Server 2016. In questo caso, quando gli utenti provano ad accedere a Outlook Web App, Outlook sul Web o all'interfaccia di amministrazione di Exchange, ricevono un codice di errore "Http 404". 

Causa

Questo problema si verifica perché è impostato un metodo di autenticazione errato per le directory virtuali "owa" e "ECP". Quando si esegue il cmdlet New-OWAVirtualDirectory o New-ECPVirtualdirectory per creare la directory virtuale "owa" o "ECP", il cmdlet abilita erroneamente l'autenticazione forms e l'autenticazione di base anziché autenticazione di Windows.

Soluzione alternativa

Per risolvere il problema, attenersi alla seguente procedura.

Per la directory virtuale "owa"

  1. Aprire Exchange Management Shell (EMS) e quindi eseguire il cmdlet seguente per modificare il metodo di autenticazione della directory virtuale "owa" in autenticazione di Windows:

    set-Owavirtualdirectory -identity "E15MBX\owa (Exchange Back End)" -WindowsAuthentication $True -Basicauthentication $false -Formsauthentication $false

  2. Eseguire il comando seguente sui server Accesso client e Cassette postali per riavviare Internet Information Services (IIS):

    iisreset /noforce

Per la directory virtuale "ECP"

  1. Iniziare Windows PowerShell.

  2. Digitare i comandi seguenti e quindi premere INVIO dopo ogni riga:

    Add-PSSnapin *exchange*Set-EcpVirtualDirectory -Identity "E15MBX\ecp (Exchange Back End)" -WindowsAuthentication $true -FormsAuthentication $false

  3. Eseguire il comando seguente sui server Accesso client e Cassette postali per riavviare Internet Information Services (IIS):

    iisreset /noforce

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