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Sintomi

Si consideri lo scenario seguente:

  • Si dispone di due computer che eseguono Windows Server 2008 o Windows Vista. Un computer invia un messaggio di autenticazione Kerberos a un altro computer.

  • L'autenticazione Kerberos utilizza l'algoritmo Advanced Encryption Standard (AES) per crittografare e decrittografare i dati di autenticazione.

In questo scenario, l'autenticazione Kerberos non riesce e il codice di errore 0X80090302 o 0x8009030f e viene visualizzato un messaggio di errore. Tuttavia, il messaggio di errore visualizzato può variare per applicazioni diverse. Ad esempio, se si tenta di connettersi a SQL Server 2005 o SQL Server 2008 Analysis Services utilizzando Excel, viene visualizzato uno dei seguenti messaggi di errore:

Messaggio 1

La funzione richiesta non è supportata

Messaggio 2

Il messaggio o fornito per la verifica della firma è stata modificata.

Causa

La funzione SpSealMessage e la funzione SpUnsealMessage non crittografare e decrittografare i messaggi di autenticazione correttamente quando la dimensione del messaggio non è divisibile per la dimensione del blocco previsto.

Risoluzione

Informazioni sull'hotfix

Importante  Quando si fa clic sul collegamento "Visualizza e Richiedi hotfix downloads", Windows Vista sarà l'unico prodotto che viene visualizzato. Tuttavia, la correzione per Windows Vista si applica a Windows Vista e Windows Server 2008.

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.


Importanti aggiornamenti rapidi di Windows Vista e Windows Server 2008 sono inclusi nel pacchetto stesso. Tuttavia, solo uno di questi prodotti può essere elencato nella pagina "Richiesta di aggiornamento rapido". Per richiedere il pacchetto di hotfix che si applica a Windows Vista e Windows Server 2008, è sufficiente selezionare il prodotto elencato nella pagina.

Prerequisiti

Per applicare questo hotfix, è necessario essere il computer sia in esecuzione uno dei seguenti sistemi operativi:

  • Windows Vista Service Pack 1 (SP1)

  • Windows Vista Service Pack 2 (SP2)

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Ambito dell'installazione di correzione

La correzione deve essere installato sul lato client e lato server della connessione. Se sono interessati numerosi client, può avere senso per implementare la correzione a tutti i sistemi Server 2008 e Windows Vista all'interno dell'organizzazione.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.


Per tutte le versioni basate su x86 di Windows Server 2008 e Windows Vista

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Kerberos.dll

6.0.6001.22435

500,736

18-May-2009

13:49

x86

Kerberos.dll

6.0.6002.22138

500,736

18-May-2009

13:44

x86

Per tutte le versioni basate su x64 di Windows Server 2008 e Windows Vista

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Requisiti SP

Ramo del servizio

Kerberos.dll

6.0.6001.22435

657,920

18-May-2009

14:04

x64

SP1

Non applicabile

Kerberos.dll

6.0.6001.22435

500,736

18-May-2009

13:49

x86

SP1

WOW

Kerberos.dll

6.0.6002.22138

657,920

18-May-2009

13:45

x64

SP2

Non applicabile

Kerberos.dll

6.0.6002.22138

500,736

18-May-2009

13:44

x86

SP2

WOW

Soluzione alternativa

Per aggirare il problema, utilizzare l'autenticazione NTLM anziché l'autenticazione Kerberos.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Per ulteriori informazioni sulla funzione SpSealMessage , visitare il seguente sito Web Microsoft:

http://msdn.microsoft.com/en-us/library/aa380181(VS.85).aspxPer ulteriori informazioni sulla funzione SpUnsealMessage , visitare il seguente sito Web Microsoft:

http://msdn.microsoft.com/en-us/library/aa380184(VS.85).aspxPer ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft


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