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Sintomi

Si supponga di disporre di un server che esegue Windows Server 2012 R2 o Windows Server 2008 R2 Service Pack 1 (SP1). Molti utenti di connettersi al server utilizzando una determinata applicazione desktop remota. In questo caso, la dimensione dell'hive del Registro di sistema seguente può superare il limite:

HKEY_USERS\.DEFAULTPertanto, gli utenti non possono connettersi al server.

Causa

Questo problema si verifica a causa di un errore che si verifica nei moduli Spooler di stampa. Quando un utente stabilisce una nuova sessione di desktop remota al server, le impostazioni della stampante dell'utente vengono scritte nella seguente sottochiave del Registro di sistema:

HKEY_USERS\.DEFAULT\Printers\DevModes2Tuttavia, le impostazioni della stampante non vengono mai eliminate. Di conseguenza, la dimensione dell'hive del Registro di sistema seguente diventa di grandi dimensioni e vari problemi sono causati da questo comportamento:

HKEY_USERS\.DEFAULT

Risoluzione

Aggiornamento cumulativo per Windows Server 2012 R2

Per risolvere questo problema in Windows Server 2012 R2, installare l'aggiornamento 2955164. Per ulteriori informazioni sull'aggiornamento di 2955164, fare clic sul numero seguente per visualizzare l'articolo della Microsoft Knowledge Base:

2955164 Windows RT 8.1, 8.1 di Windows e Windows Server 2012 R2 rollup di aggiornamento: maggio 2014Per risolvere questo problema in Windows Server 2008 R2, installare l'hotfix descritto in questo articolo.

Informazioni sull'hotfix per Windows Server 2008 R2

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Comprimere l'hive del Registro di sistema

Dopo aver installato questo aggiornamento, è consigliabile che l'operazione di compressione sul seguente hive del Registro di sistema se le dimensioni superano il limite: HKEY_USERS \. PREDEFINITOper comprimere l'hive del Registro di sistema, attenersi alla procedura nel seguente articolo della Microsoft knowledge base riportato di seguito:

Come comprimere gli hive del Registro di sistema "Diventare"Nota: Quando si eseguire la procedura seguente per comprimere HKEY_USERS \ . DEFAULT, il file hive può trovarsi in C:\windows\system32\config\DEFAULT.

Prerequisiti

Per applicare questo hotfix, è necessario eseguire Windows Server 2008 R2 SP1.

Per ulteriori informazioni su come ottenere un service pack di Windows 7 o Windows Server 2008 R2, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

976932 Informazioni sul Service Pack 1 per Windows 7 e Windows Server 2008 R2

Informazioni del Registro di sistema

Per applicare questo hotfix, non è necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

La versione globale di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e ore per questi file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.

Note di informazioni file di Windows Server 2008 R2Importante Aggiornamenti rapidi di Windows 7 e aggiornamenti rapidi di Windows Server 2008 R2 sono inclusi nel pacchetto stesso. Tuttavia, gli aggiornamenti rapidi nella pagina richiesta Hotfix sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella pagina in "Windows 7 e Windows Server 2008 R2". Fare sempre riferimento alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo a cui si applica ogni aggiornamento rapido .

  • I file relativi a un prodotto specifico, SR_Level (RTM, SPn) e un ramo del servizio (LDR, GDR) possono essere identificati esaminando i numeri di versione del file come indicato nella seguente tabella:

    Versione

    Prodotto

    Attività cardine

    Ramo del servizio

    6.1.760
    1.22 xxx

    Windows Server 2008 R2

    SP1

    LDR

  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente nella sezione "Ulteriori informazioni sui file per Windows Server 2008 R2". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associato, sono estremamente importanti per mantenere lo stato del componente aggiornato. I file catalogo di protezione elencati senza attributi sono firmati con firma digitale Microsoft.

Per tutte le versioni basate su x64 supportate di Windows Server 2008 R2

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Winspool.drv

6.1.7601.22406

442,880

30-Jul-2013

02:23

Non applicabile

Per tutte le versioni basate su IA-64 supportate di Windows Server 2008 R2

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Winspool.drv

6.1.7601.22406

863,232

30-Jul-2013

01:40

Non applicabile


Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file per Windows Server 2008 R2

File aggiuntivi per tutte le versioni basate su x64 supportate di Windows Server 2008 R2

Proprietà file

Valore

Nome del file

Amd64_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.1.7601.22406_none_f1ea4e45486130a1.manifest

Versione del file

Non applicabile

Dimensione del file

2,774

Data (UTC)

30-Jul-2013

Ora (UTC)

02:48

Piattaforma

Non applicabile

File aggiuntivi per tutte le versioni basate su IA-64 supportate di Windows Server 2008 R2

Proprietà file

Valore

Nome del file

Ia64_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.1.7601.22406_none_95cd56b79001c867.manifest

Versione del file

Non applicabile

Dimensione del file

2,772

Data (UTC)

30-Jul-2013

Ora (UTC)

02:14

Piattaforma

Non applicabile


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