Sintomi
Se si tenta di esportare o importare una cassetta postale usando New-MailboxExportRequest o New-MailboxImportRequest in Exchange Server 2010 con Service Pack 1 o una versione successiva, la richiesta potrebbe essere persa e potrebbe essere visualizzato il messaggio di errore seguente:
[PS] New-MailboxExportRequest -Mailbox "<mailbox_name>" -FilePath \\<server_name>\<share>\<file_name>.pst
Timeout della chiamata a "net.tcp://<server_name>/Microsoft.Exchange.MailboxReplicationService <server_name> (14.1.218.11 caps:07)". Dettagli errore: questa operazione di richiesta inviata a net.tcp://<server_name>/Microsoft.Exchange.MailboxReplicationService non ha ricevuto una risposta all'interno del timeout configurato (00:01:00). Il tempo allocato a questa operazione potrebbe essere stato parte di un timeout più lungo. È possibile che il servizio stia ancora elaborando l'operazione o che il servizio non sia riuscito a inviare un messaggio di risposta. Valutare l'aumento del timeout dell'operazione (eseguendo il cast del canale/proxy su IContextChannel e impostando la proprietà OperationTimeout) e assicurarsi che il servizio possa connettersi al client. + CategoryInfo : NotSpecified: (0:Int32) [New-MailboxExportRequest], TimeoutErrorTransientException + FullyQualifiedErrorId : 59EDFA88,Microsoft.Exchange.Management.RecipientTasks.NewMailboxExportRequest
Causa
Questo problema può verificarsi se è stata configurata una matrice di accesso client e viene usato un servizio di bilanciamento del carico. Quando il server Exchange tenta di accedere alla cassetta postale per la quale è stata richiesta l'importazione/esportazione, il server si connetterà all'endpoint MoMT (server di accesso client RPC) per il database, che nella maggior parte dei casi sarà il nome della matrice CAS. Se il bilanciamento del carico non è configurato correttamente per abilitare le connessioni dai server Exchange al VIP a cui risolve la matrice CAS, il bilanciamento del carico restituirà reimpostazioni che causeranno gli errori di timeout elencati in "Sintomi".
Risoluzione
Verificare che i server Exchange possano connettersi al servizio di bilanciamento del carico come client.Inoltre, sono state documentate le soluzioni alternative seguenti per consentire l'invio della richiesta di spostamento. Queste soluzioni alternative possono essere implementate se la connettività client dai server Exchange al servizio di bilanciamento del carico non è abilitata o non è possibile.
-
È possibile modificare il valore di RPCClientAccessServer nel database che contiene la cassetta postale che si desidera importare o esportare in modo che punti a un server CAS specifico invece di puntare alla matrice CAS che userà il bilanciamento del carico. Si tratta di un'impostazione dinamica che può essere modificata in base alle esigenze.
-
È possibile utilizzare l'opzione -MRSServer nel cmdlet New-MailboxExportRequest o New-MailboxImportRequest e specificare un server CAS che non fa parte della matrice CAS.
-
È possibile aggiungere una voce al file Hosts in uno o più server CAS che risolve il nome della matrice CAS al localhost.
Ulteriori informazioni
Quando viene inviata una richiesta di importazione o esportazione di una cassetta postale, questo processo richiede diversi passaggi. Nel complesso, è molto simile al processo di richiesta di spostamento. Il processo di base include i passaggi seguenti:
-
Il server Exchange a cui è connessa la sessione remota di Powershell crea la richiesta di esportazione/importazione. Come parte della convalida eseguita durante la fase di creazione, questo server Exchange si connetterà all'endpoint MoMT e tenterà di accedere (tramite MAPI.Net) alla cassetta postale in cui si sta tentando di esportare o importare. Se la convalida ha esito positivo, nella cassetta postale di sistema del database che contiene la cassetta postale da esportare o importare verrà inserito uno speciale messaggio FAI. La richiesta verrà inserita nello stato "In coda".Nota Questo è il passaggio che ha esito negativo con l'errore come descritto in precedenza, quindi la richiesta non viene mai creata e mai inserita nella cassetta postale di sistema.
-
Tutte le istanze MRS all'interno dello stesso sito di Active Directory controllano periodicamente la cassetta postale. Se nel comando non è specificato alcun valore MRSServer, ne verrà selezionato uno in modo casuale. Se nel comando viene designato uno specifico MRSServer, verrà utilizzata l'istanza MRS.
-
Mrs inizia l'esportazione (o l'importazione) e, al termine, cambia lo stato della richiesta "Completato".
-
Facoltativamente, la richiesta di esportazione o importazione può essere cancellata da un amministratore.
Per altre informazioni sulle richieste di importazione ed esportazione, vedere il seguente articolo di TechNet: