Sintomi
I dispositivi SATA interni (HDD o SSD) possono essere visualizzati come supporti rimovibili nella barra delle applicazioni.
Causa
Se un dispositivo è considerato rimovibile è determinato dal BIOS del sistema e da come contrassegna le varie porte SATA sulla scheda madre. Il driver della posta in arrivo esamina direttamente le porte SATA e considera i dispositivi connessi a tali porte contrassegnati come "esterni" come dispositivi rimovibili. Non tutti i driver di archiviazione lo fanno, il che può essere una potenziale causa di danneggiamento o perdita di dati.
Risoluzione
Innanzitutto, controlla e installa gli aggiornamenti del BIOS disponibili rilasciati dal produttore del PC. Se non sono disponibili, è possibile seguire questa procedura per sostituire il modo in cui il driver della posta in arrivo mostra i dispositivi su determinate porte:
-
Aprire un prompt dei comandi con privilegi di amministratore.
-
Nella finestra del prompt dei comandi digita il comando seguente in invio: devmgmt.msc
-
In Unità disco identifica il dispositivo SATA che vuoi che il driver della posta in arrivo consideri le proprietà interne e aperte del dispositivo facendo clic con il pulsante destro del mouse e selezionando Proprietà.
-
Si noti il numero di bus dalla panoramica delle proprietà ("1" nell'esempio seguente).
-
Per Windows 7:
-
Digitare il comando seguente nel prompt dei comandi aperto in precedenza e premere INVIO:
reg.exe aggiungere "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channelx\" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001 Dove xcorresponds al numero di bus annotato nel passaggio 4.
-
-
Per Windows 8 e versioni successive:
-
Digitare il comando seguente nel prompt dei comandi aperto in precedenza e premere INVIO:
reg.exe aggiungere "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device" /f /v TreatAsInternalPort /t REG_MULTI_SZ /d x Dove x corrisponde al numero di bus annotato nel passaggio 4.
-