Applies ToWindows 7 Home Basic Windows 7 Home Premium Windows 7 Enterprise Windows 7 Professional Windows 7 Starter Windows 7 Ultimate Windows Vista Business Windows Vista Enterprise Windows Vista Home Basic Windows Vista Home Premium Windows Vista Starter Windows Vista Ultimate Microsoft Windows XP Home Edition Microsoft Windows XP Professional Microsoft Windows XP Service Pack 2 Windows 8 Windows 8.1

Il supporto per Windows Vista Service Pack 1 (SP1) è terminato il 12 luglio 2011. Per continuare a ricevere gli aggiornamenti della sicurezza per Windows, assicurarsi di utilizzare Windows Vista con Service Pack 2 (SP2). Per altre informazioni, consulta questa pagina Web Microsoft: Il supporto per alcune versioni di Windows sta per terminare.

Sintomi

Si prova a scaricare un file di dimensioni maggiori di 50000000 byte da una cartella Web in Windows XP Service Pack 2 (SP2) o in una versione successiva di Windows. Potrebbe essere visualizzato un messaggio di errore simile al seguente:

Impossibile copiare NomeFile:impossibile leggere dal file o dal disco di origine

Nota: In questo messaggio di errore FileName è un segnaposto per il nome del file. Questo problema si verifica anche in un computer basato su Windows Vista o in un computer basato su Windows XP Service Pack 1 (SP1) in cui è installato l'aggiornamento di sicurezza 896426 (MS05-028).In questo scenario in Windows 7, 8 o 8.1 potrebbe essere visualizzato il messaggio di errore seguente:

Copia cartella

Si è verificato un errore imprevisto che non consente di copiare la cartella. Se l'errore persiste, è possibile usare il codice di errore per cercare assistenza per il problema.

Errore 0x800700DF: Le dimensioni del file superano il limite consentito e non possono essere salvate.

<nome file>

Riprova Annulla

Causa

Questo problema si verifica perché una modifica della sicurezza introdotta in Windows XP SP2 influisce sul redirector WebDAV (Web Distributed Authoring and Versioning). Questa modifica alla sicurezza assicura che un server non autorizzato non possa forzare un computer client in un attacco Denial of Service. Se si prova a scaricare un file di dimensioni superiori a 50000000 byte, il computer client interpreta il download come un attacco Denial of Service. Di conseguenza, il processo di download si interrompe.

Risoluzione

Importante Questa sezione, metodo o attività contiene i passaggi che spiegano come modificare il Registro di sistema. L'errata modifica del Registro di sistema può causare seri problemi. Per questo motivo, occorre attenersi scrupolosamente alla procedura indicata. Per una maggiore sicurezza, eseguire una copia di backup del Registro di sistema prima di modificarlo. in modo da poterlo poi ripristinare in caso di problemi. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows Se si dispone di Windows XP SP2, Vista o 7, passare alla sezione " Fix it for me " per eseguire Fix it. Se preferisci risolvere il problema manualmente o se utilizzi Windows 8 o 8.1, vai alla sezione"Risoluzionedel problema manualmente".

Windows XP SP2, Vista o 7: correzione per me

Per risolvere il problema automaticamente, fare clic sul collegamento o sul pulsante Correggi. Quindi fare clic su Esegui nella finestra di dialogo Download file e seguire i passaggi della procedura guidata Correggilo.Nota: questa correzione non funziona con Windows 8 o versioni successive.

Note

  • Quando si esegue la procedura guidata Fix it, è necessario immettere un valore FileSizeLimitInBytes maggiore delle dimensioni del file da scaricare.

  • Questa procedura guidata è disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.

  • Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Mix IT su un'unità di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.

Passare quindi alla sezione "Il problema è stato risolto?"

Correzione manuale del problema

Per risolvere il problema, seguire questa procedura:

  1. Windows XP SP2, Vista o 7: fare clic sul pulsante Start,scegliere Esegui,digitare regedit e quindi fare clic su OK.Windows 8 o versioni successive: scorrere rapidamente da destra per visualizzare gli accessi, quindi selezionare Cerca e digitare regedit (o digitare regedit dalla schermata Start). Selezionare regedit nei risultati della ricerca per eseguirlo.

  2. Individuare e selezionare la seguente sottochiave del Registro di sistema:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

  3. Nel riquadro destro fare clic con il pulsante destro del mouse sul valore FileSizeLimitInBytes e quindi scegliere Modifica.Se il valore FileSizeLimitInBytes non è visualizzato, fare clic con il pulsante destro del mouse nello spazio vuoto nel riquadro destro, scegliere Nuovo, fare clic su Valore DWORD,digitare FileSizeLimitInBytes e quindi fare clic su OK.

  4. Nella casella Modifica valore DWORD fare clic per selezionare l'opzione Decimale. Nella casella Dati valoredigitare un valore superiore alle dimensioni del file da scaricare. Scegliere OK.Nota Il valore predefinito per il limite di dimensioni del file è 50000000 byte.

  5. Chiudere l'Editor del Registro di sistema. Riavviare il computer.

Il problema è stato risolto?

  • Verificare se il problema è stato risolto. Se il problema è stato risolto, non occorre leggere il resto della sezione. Se il problema persiste, è possibile contattare il supporto tecnico.

  • Inviare commenti e suggerimenti. Per inviare feedback o segnalare eventuali problemi con la soluzione, lasciare un commento nel blog "Correggi il problema perme"o inviarci un messaggio di posta elettronica.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.