Sintomi

Quando si avvia il portale aziendale in Microsoft Dynamics GP o in Microsoft Dynamics SL su una workstation, viene visualizzato il messaggio di errore seguente:

Errore: il nome dell'entità servizio (SPN) per l'utente 'dominio\utente' non è stato trovato in Active Directory

Causa

Questo problema si verifica quando si verificano le condizioni seguenti:

  • Il server virtuale viene esteso SharePoint Amministrazione centrale.

  • L'autenticazione Kerberos è selezionata.

  • Il servizio directory Active Directory non è configurato per l'uso dell'autenticazione Kerberos.

Risoluzione

Per risolvere il problema, usare l'autenticazione NTLM invece dell'autenticazione Kerberos.Nota Se è necessario usare l'autenticazione Kerberos, visitare il seguente sito Web Microsoft per altre informazioni:

http://www.microsoft.com/windowsserver2003/technologies/security/kerberos/default.mspx Per abilitare l'autenticazione NTLM, seguire questa procedura:

  1. Nel server che esegue Microsoft Internet Information Services (IIS) fare clic su Start, scegliere Esegui, digitare cmd e quindi fare clic su OK.

  2. Al prompt dei comandi digitare il comando seguente e quindi premere INVIO:

    cd Unità:\inetpub\adminscriptsNote Sostituire l'unità con il nome dell'unità disco rigido in cui è installato Windows Server 2003.

  3. Al prompt dei comandi digitare il comando seguente e quindi premere INVIO:

    cscript adsutil.vbs ottenere w3svc/xx/NTAuthenticationProvidersNote Sostituire xx con il numero di ID del server virtuale. Per determinare il numero di ID del server virtuale, seguire questa procedura:

    1. Nel server che esegue IIS fare clic su Start, scegliere Tutti i programmi ,Strumenti di amministrazione equindi fare clic su Gestione Internet Information Services (IIS).

    2. Espandere il nome del computer, espandere Siti Web, fare clic con il pulsante destro del mouse sul sito Web in cui è installato il portale aziendale e quindi scegliere Proprietà.

    3. Fare clic sulla scheda Sito Web e quindi su Proprietà accanto alla casella Formato log attivo.

    4. Prendere nota del percorso e del nome del file di log. Il percorso e il nome del file sono simili ai seguenti:

      W3SVCxx\exyymmdd.logIn questo percorso, xx rappresenta il numero di ID del server virtuale.

  4. Per abilitare l'autenticazione NTLM nel server virtuale, digitare il comando seguente al prompt dei comandi e quindi premere INVIO:

    cscript adsutil.vbs set w3svc/xx/NTAuthenticationProviders "NTLM"Nota Sostituire xx con il numero di ID del server virtuale specificato nel passaggio 3.

  5. Riavviare IIS. A questo scopo, seguire questa procedura:

    1. Fare clic su Start, scegliere Esegui, digitare cmd e quindi fare clic su OK.

    2. Al prompt dei comandi digitare iisreset e quindi premere INVIO.

    3. Al prompt dei comandi digitare exit e quindi premere INVIO.

  6. Avviare Microsoft Internet Explorer su una workstation e quindi digitare l'URL seguente sulla barra degli indirizzi:

    http://xx/sites/businessportalNote Sostituire xx con il nome del server.

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