Messaggio di errore quando si installa un pacchetto di aggiornamento con estensione msu in un computer che esegue Windows: "I moduli di Windows Installer deve essere aggiornato prima di installare questo pacchetto"

Sintomi

Quando si installa un pacchetto di aggiornamento msu in un computer che esegue Windows, è che venga visualizzato il seguente messaggio di errore:

I moduli di Windows Installer deve essere aggiornato prima di poter installare questo pacchetto. Aggiornare i moduli di Windows Installer sul computer, quindi ritentare l'installazione.

Quando si utilizza uno script per installare il pacchetto di aggiornamento msu, l'installazione non riesce. Quando si verifica questo problema, il processo di Wusa.exe restituisce il codice di errore 0x800f0823.

Causa

Questo problema si verifica perché l'installazione richiede una nuova versione di Windows Installer moduli o stack di manutenzione.

Risoluzione

Per risolvere questo problema, utilizzare Windows Update per aggiornare Windows Installer moduli o stack di manutenzione. In alternativa, è possibile scaricare gli aggiornamenti elencati nella tabella riportata di seguito dal Microsoft Download Center.

Sistema operativo

Numero KB

Windows Vista e Windows Server 2008

Windows 7 e Windows Server 2008 R2

Windows 8 e Windows Server 2012

Windows 8.1 e Windows Server 2012 R2

Ulteriori informazioni

Quando si utilizza Windows Update, è necessario Windows Installer moduli o l'aggiornamento dello stack di manutenzione. Tuttavia, quando si installa un pacchetto di aggiornamento msu, il programma di installazione non si connette a Windows Update per aggiornare Windows Installer moduli o stack di manutenzione.

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

×