Si applica a
Microsoft Dynamics AX 4.0 Axapta Object Server

Sintomi

Quando si prova ad avviare il client Microsoft Dynamics AX 4.0, viene visualizzato il messaggio di errore seguente:

Impossibile stabilire la connessione

Causa

Questo problema può avere una delle cause seguenti:

  • Il servizio Server oggetti applicativi (AOS) non è in esecuzione. Vedere la risoluzione 1 nella sezione "Risoluzione".

  • Il client Microsoft Dynamics AX non è configurato per l'uso della porta TCP/IP corretta. Vedere la risoluzione 2 nella sezione "Risoluzione".

  • La versione del servizio AOS non corrisponde alla versione del client Microsoft Dynamics AX. Vedere la risoluzione 3 nella sezione "Risoluzione".

  • La workstation client non ha accesso alla rete. In caso contrario, la workstation client non può connettersi al server AOS. Vedere la risoluzione 4 nella sezione "Risoluzione".

  • Il client Microsoft Dynamics AX è connesso a un firewall o a più domini. Vedere la risoluzione 5 nella sezione "Risoluzione".

  • I criteri locali non concedono il diritto "Accedi al computer dalla rete" ai client AOS nella stessa rete. Vedere la risoluzione 6 nella sezione "Risoluzione".

Risoluzione

Per risolvere il problema, usare la risoluzione appropriata.

Risoluzione 1

Per risolvere il problema, avviare il servizio AOS. A tal fine, attenersi alla seguente procedura:

  1. Fare clic su Start, scegliere Tutti i programmi, Strumenti di amministrazionee quindi fare clic su Servizi.

  2. Individuare il servizio Microsoft Dynamics AOS (Application Object Server).

  3. Se il servizio non è in esecuzione, fare clic con il pulsante destro del mouse sul servizio e quindi scegliere Avvia.Nota Il nome del servizio AOS usa il formato seguente:

    Dynamics Server$ instance-number AOS-instance-name

Risoluzione 2

Per risolvere il problema, verificare che l'utilità di configurazione del server Microsoft Dynamics AX utilizzi la porta TCP/IP corretta. Verificare quindi che per il client Microsoft Dynamics AX sia usata la porta corretta. A tal fine, attenersi alla seguente procedura:

  1. Fare clic su Start, scegliere Tutti i programmi, Strumenti di amministrazionee quindi fare clic su Utilità di configurazione del server Microsoft Dynamics AX.

  2. Fare clic sull'istanza appropriata del server AOS e sulla configurazione appropriata.

  3. Fare clic sulla scheda Server oggetti applicativi.

  4. Verificare che il numero di porta nella casella Porta TCP/IP sia corretto e quindi fare clic su OK.

  5. Fare clic sul pulsante Start, scegliere Tutti iprogrammi , Strumenti di amministrazionee quindi fare clic su Utilità di configurazione di Microsoft Dynamics AX.

  6. Fare clic sulla scheda Connessione.

  7. Prendere nota del numero di porta TCP/IP. Se il nome del server AOS e il numero di porta non sono corretti, digitare il nome del server AOS corretto. Digitare quindi il numero di porta verificato nel passaggio 4.

  8. Scegliere OK.

Risoluzione 3

Per risolvere il problema, verificare che la versione del servizio AOS corrisponda alla versione del client Microsoft Dynamics AX. A questo scopo, seguire questa procedura:

  1. Individuare la versione del client Microsoft Dynamics AX. A tal fine, attenersi alla seguente procedura:

    1. Nel menu ? fare clic su Informazioni su Microsoft Dynamics AX.

    2. Prendere nota della versione del kernel e della versione dell'applicazione.

  2. Individuare la versione del servizio AOS. A tal fine, attenersi alla seguente procedura:

    1. Individuare il file Ax32Serv.exe nel server AOS.Nota Per impostazione predefinita, il file Ax32Serv.exe si trova nella cartella seguente:

      C:\Microsoft Dynamics AX\40\Server\AX40SP1\Bin

    2. Fare clic con il Ax32Serv.exe e quindi scegliere Proprietà.

    3. Nella finestra di dialogo Proprietà fare clic su Dettagli.

    4. Nella scheda Dettagli prendere nota della versione del servizio AOS nel campo Versione file.

Risoluzione 4

Per risolvere questo problema, attenersi alla seguente procedura:

  1. Fare clic su Start e su Esegui, digitare cmd nella casella Apri e quindi fare clic su OK.

  2. Al prompt dei comandi eseguire il comando seguente.

    ping <computer name>

    Se il comando non riesce o se il comando non restituisce i valori corretti, la workstation client non ha accesso alla rete.

Risoluzione 5

Per risolvere il problema, seguire questa procedura.Nota Per eseguire questa procedura, è necessario essere membri del gruppo Domain Admins.

  1. Fare clic sulpulsante Start , scegliere Strumenti di amministrazione , scegliere Criteri di sicurezza Impostazioni, Criteri locali equindi fare clic su Assegnazione diritti utente nell'AOS.

  2. Fare clic su Accedi al computer dalla rete.

  3. Fare clic per selezionare la casella di controllo Definisci queste impostazioni dei criteri.

  4. Aggiungere gli utenti a cui connettersi all'AOS e i gruppi di utenti da connettere all'AOS.

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