Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Quando si riavvia o arresta un computer basato su Windows Server 2003, viene visualizzato uno dei seguenti messaggi di errore irreversibile durante il processo di arresto:

STOP 0x000000CE (parametro1, 0x00000000, parametro3, 0x00000000)
DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS

Stop 0x00000050 (parametro1, 0x00000000, parametro3, 0x00000000)
PAGE_FAULT_IN_NONPAGED_AREA

Note

  • I parametri nei messaggi di errore Stop possono variare a seconda della configurazione del computer.

  • Questo problema si verifica in modo casuale.

Causa

Quando il sistema viene arrestato, viene inserito un elemento di lavoro correlato al driver Mrxsmb. sys in una coda dalla funzione ExQueueWorkItem . Tuttavia, la funzione ExQueueWorkItem non fornisce un meccanismo per verificare che l'oggetto di periferica associato all'elemento di lavoro specificato sia disponibile prima dell'elaborazione dell'elemento di lavoro. Pertanto, se il driver Mrxsmb. sys viene scaricato prima al termine dell'elemento della coda di lavoro, il sistema genera un errore irreversibile.

Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario disporre di Windows Server 2003 Service Pack 1 o Windows Server 2003 Service Pack 2.

Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

889100 informazioni su come ottenere il service pack più recente per Windows Server 2003

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.

Windows Server 2003 con Service Pack 1, versioni basate su x86

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Mrxsmb.sys

5.2.3790.3276

438,784

07-Jan-2009

11:39

x86

Windows Server 2003 con Service Pack 2, versioni basate su x86

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Mrxsmb.sys

5.2.3790.4441

438,784

07-Jan-2009

11:44

x86

Windows Server 2003 con Service Pack 1, versioni basate su Itanium

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Mrxsmb.sys

5.2.3790.3276

1,172,992

07-Jan-2009

00:41

IA-64

Windows Server 2003 con Service Pack 2, versioni basate su Itanium

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Mrxsmb.sys

5.2.3790.4441

1,173,504

07-Jan-2009

00:47

IA-64

Windows Server 2003 con Service Pack 1, versioni basate su x64

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Mrxsmb.sys

5.2.3790.3276

786,944

07-Jan-2009

00:41

x64

Windows Server 2003 con Service Pack 2, versioni basate su x64

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Mrxsmb.sys

5.2.3790.4441

787,456

07-Jan-2009

00:49

x64

Windows XP Professional x64 Edition con Service Pack 1

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Mrxsmb.sys

5.2.3790.3276

786,944

07-Jan-2009

00:41

x64

Windows XP Professional x64 Edition con Service Pack 2

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Mrxsmb.sys

5.2.3790.4441

787,456

07-Jan-2009

00:49

x64

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Le funzioni ExInitializeWorkItem ed ExQueueWorkItem possono essere utilizzate solo quando l'elemento di lavoro specificata non è associato a qualsiasi oggetto di periferica o stack di dispositivo. In tutti gli altri casi, i driver devono utilizzare le routine di IoAllocateWorkItem, IoFreeWorkIteme IoQueueWorkItem . Solo queste routine garantiscono che l'oggetto di periferica associato all'elemento di lavoro specificato rimane disponibile fino a quando l'elemento di lavoro è stata elaborata.

Per ulteriori informazioni, visitare il seguente sito Web Microsoft Developer Network:

http://msdn.microsoft.com/en-us/library/ms791491.aspxPer ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Supporto tecnico per versioni basate su x64 di Microsoft Windows

Se l'hardware fornito con un'edizione di Microsoft Windows x64 è già installata, il produttore dell'hardware offre supporto tecnico e assistenza per Windows x64 edition. In questo caso, il produttore dell'hardware fornisce supporto poiché una Windows x64 edition è stato inclusa con l'hardware. Il produttore dell'hardware potrebbe avere personalizzato l'installazione di Windows x64 utilizzando componenti univoci. Quali specifici driver di periferica o impostazioni facoltative per ottimizzare le prestazioni dell'hardware. Se è necessario disporre di assistenza tecnica con una Windows x64 edition, Microsoft fornirà assistenza ragionevole sforzo. Tuttavia, potrebbe essere necessario contattare direttamente il produttore. Il soggetto più qualificato per supportare il software preinstallato sull'hardware. Se è stata acquistata separatamente una versione x64 di Windows come una Windows Server 2003 x64 edition, contattare il supporto tecnico Microsoft.

Per informazioni su Windows XP Professional x64 Edition, visitare il seguente sito Web Microsoft:

http://www.microsoft.com/windowsxp/64bit/default.mspxPer informazioni sulle versioni basate su x64 di Windows Server 2003, visitare il seguente sito Web Microsoft:

http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×