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Sintomo

Durante l'utilizzo di Microsoft Dynamics CRM on-premise utenti potrebbero essere necessario immettere le credenziali di autenticazione ogni 24 ore. Questa situazione può verificarsi per entrambi gli utenti del client web con gli utenti del client di Outlook di Microsoft Dynamics CRM.

Questa operazione verrà eseguita solo per le distribuzioni che dispongono di autenticazione delle attestazioni abilitato.

Causa

Una delle possibili cause di questo problema è che le attestazioni di impostazione SessionSecurityTokenLifetimeInHours è impostata su un valore pari a 24 ore. Questo è il valore predefinito.

Risoluzione

Le attestazioni di impostazione SessionSecurityTokenLifetimeInHours saranno necessario aggiornare in maniera diversa da 24. In questo caso particolare, è stata impostata su una settimana.

1. sul server in cui è installato il ruolo di individuazione CRM Dynamics, aprire una finestra di comando di PowerShell.
2. eseguire i seguenti comandi dalla finestra.

$Settings = get-CrmSetting - SettingType - DwsServerUrl ClaimsSettings https://CrmDiscoverServer.domain.com -$creds di credenziali
$Setting.SessionSecurityTokenLifetimeInHours = '168'
Set-CrmSetting - DwsServerUrl https://CrmDiscoverServer.domain.com -$creds di credenziali $setting

3. al termine, verificare che il valore della durata è 168 eseguendo il seguente comando.

Get-CrmSetting - SettingType - DwsServerUrl ClaimsSettings https://CrmDiscoverServer.domain.com -$creds di credenziali

4. a questo punto, riavviare IIS sui server front-end.
5. infine, riavviare Outlook per tutti gli utenti che si verifica il problema definito nella sezione sintomo

NOTA:

Nell'esempio precedente, l' URL https://CrmDiscoverServer.domain.com , sarà necessario aggiornare l'URL del server con il ruolo nella distribuzione di Microsoft Dynamics CRM.

Gli utenti continuerà a verificarsi la richiesta di autenticazione delle credenziali ma eseguendo queste istruzioni, il prompt dei comandi verranno eseguite ogni 7 giorni a meno che non si riavvia Outlook e/o del browser. Riavviare Outlook/browser consente di rinnovare i token di protezione e consentirà agli utenti di non visualizzare la richiesta di autenticazione.

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