Si applica a
Outlook 2016 Outlook 2013

Sintomi

Se 2016 di Microsoft Outlook o Outlook 2013 viene distribuito utilizzando lo strumento di personalizzazione di Microsoft Office (OCT) in Windows 10, 2016 Outlook o Outlook 2013 non visualizza nuovo messaggio di posta elettronica gli allarmi del desktop (notifiche toast).

Causa

È stato introdotto un nuovo requisito di Windows per le notifiche toast 10 di Windows, versione 1607, e viene applicato a partire da Windows 10, versione 1709. Il requisito di Windows specifica che il collegamento di un'applicazione nel menu di avvio deve contenere un tag AppUserModelID . Tuttavia, il collegamento di Outlook che viene creato dal PTOM non contiene il tag AppUserModelID, in modo che le notifiche popup non vengono visualizzate.

Per le applicazioni desktop che inviano notifiche popup, è necessario includere il tag di AppUserModelID di scelta rapida dell'applicazione nella schermata iniziale di ogni volta che si chiama il metodo CreateToastNotifier . In caso contrario, le notifiche di avvisi non saranno visualizzate. Per ulteriori informazioni, vedere delle Guide rapide: invio di una notifica popup dal desktop.

Risoluzione

Per ovviare a questo problema, attenersi alla seguente procedura:

  1. Eseguire un'installazione di Windows installer (MSI) di Outlook senza l'utilizzo dei PTOM. Quindi, verrà creato il collegamento di Outlook che contiene il tag AppUserModelID nella seguente posizione: C:\ProgramData\Microsoft\Windows\Start Avvio\Programmi

  2. Copiare il nuovo collegamento di Outlook e distribuirla nei computer che presentano il problema.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.