Sintomi
Considerare lo scenario descritto di seguito:
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Si dispone di un'applicazione di terze parti che imposta un ordine non corretto per l'elenco di controllo di accesso di una cartella Calendario in una cassetta postale.
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Si sposta la cassetta postale che contiene la cartella Calendario in un server delle cassette postali Microsoft Exchange Server 2010. L'operazione di spostamento è stata completata.
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Si prova a modificare le autorizzazioni di accesso della cartella Calendario usando un'applicazione Exchange Web Service (EWS) oppure un'applicazione MAPI, come Microsoft Outlook.
In questo scenario non è possibile modificare le autorizzazioni di accesso della cartella Calendario.
Causa
Questo problema si verifica a causa di un errore quando l'archivio di Exchange convalida gli elenchi di controllo di accesso canonici. Di conseguenza, l'applicazione MAPI o EWS non può recuperare la tabella dell'elenco di controllo di accesso della cartella Calendario.
Risoluzione
Per risolvere il problema, installare l'aggiornamento cumulativo seguente:
2685289 Descrizione dell'aggiornamento cumulativo 3 per Exchange Server 2010 Service Pack 2 Dopo l'installazione dell'aggiornamento, è possibile abilitare la convalida degli elenchi di controllo di accesso canonici configurando una chiave del Registro di
sistema. Per abilitare automaticamente la convalida degli elenchi di controllo di accesso canonici, passare alla sezione " Risolvereil problema per me". Se si preferisce abilitare manualmente la convalida degli elenchi di controllo di accesso canonici, passare alla sezione "Risoluzionedeiproblemi".
Correzione automatica
Per abilitare automaticamente la convalida degli elenchi di controllo di accesso canonici, fare clic sul pulsante Fix it o sul collegamento. Quindi fare clic su Esegui nella finestra di dialogo Download file e seguire i passaggi della procedura guidata Fix it.
Note
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Installare l'aggiornamento descritto nell'articolo 2685289 della Microsoft Knowledge Base (KB) prima di eseguire questa soluzione Fix it.
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Questa procedura guidata è disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.
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Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Mix IT su un'unità di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.
Passare quindi alla sezione "Il problema è stato risolto?".
Correzione manuale del problema
Per abilitare la convalida degli elenchi di controllo di accesso canonici configurando una chiave del Registro di sistema, seguire questa procedura:
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Aprire l'Editor del Registro di sistema. A questo scopo, fare clic sul pulsante Start,digitare regedit nella casella Inizia ricerca e quindi premere INVIO.
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Individuare e fare clic sulla sottochiave del Registro di sistema seguente: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
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Scegliere Nuovo dal menu Modifica equindi fare clic su Valore DWORD (32 bit).
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Digitare CheckCanonicalACLDuringMove, quindi premere INVIO.
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Scegliere Modifica dal menu Modifica.
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Nella casella Dati valore digitare 1 e quindi fare clic su OK.
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Uscire dall'editor del Registro di sistema.
Dopo aver abilitato la convalida degli elenchi di controllo di accesso canonici, non è possibile spostare cartelle in cui l'elenco di controllo di accesso non è in ordine canonico. Inoltre, viene visualizzato il messaggio di errore seguente quando si prova a spostare la cartella:
Errore: MapiExceptionInvalidParameter: Impossibile impostare le proprietà sull'oggetto. (hr=0x80070057, ec=-2147024809)
Contesto diagnostico:
Id: 55847 EMSMDBPOOL. EcPoolSessionDoRpc called [length=267]
Lid: 43559 EMSMDBPOOL. EcPoolSessionDoRpc ha restituito [ec=0x0][length=232][latency=0]
Lid: 23226 --- POOL Parse Start ---
Lid: 27962 SESSION: netteSetProps
[10] Lid: 17082 POOL Error: 0x80070057
Lid: 30561
Lid 21921 StoreEc: 0x80070057
Lid: 27962 PIÙ. PIÙ.SE: êExtendedError [250]
Lid: 1494 ---- Remote Context Beg ----
Lid: 26426 PIÙ.ZIONI: netteSetProps [10]
Lid: 21970 StoreEc: 0x8004010F PropTag: 0x668F0040
Lid: 25000
Lid: 24936
Lid: 24952
Lid: 47113
Lid: 7915 StoreEc: 0x80070057
Lid: 5263 StoreEc: 0x80070057
Lid: 19768
Lid: 4559 StoreEc: 0x80070057
ID: 1750 ---- Remote Context End ----
Lid: 26849
Lid: 21817 Errore IDI: 0x80070057
Lid: 25761
Lid: 1940 StoreEc: 0x80070057
Lid: 25297
Lid: 21201 StoreEc: 0x80070057
Il problema è stato risolto?
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Verificare se il problema è stato risolto. Se il problema è stato risolto, non occorre leggere il resto della sezione. Se il problema persiste, è possibile contattare il supporto tecnico.
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Inviare commenti e suggerimenti. Per inviare feedback o segnalare eventuali problemi con la soluzione, lasciare un commento nel blog "Correggi il problema perme"o inviarci un messaggio di posta elettronica.
Ulteriori informazioni
Per altre informazioni sugli elenchi di controllo di accesso, visitare il sito Web Microsoft seguente:
Informazioni generali sugli elenchi di controllo di accessoPer altre informazioni sulle voci del controllo di accesso, visitare il sito Web Microsoft seguente:
Informazioni generali sulle voci di controllo di accessoPer altre informazioni su come usare Visual Basic e ADsSecurity.dll per ordinare in modo idoneo le voci ACL in un ACL, visitare il sito Web Microsoft seguente:
Come usare i Visual Basic e ADsSecurity.dll ordinare in modo idoneo le voci ACE in un ACL