Pacchetto cumulativo di 3146709 per .NET Framework 4.5, 4.5.1 e 4.5.2 in Windows

In questo articolo viene cumulativo di hotfix 3146709, disponibile per il Microsoft.NET Framework 4.5, 4.5.1 e 4.5.2. Per ulteriori informazioni sui problemi risolti con questo cumulativo, vedere la sezione "problemi risolti con questo hotfix cumulativo".

Risoluzione

I seguenti file sono disponibili per il download da Microsoft Download Center:

Download Download del pacchetto di x86.

Download Download del pacchetto di x64.

Per ulteriori informazioni su come scaricare i file di supporto Microsoft, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

119591 come ottenere file di supporto Microsoft dai servizi onlineMicrosoft ha analizzato questo file per individuare eventuali virus. Microsoft ha utilizzato il software antivirus più recente disponibile alla data in cui il file è stato registrato. Il file è archiviato in un server con protezione avanzata che impedisce modifiche non autorizzate al file.

Nota: Per verificare la versione hotfix di aggiornamento, controllare il valore della parola chiave rilascio per determinare la versione installata. Per essere compatibile in avanti, è possibile cercare un valore che è maggiore o uguale a quello elencato nella tabella riportata di seguito.

Versione di aggiornamento cumulativo di hotfix

Valore di emissione DWORD

Pacchetto cumulativo di 3146709 per .NET Framework 4.5 e versioni successive

380035

Per ulteriori informazioni su come determinare le versioni di.NET Framework, vedere How to: determinare quali versioni di.NET Framework sono installati.

Ulteriori informazioni

Prerequisiti

Per applicare questo hotfix, è necessario disporre di.NET Framework 4.5 installato 4.5.2 o 4.5.1.

Richiesta di riavvio

È necessario riavviare il computer dopo avere applicato questo hotfix se vengono utilizzati i file interessati. Si consiglia di chiudere tutte le applicazioni basate su.NET Framework prima di applicare questo hotfix.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce un pacchetto di hotfix precedentemente rilasciato.


Problemi risolti con questo hotfix cumulativo

Problema ASP.NET

Conflitti e le prestazioni non valida in System.Web.BufferAllocator quando si esegue un'applicazione web su computer che dispongono di più di 32 Core.

Correggere : Il conflitto è stato eliminato rimuovendo il blocco globale in System.Web.BufferAllocator.

Problema di Windows Form

L'interfaccia utente di Windows Form PrintPreviewDialog viene inizializzata molto lentamente quando sono vere le seguenti condizioni:

  • Viene utilizzata una stampante di rete.

  • Le preferenze utente per questa stampante, ad esempio le impostazioni duplex, vengono modificate.

Ottimizzazione delle prestazioni è stato aggiunto a questo scenario. Se le impostazioni di pagina non vengono modificate per una pagina specifica, le impostazioni della stampante per questa pagina non vengono riapplicate (accedendo lo spooler di stampa). Se l'applicazione consente di modificare le impostazioni della stampante utilizzando il gestore di evento QueryPageSettings , le prestazioni di generazione dell'anteprima di stampa per le pagine interessate non risulta migliorata, anche se è impostato il flag di consenso esplicito .

Per aderire a questa ottimizzazione, la seguente chiave deve essere aggiunti al file app. config, a seconda della versione di.NET Framework.

NET Framework 4.5.2:

<?xml version="1.0" encoding="utf-8"?><configuration>
< appSettings >
< add key="OptimizePrintPreview" value="true" />
< /appSettings >
</configuration>
.NET Framework 4.6 o versione successiva:

<?xml version="1.0" encoding="utf-8"?><configuration>
< runtime>
< AppContextSwitchOverrides value = "Switch.System.Drawing.Printing.OptimizePrintPreview=true" />
< /runtime>
</configuration>
Se un'applicazione può essere eseguito su qualsiasi versione di.NET Framework, è possibile utilizzare entrambe le opzioni nello stesso file.

Per abbandonare, rimuovere l'opzione o impostare i valori su false.

ClickOnce issue

ClickOnce è stato aggiornato per supportare TLS 1.1 e 1.2. ClickOnce rileverà automaticamente il protocollo TLS è necessario in fase di esecuzione. Non esistono ulteriori passaggi necessari nell'applicazione ClickOnce per abilitare questa funzionalità.

Nota: ClickOnce supporta comunque TLS 1.0 in futuro, anche se non è più considerato compatibili PCI.

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×