Problema

Quando si tenta di installare un pacchetto R su Linux è visualizzato il seguente messaggio di errore:

"Avviso: Impossibile accedere all'indice per repository - http://www.revolutionanalytics.com./repositories/cran/2.15/stable/s..."

Soluzione

Una soluzione per questo problema consiste nel modificare il file:
/usr/lib64/Revo-6.2/R-2.15.3/lib64/R/etc/Rprofile.site

e modificare la riga: r < - c (REVO = Revobase::getRevoRepos())

In questo blocco di codice:

Se (. Platform$OS.Type = = "windows") {
r["CRAN"] <- Revobase::getRevoRepos(CRANmirror=TRUE) 
} else {
r < - c (REVO = Revobase::getRevoRepos())
}

A:

r < - c (REVO = "http://packages.revolutionanalytics.com/cran/2.15/stable")

Sarà quindi necessario riavviare dell'organizzazione R di rivoluzione per rendere effettive le modifiche.

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×