Sintomi
2019 di Microsoft Exchange Server o Exchange Server 2016, si presuppone che si imposta un server proxy web utilizzato per accedere a Internet utilizzando il parametro InternetWebProxy di Exchange Server e non è possibile accedere direttamente a Internet. Potrebbe verificarsi che la connettività OAuth sempre esito negativo se viene testato utilizzando il cmdlet Test-OAuthConnectivity , anche se la connessione funziona correttamente.
Causa
Questo problema si verifica perché il cmdlet Test-OAuthConnectivity non rispetta le impostazioni di InternetWebProxy impostato su di Exchange Server. Se di Exchange Server è bloccato per connettersi direttamente a Internet, è pertanto non correttamente verificare la connettività OAuth.
Stato
Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".
Risoluzione
Per risolvere questo problema, installare uno dei seguenti aggiornamenti:Per Exchange Server 2019, installare il 1 di aggiornamento cumulativo per Exchange Server 2019 o un aggiornamento cumulativo in un secondo momentoper Exchange Server 2019.
Per il 2016 di Exchange Server, installare il 12 di aggiornamento cumulativo per Exchange Server 2016 o un aggiornamento cumulativo in un secondo momento per il 2016 di Exchange Server.
Riferimenti
Informazioni sulla terminologiautilizzata da Microsoft per descrivere gli aggiornamenti software.