Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Quando si prova a creare una nuova integrazione con Integration Manager con Microsoft Dynamics GP o con Microsoft Business Solutions - Great Plains, viene visualizzato uno dei messaggi di errore seguenti:

Messaggio di errore 1

Elemento '-8' Non in raccolta

Messaggio di errore 2

La classe non supporta l'automazione

Quando si prova ad aprire Integration Manager, potrebbe essere visualizzato anche il messaggio di errore seguente:

Errore di automazione: Sistema operativo non disponibile

Quando si installa Integration Manager in una workstation client, viene visualizzato il messaggio di errore seguente:

Errore interno in TTGErrors: errore di automazione. Il sistema operativo non può eseguire %1.

Quando si fa clic su Dettagli, viene visualizzato il report degli errori seguente:

Impossibile creare l'oggetto IMProvider.ODBCProvider.

Quando si fa clic su ? sulla barra dei menu di Integration Manager e quindi si fa clic su Informazioni su IntegrationManager,viene visualizzato il messaggio di errore seguente:

La classe non supporta l'automazione o non supporta il numero di interfaccia
previsto: 430

Stack di chiamate:

frmAbout.Form_Load

Questo errore si verifica se è installato Microsoft Office 2003.

Causa

Questo errore è causato da un conflitto che si verifica quando Business Contact Manager 2003 e Integration Manager si trova nello stesso computer. Business Contact Manager gli stessi file e alcune chiavi del Registro di sistema di Gestione integrazione 9.0, 8.0 e 7.50. I componenti di Integration Manager 7.0 sono stati usati per creare Business Contact Manager. Tuttavia, un problema si verifica quando nello stesso computer sono installati Business Contact Manager e Integration Manager 9.0, 8.0 o 7.50. Il problema è che il motore WINDOWS a livello di sistema operativo cerca nel Registro di sistema la posizione di un server COM.

NotaBusiness Contact Manager è disponibile solo in Microsoft Office Small Business Edition 2003 e in Microsoft Office Professional Edition 2003.

Risoluzione

Per risolvere il problema, usare la risoluzione 1 o 2 a seconda che si usi o meno Business Contact Manager. Se non si usa Business Contact Manager, è possibile rimuovere il componente usando la risoluzione 1. Se si usa Business Contact Manager, è necessario usare la risoluzione 2.

Risoluzione 1: Rimuovere Business Contact Manager

Se non si usa Business Contact Manager, è possibile risolvere il problema rimuovendo il componente. A questo scopo, è necessario usare Installazione applicazioni. Dopo la rimozione dei componenti, è necessario ripristinare Integration Manager. Per eliminare BusinessContactManager e ripristinare Integration Manager, seguire questa procedura:

  1. Fare clic su Start, scegliere Programmi , Pannello di controllo , fare doppio clic su Installazione applicazioni , fare clic su Business Contact Managere quindi su Rimuovi.

  2. In Installazione applicazioni selezionareIntegration Manager,fare clicsu Cambia/Rimuovie quindi su Ripristina.

  3. Se si continua a ricevere il messaggio di errore, ripetere questa procedura facendo clic su Modifica nel passaggio 2 invece di Ripristina. Quindi selezionare per installare tutti gli oggetti.

Soluzione 2: Forzare il Registro di sistema a usare i file del motore COM corretti

Se si usa Business Contact Manager, è possibile risolvere il problema creando un IM.EXE. FILE LOCALE per forzare il Registro di sistema a usare i file del motore COM Windows corretti per Integration Manager. A tal fine, attenersi alla seguente procedura:

  1. Iniziare Blocco note e lasciare vuoto il tastierino.

  2. Fare clic su Filee quindi su Salva con nome.

  3. Modificare il valore del campo Tipo file in Tutti i file.

  4. Nel campo Nome file digitare IM.EXE. LOCALE. Salvare quindi il file nella stessa cartella in cui è installato Integration Manager (IM.exe).

    Nota Se un file ha lo stesso nome dell'applicazione client e il nome del file ha il nome . Estensione LOCAL, il motore COM verifica se il server COM si trova nella directory locale invece di caricarlo dalla cartella nel Registro di sistema.

  5. Copiare CBOMLib.dll e i CBOMLibX.dll file nella stessa cartella del IM.exe e del IM.EXE. File LOCALI. Quando il file IM.exe viene aperto da questa cartella, il file IM.exe usa le copie locali dei file CBOMLib.dll e CBOMLibX.dll invece dei file identificati nel Registro di sistema.

    Nota Poiché Business Contact Manager è stato installato dopo Integration Manager, il Registro di sistema punta alle copie Business Contact Manager di tali file. Queste copie sono uguali a quelle di Integration Manager 7.0.

Ulteriori informazioni

Questo articolo è stato ID documento TechKnowledge:34103 Il problema descritto nella sezione Sintomi non si applica a


Microsoft Dynamics GP 10.0.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×