Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Quando si prova a ripristinare un backup o si prova a masterizzare un backup in un CD-RW o in un DVD-RW in Microsoft Office Accounting Professional o in Microsoft Office Accounting Express, viene visualizzato uno dei messaggi di errore seguenti.

Messaggio di errore 1

L'handle non supporta il funzionamento sincrono, potrebbe essere necessario modificare i parametri per il costruttore dello screen screen per indicare che l'handle è stato aperto in modo asincrono, ovvero è stato aperto in modo esplicito per operazioni di I/O sovrapposte.

Messaggio di errore 2

La famiglia di supporti nel dispositivo C è formata in modo non corretto. SQL server non è in grado di elaborare questa famiglia di supporti. RESTORE HEADERONLY termina in modo anomalo.

Messaggio di errore 3

Accesso negato.

Causa

Questo problema si verifica per uno dei motivi seguenti:

  • Se viene visualizzato il messaggio di errore 1, nel computer non è installato Microsoft SQL Server prodotto. Vedere il metodo 1 o il metodo 2 nella sezione "Risoluzione".

  • Se viene visualizzato il messaggio di errore 2, Microsoft SQL Server 2005 è installato nel computer. Si sta provando a ripristinare il backup usando un file di backup in un dispositivo di archiviazione portatile. Tuttavia, il dispositivo di archiviazione portatile non è compatibile con il SQL Server di ripristino di SQL Server 2005. Vedere il metodo 3 nella sezione "Risoluzione".

  • Se viene visualizzato il messaggio di errore 3, è possibile che si stia provando a masterizzare il backup su un CD riscrivibile (CD-RW) o un DVD riscrivibile (DVD-RW). Il backup scritto direttamente sul supporto è in conflitto con il processo di masterizzazione. Vedere il metodo 4 nella sezione "Risoluzione".

Risoluzione

Per risolvere il problema, usare il metodo appropriato.

Metodo 1

Rimuovere manualmente accounting Professional o Accounting Express. Reinstallare quindi Accounting Professional o Accounting Express.

Per altre informazioni su come rimuovere manualmente accounting Professional o Accounting Express, fare clic sui numeri degli articoli seguenti per visualizzare gli articoli della Microsoft Knowledge Base:

945462 Come rimuovere manualmente Accounting Professional 2008 o Accounting Express 2008 e SQL Server 2005

930294 Come rimuovere manualmente Microsoft Office Accounting 2007 e Microsoft SQL Server Express 2005
Nota Microsoft SQL Server 2005 Express Edition viene installato quando si reinstalla
Accounting Professional o Accounting Express.

Metodo 2

Installare SQL Server 2005 Express Edition. Per informazioni su come ottenere SQL Server 2005 Express Edition, visitare il seguente sito Web Microsoft:

http://msdn.microsoft.com/vstudio/express/sql/download/

Metodo 3

Copiare il file di backup dal dispositivo di archiviazione portatile in un'unità disco rigido locale. Usare quindi questo file di backup per ripristinare il backup nel computer. A questo scopo, seguire questa procedura:

  1. Fare clic sul pulsante Start, quindi scegliere Risorse del computer.

  2. Connessione dispositivo di archiviazione portatile che contiene il file di backup nel computer.

  3. Fare doppio clic sul nome del dispositivo di archiviazione portatile.

  4. Fare clic con il pulsante destro del mouse sul file di backup e quindi scegliere Copia.

  5. Fare doppio clic su un'unità disco rigido locale. Ad esempio, fare doppio clic su Disco locale (C).

  6. Scegliere Incolla dal menu Modifica.

  7. Avviare Accounting Professional o Accounting Express.

  8. Usare il file di backup copiato nell'unità disco rigido locale per ripristinare il backup nel computer.

Metodo 4

Creare un file di backup per l'azienda e quindi copiarlo nel CD-RW o nel DVD-RW. A tal fine, attenersi alla seguente procedura:

  1. Avviare Accounting Professional o Accounting Express.

  2. Nel menu File fare clic su Apri società per aprire la società.

  3. Scegliere Utilità dal menu File equindi fare clic su Utilità dati.

  4. Nella scheda Strumenti di base fare clic su Backup.

  5. Fare clic suSfoglia , specificare un nome file per il file di backup e quindi fare clic su Salva.


    Nota Per impostazione predefinita, il percorso dei file di backup è il seguente:

    C:\Documents and Impostazioni\User_name\My Documents\Small Business Accounting\Backups

  6. Se si vuole aggiungere una password per proteggere il file di backup, digitare la password e la password di verifica.

  7. Scegliere OK.

  8. Al termine del backup, fare clic su Chiudi nella Microsoft Office finestra di dialogo File utilità dati contabilità.

  9. Chiudere Accounting Professional o Accounting Express.

  10. Fare clic sul pulsante Start, quindi scegliere Risorse del computer.

  11. Individuare il file di backup salvato nel passaggio 5.

  12. Fare clic con il pulsante destro del mouse sul file di backup e quindi scegliere Copia.

  13. Individuare l'unità CD o DVD scrivibile, fare clic con il pulsante destro del mouse sull'unità e quindi scegliere Incolla.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×