Aggiornamento dell'ora legale
Importante L'aggiornamento in questo articolo è stato superato dall'aggiornamento cumulativo nell Microsoft articolo della Knowledge Base 955839.
Non è necessario rimuovere alcun aggiornamento dell'ora legale installato in precedenza per applicare questo aggiornamento cumulativo.
Sintomi
Quando il fuso orario è impostato su (GMT+02:00) Il Cairo in Microsoft Windows Server 2003, in Microsoft Windows XP o in Microsoft Windows 2000, l'ora legale potrebbe iniziare o terminare in una data non corretta e in un orario non corretto.
Ad esempio, l'orologio di un computer può passare all'ora legale il primo venerdì di maggio alle 02:00 e può cambiare dall'ora legale dell'ultimo mercoledì di settembre alle 02:00. Tuttavia, in Egitto, l'ora legale inizia l'ultimo venerdì di aprile alle 00:00:00 (mezzanotte) e termina l'ultimo venerdì di settembre alle 00:00:00.
Il comportamento si verifica se le proprietà di data e ora sono impostate su quanto segue:
-
Fuso orario è impostato su (GMT+02:00) Cairo.
-
La casella di controllo Regola automaticamente l'orologio per le modifiche all'ora legale è selezionata.
Causa
Questo problema si verifica perché le informazioni nel Registro di sistema per questo fuso orario non sono corrette. I dati di riferimento vengono archiviati nella seguente sottochiave:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones\Egypt Standard TimeLe informazioni attualmente in uso vengono archiviate nella sottochiave seguente:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformationLe informazioni sul fuso orario in entrambe le posizioni sono in formato binario. Non è consigliabile risolvere il problema modificando il Registro di sistema.
Risoluzione
Informazioni su Windows Server 2003 Service Pack
Per risolvere il problema, ottenere il Service Pack più recente per Windows Server 2003.
Informazioni sull'aggiornamento rapido di Windows Server 2003
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix ha lo scopo di correggere solo il problema descritto in questo articolo. Applica questo hotfix solo ai sistemi che stanno riscontrando questo problema specifico. Questo hotfix potrebbe ricevere ulteriori test. Pertanto, se non si è gravemente colpiti da questo problema, è consigliabile attendere il prossimo aggiornamento software che contiene questo hotfix.
Se l'hotfix è disponibile per il download, nella parte superiore di questo articolo della Knowledge Base è presente la sezione "Download di hotfix disponibile". Se questa sezione non viene visualizzata, contattare Microsoft servizio clienti e supporto tecnico per ottenere l'hotfix.
Nota Se si verificano altri problemi o se è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di servizio separata. I soliti costi di supporto si applicano a ulteriori domande e problemi di supporto che non sono idonei per questo hotfix specifico. Per un elenco completo dei numeri di telefono del servizio clienti e del supporto tecnico Microsoft o per creare una richiesta di servizio separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota Il modulo "Download di hotfix disponibile" mostra le lingue per cui l'hotfix è disponibile. Se non vedi la tua lingua, è perché non è disponibile un hotfix per tale lingua.
Informazioni sui file
La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Le date e le ore di questi file sono espresse nel formato UTC (Coordinated Universal Time). Quando esaminate le informazioni del file, viene convertito in orario locale. Per trovare la differenza tra UTC e l'ora locale, usare la scheda Fuso orario nell'elemento Data e ora in Pannello di controllo.
Windows Server 2003, versioni a 32 bit
Nome file |
Versione file |
Dimensione file |
Date |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cstegypt.dll |
5.2.3790.199 |
5,632 |
16-agosto 2004 |
18:09 |
x86 |
Cstegypt.dll |
5.2.3790.199 |
5,632 |
16-agosto 2004 |
18:09 |
x86 |
Versioni basate su Itanium di Windows Server 2003
Nome file |
Versione file |
Dimensione file |
Date |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cstegypt.dll |
5.2.3790.199 |
8,704 |
16-agosto 2004 |
18:09 |
IA-64 |
Cstegypt.dll |
5.2.3790.199 |
8,704 |
16-agosto 2004 |
18:09 |
IA-64 |
Windows Server 2003 con Service Pack 1, versioni a 32 bit
Nome file |
Versione file |
Dimensione file |
Date |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cstegypt.dll |
5.2.3790.2688 |
6,144 |
24 aprile 2006 |
18:09 |
x86 |
Cstegypt.dll |
5.2.3790.2688 |
6,144 |
24 aprile 2006 |
18:09 |
x86 |
Windows Server 2003 con Service Pack 1, versioni basate su Itanium
Nome file |
Versione file |
Dimensione file |
Date |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cstegypt.dll |
5.2.3790.2688 |
11,264 |
24 aprile 2006 |
22:31 |
IA-64 |
Cstegypt.dll |
5.2.3790.2688 |
11,264 |
24 aprile 2006 |
22:31 |
IA-64 |
Windows Server 2003, versioni basate su x64
Nome file |
Versione file |
Dimensione file |
Date |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cstegypt.dll |
5.2.3790.2688 |
9,216 |
24 aprile 2006 |
22:31 |
x64 |
Cstegypt.dll |
5.2.3790.2688 |
9,216 |
24 aprile 2006 |
22:31 |
x64 |
Informazioni sull'aggiornamento rapido di Windows XP
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix ha lo scopo di correggere solo il problema descritto in questo articolo. Applica questo hotfix solo ai sistemi che stanno riscontrando questo problema specifico. Questo hotfix potrebbe ricevere ulteriori test. Pertanto, se non si è gravemente colpiti da questo problema, è consigliabile attendere il prossimo aggiornamento software che contiene questo hotfix.
Se l'hotfix è disponibile per il download, nella parte superiore di questo articolo della Knowledge Base è presente la sezione "Download di hotfix disponibile". Se questa sezione non viene visualizzata, contattare Microsoft servizio clienti e supporto tecnico per ottenere l'hotfix.
Nota Se si verificano altri problemi o se è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di servizio separata. I soliti costi di supporto si applicano a ulteriori domande e problemi di supporto che non sono idonei per questo hotfix specifico. Per un elenco completo dei numeri di telefono del servizio clienti e del supporto tecnico Microsoft o per creare una richiesta di servizio separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota Il modulo "Download di hotfix disponibile" mostra le lingue per cui l'hotfix è disponibile. Se non vedi la tua lingua, è perché non è disponibile un hotfix per tale lingua. La versione in lingua inglese di questo hotfix contiene gli attributi di file (o attributi di file successivi) elencati nella tabella seguente. Le date e le ore di questi file sono espresse nel formato UTC (Coordinated Universal Time). Quando esaminate le informazioni del file, viene convertito in orario locale. Per trovare la differenza tra UTC e l'ora locale, usare la scheda Fuso orario nell'elemento Data e ora in Pannello di controllo.
Nome file |
Versione file |
Dimensione file |
Date |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cstegypt.dll |
5.1.2600.2505 |
5,632 |
14-agosto 2004 |
00:24 |
x86 |
Cstegypt.dll |
5.1.2600.2505 |
5,632 |
14-agosto 2004 |
00:24 |
x86 |
Informazioni sull'aggiornamento rapido di Windows 2000
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix ha lo scopo di correggere solo il problema descritto in questo articolo. Applica questo hotfix solo ai sistemi che stanno riscontrando questo problema specifico.
Se l'hotfix è disponibile per il download, nella parte superiore di questo articolo della Knowledge Base è presente la sezione "Download di hotfix disponibile". Se questa sezione non viene visualizzata, inviare una richiesta a Microsoft servizio clienti e supporto tecnico per ottenere l'hotfix.
Nota Se si verificano altri problemi o se è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di servizio separata. I soliti costi di supporto si applicano a ulteriori domande e problemi di supporto che non sono idonei per questo hotfix specifico. Per un elenco completo dei numeri di telefono del servizio clienti e del supporto tecnico Microsoft o per creare una richiesta di servizio separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota Il modulo "Download di hotfix disponibile" mostra le lingue per cui l'hotfix è disponibile. Se non vedi la tua lingua, è perché non è disponibile un hotfix per tale lingua.
Informazioni sui file
La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Le date e le ore di questi file sono espresse nel formato UTC (Coordinated Universal Time). Quando esaminate le informazioni del file, viene convertito in orario locale. Per trovare la differenza tra UTC e l'ora locale, usare la scheda Fuso orario nell'elemento Data e ora in Pannello di controllo.
Nome file |
Versione file |
Dimensione file |
Date |
Ora |
Piattaforma |
---|---|---|---|---|---|
Cstegypt.dll |
5.0.2195.6961 |
5,392 |
Dal 30 luglio 2004 |
18:38 |
x86 |
Cstegypt.dll |
5.0.2195.6961 |
5,392 |
Dal 30 luglio 2004 |
18:38 |
x86 |
Stato
Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a". Questo problema è stato innanzitutto corretto in Microsoft Windows Server 2003 Service Pack 2.
Ulteriori informazioni
L'hotfix modifica le impostazioni del Registro di sistema sui valori seguenti:
-
Inizio ora legale: Ultimo giovedì di aprile alle 23:59:59
-
Fine ora legale: Ultimo giovedì di settembre alle 23:59:59
Per impostare automaticamente l'ora legale nel computer, usare i metodi seguenti.
Impostare il computer per regolare automaticamente l'ora legale in Windows Server 2003
-
Fare clic su Inizio, scegliere Pannello di controllo e quindi fare clic su Data e ora.
-
Nella scheda Fuso orario usare una delle procedure seguenti:
-
Per impostare il computer in modo da cambiare l'orologio di sistema per l'ora legale, fare clic per selezionare la casella di controllo Regola automaticamente l'orologio per le modifiche all'ora legale e quindi fare clic su OK.
-
Per impostare il computer in modo da non modificare l'orologio di sistema per l'ora legale, fare clic per deselezionare la casella di controllo Regola automaticamente l'orologio per le modifiche all'ora legale e quindi fare clic su OK.
-
Impostare il computer per regolare automaticamente l'ora legale in Windows XP
-
Fare clic sul pulsante Start, scegliere Esegui, digitare timedate.cpl e quindi fare clic due volte su OK .
-
Nella scheda Fuso orario usare una delle procedure seguenti:
-
Per impostare il computer in modo da cambiare l'orologio di sistema per l'ora legale, fare clic per selezionare la casella di controllo Regola automaticamente l'orologio per le modifiche all'ora legale e quindi fare clic su OK.
-
Per impostare il computer in modo da non modificare l'orologio di sistema per l'ora legale, fare clic per deselezionare la casella di controllo Regola automaticamente l'orologio per le modifiche all'ora legale e quindi fare clic su OK.
-
Impostare il computer per regolare automaticamente l'ora legale in Windows Server 2000
-
Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.
-
Fare doppio clic su Data e ora.
-
Nella scheda Fuso orario usare una delle procedure seguenti:
-
Per impostare il computer in modo da cambiare l'orologio di sistema per l'ora legale, fare clic per selezionare la casella di controllo Regola automaticamente l'orologio per le modifiche all'ora legale e quindi fare clic su OK.
-
Per impostare il computer in modo da non modificare l'orologio di sistema per l'ora legale, fare clic per deselezionare la casella di controllo Regola automaticamente l'orologio per le modifiche all'ora legale e quindi fare clic su OK.
-