Aggiungere connettori tra le forme di Visio

Si applica a
Visio - Piano 1 Visio Professional 2024 Visio Standard 2024 Visio Professional 2021 Visio Standard 2021 Visio Professional 2016 Visio Standard 2016

Con Visio diventa facile connettere le forme del disegno.

È possibile usare Connessione automatica per connettere le forme aggiunte e quelle già presenti tramite lo strumento Connettore. È anche possibile modificare le forme visualizzate nella barra di formattazione rapida e attivare o disattivare la connessione automatica.

Connettere automaticamente una forma

Connettere forme già presenti nella pagina

Creare una connessione a una forma in un'altra pagina

Usare i temi per cambiare l'aspetto dei connettori

Usare forme connettore alternative

Modificare le forme sulla barra di formattazione rapida Connessione automatica

Attivare o disattivare la connessione automatica

Connettere automaticamente una forma

Uno dei possibili modi per connettere le forme consiste nel lasciar eseguire automaticamente questa operazione da Visio quando si aggiunge una forma a una pagina. Questa opzione risulta particolarmente utile quando si creano diagrammi di flusso.

  1. Assicurarsi che l'opzione Connessione automatica sia attiva. Nel gruppo Strumenti visivi della scheda Visualizza verificare che l'opzione Connessione automatica sia selezionata.

  2. Trascinare una forma dal riquadro Forme alla pagina.

  3. Posizionare il puntatore del mouse sulla forma finché attorno a essa non vengono visualizzate frecce di connessione automatica.

    Screenshot che mostra che la connessione automatica è attiva. Passare il puntatore del mouse sopra una forma per visualizzare le frecce di connessione.

  4. Posizionare il puntatore del mouse sulla freccia nella direzione in cui si desidera aggiungere una forma.

    Screenshot che mostra il passaggio del mouse su una freccia di Connessione automatica e una barra degli strumenti con le forme da aggiungere.

    Viene visualizzata una barra di formattazione rapida contenente le prime quattro forme rapide presenti nello stencil Forme rapide. Quando si posiziona il puntatore su una forma nella barra degli strumenti, Visio visualizza l'anteprima corrispondente nella pagina.

  5. Selezionare la forma da aggiungere.

  6. Se si vuole continuare, posizionare il puntatore su una freccia di Connessione automatica su una forma appena aggiunta per aggiungerne un'altra che verrà connessa automaticamente.

    Screenshot che mostra il passaggio del puntatore del mouse sulla forma appena aggiunta e le frecce di connessione automatica per l'aggiunta di un'altra forma.

Inizio pagina

Connettere forme già presenti nella pagina

Suggerimento

I comandi nel gruppo Strumenti della scheda Home modificano lo stato o la modalità di Visio, fatto che in alcuni casi può creare confusione. Utilizzare la tastiera per passare comodamente tra gli strumenti Selezioneoggetti (premereCtrl+1) e Immagine pulsante connettore (premere Ctrl+3). Qualunque sia lo strumento in uso, ad esempio Blocco di testo o Punto di connessione, premere ESC più volte per tornare a Strumento Selezione.

  1. Nel gruppo Strumenti della scheda Home selezionare l'immagine del pulsante Connettore o premere CTRL+3.
  2. Selezionare una forma e trascinare un connettore su un'altra forma.
  3. Al termine, selezionare lo strumento Selezione Seleziona oggetti nella scheda Home nel gruppo Strumenti oppure premere CTRL+1.

Mostrare o nascondere l'animazione

Screenshot che mostra lo strumento Connettore connette due forme con una connessione punto a punto a ogni estremità.

In alternativa, è possibile aggiungere il comando Connetti forme alla barra multifunzione e usarlo per connettere più forme nell'ordine in cui sono state selezionate.

Screenshot che mostra il video delle forme Connetti

Suggerimento

I comandi utili che non sono già visibili sulla barra multifunzione possono essere aggiunti selezionandoOpzioni>file>Personalizzare la barra multifunzione.

Inizio pagina

Creare una connessione a una forma in un'altra pagina

È possibile usare connettori solo tra le forme nella stessa pagina. Per creare una connessione a una forma in un'altra pagina, usare la forma Riferimento esterno pagina per creare un collegamento ipertestuale da una pagina alla successiva oppure aggiungere un collegamento ipertestuale e un'azione Doppio clic a qualsiasi forma in modo che possa passare a un'altra pagina nello stesso documento.

Usare Riferimento esterno pagina

  1. Aprire lo stencil Diagramma di flusso - Forme base e quindi trascinare la forma Riferimento esterno pagina nella pagina corrente.

    Schermata che mostra la forma Riferimento esterno pagina

  2. Nella finestra di dialogo Riferimento esterno pagina selezionare OK per aggiungere la forma alla pagina corrente e a una pagina appena creata.

  3. Nella nuova pagina continuare a creare il diagramma.

  4. Per modificare l'aspetto della forma Riferimento esterno pagina, fare clic con il pulsante destro del mouse sulla forma e quindi scegliere In uscita, In ingresso, Cerchio o Freccia.

Per spostarsi tra le pagine, fare doppio clic sulla forma Riferimento esterno pagina in una delle due pagine. Per altre informazioni, vedere Finestra di dialogo Riferimento esterno pagina.

  1. Fare clic con il pulsante destro del mouse sulla forma e selezionare Collegamento ipertestuale oppure selezionare la forma e premere CTRL+K*.

  2. Selezionare Sfoglia accanto al campo Sottoindirizzo e quindi selezionare l'elenco a discesa accanto a Pagina per selezionare la pagina desiderata.

    Screenshot che mostra la finestra di dialogo Collegamento ipertestuale

    Nota

    Il nome di una forma nella pagina di destinazione può essere specificato anche per un collegamento ipertestuale. Selezionare la scheda Sviluppo e quindi selezionare Nome forma oppure usare il nome predefinito nel campo Nome oppure modificarlo e quindi selezionare OK.

    Gli utenti potrebbero dover abilitare la scheda Sviluppo prima di seguire le istruzioni sul nome della forma e sul comportamento.

  3. Per impostare l'azione doppio clic per una forma, selezionare la scheda Sviluppo e quindi Comportamento.

  4. Selezionare la scheda Doppio clic , selezionare l'opzione Vai a pagina e quindi selezionare la pagina che si vuole nell'elenco a discesa.

    Screenshot che mostra l'azione Double-Click Visio

    Nota

    Eseguire questa operazione dopo aver modificato i nomi delle pagine perché qui non vengono aggiornati automaticamente.

Inizio pagina

Usare i temi per cambiare l'aspetto dei connettori

I connettori possono essere semplici righe per impostazione predefinita, ma è possibile progettarli per la compatibilità con temi che aggiungono dettagli decorativi, ad esempio punte di frecce. I temi predefiniti possono essere applicati dalla raccolta Temi nella scheda Progettazione . Per modificare un attributo di un connettore, ad esempio stile, colore, spessore e così via, vedere Modifica delle forme del connettore.

Mostrare o nascondere l'animazione

Screenshot che mostra le animazioni nascoste

Nota

Per visualizzare altre decorazioni, seleziona la scheda Progettazione . Nel gruppo Varianti selezionare la freccia a discesa e quindi selezionare Connettori. Screenshot che mostra le animazioni nascoste-1

Usare forme connettore alternative

Per connettere le forme è possibile usare qualsiasi forma di connettore, ad esempio quelle disponibili nello stencil Altre forme>di Visio Extras>Connettori , al posto della forma connettore dinamico predefinita. Possono essere trascinate in una pagina o selezionate con gli strumenti Connettore e Connetti forme oppure usate semplicemente in sostituzione dei connettori esistenti.

  1. Aprire lo stencil contenente le forme di connettore alternative.
  2. Nella pagina selezionare i connettori esistenti da sostituire.
  3. Nel gruppo Modifica della scheda Home selezionare Cambia forma e quindi selezionare la forma del connettore che si vuole.

Mostrare o nascondere l'animazione

Screenshot che mostra l'animazione nascosta della modifica della forma

Nota

La funzionalità Cambia forma è stata introdotta in Visio 2013, mentre gli strumenti Connettore e Connetti forme sono precedenti a Visio 2007.

Inizio pagina

Modificare le forme sulla barra di formattazione rapida Connessione automatica

Le forme sulla barra di formattazione rapida provengono dallo stencil Forme rapide di un diagramma. La barra di formattazione rapida può visualizzare fino a quattro forme. È possibile personalizzare le forme presenti nella barra di formattazione rapida. La procedura seguente usa come esempio il Diagramma base.

  1. Per impostazione predefinita, le forme nella barra di formattazione rapida sono le prime quattro nello stencil che segue immediatamente lo stencil Forme rapide. Ad esempio, queste sono le prime quattro forme dello stencil Forme base.

    Screenshot che mostra la barra di formattazione rapida con le forme base predefinite

  2. Per visualizzare forme diverse nella barra di formattazione rapida per un determinato stencil, è possibile riordinare le forme trascinandole nella parte superiore dello stencil. Ad esempio, è possibile trascinare le forme Stella a 4 punte, Stella a 5 punte, Stella a 6 punte e Stella a 7 punte nella parte superiore dello stencil Forme base.

    Screenshot che mostra la barra di formattazione rapida con le nuove forme base

  3. Si può anche modificare l'ordine degli stencil trascinandoli più in alto o più in basso nel riquadro Forme. Un subset di queste forme viene visualizzato nello stencil Forme rapide, nello stesso ordine in cui si trovano nel riquadro Forme. Ad esempio, dopo aver trascinato lo stencil Forme decorative immediatamente dopo lo stencil Forme rapide nel riquadro Forme, la sequenza cambia nello stencil Forme rapide.

    Screenshot che mostra la barra di formattazione rapida con un nuovo stencil tramite riordino

    Nota

    Quando si chiude e si riapre un diagramma, l'ordine predefinito degli stencil nel riquadro Forme viene ripristinato automaticamente e riflesso in Forme rapide.

  4. Per usare un altro stencil come base per la barra di formattazione rapida, nello stencil Forme rapide selezionare una forma nel subset di queste forme per uno stencil. Ad esempio, selezionare Diagramma di Venn nello stencil Forme grafiche e matematiche.

    Screenshot che mostra la barra di formattazione rapida con un nuovo stencil selezionando

Suggerimento

Per tornare alla sequenza predefinita delle forme in uno stencil, fare clic con il pulsante destro del mouse sul nome dello stencil nel riquadro Forme e quindi scegliere Reimposta stencil.

Nota

Non tutti gli stencil hanno forme che possono essere usate nella barra di formattazione rapida. Ad esempio, le forme nello stencil Frecce - Forme non vengono visualizzate nella barra di formattazione rapida.

Inizio pagina

Attivare o disattivare la connessione automatica

Connessione automatica è un'opzione a livello di file. Se si abilita l'opzione, rimane così per il file corrente, ma è necessario abilitarla nuovamente quando si lavora su un file diverso. Per alcuni modelli, l'opzione è abilitata per impostazione predefinita. 

Attivare o disattivare la connessione automatica nel diagramma attivo

  • Nel gruppo Strumenti visivi della scheda Visualizza selezionare o deselezionare Connessione automatica.

    Screenshot che mostra come selezionare o deselezionare la connessione automatica nella scheda Visualizza per attivare o disattivare questa opzione.

Se l'opzione Connessione automatica è disattivata, è possibile riattivarla andando suOpzioni>file>avanzate e selezionando Abilita connessione automatica:

Attivare o disattivare Connessione automatica

  1. Selezionare la scheda File , quindi scegliere Opzioni.

  2. In Opzioni Visio, selezionare Avanzate.

  3. In Opzioni di modifica selezionare Attiva connessione automatica per attivare la connessione automatica. Oppure deselezionare la casella di controllo per disattivare Connessione automatica.

    Screenshot che mostra come selezionare o deselezionare Abilita connessione automatica per attivare o disattivare la connessione automatica per tutti i diagrammi & i disegni.

  4. Selezionare OK.

Inizio pagina

Vedere anche

Modificare linee, frecce o punti di connessione

Aggiungere e modificare il testo del connettore

Creare un connettore personalizzato

Associare o rimuovere l'associazione dei connettori

Informazioni utili sui connettori desktop di Visio

Formazione su Visio