注 この資料は、オンプレミスの Lync Server が構成されていることと、TechNet の記事にある「Lync Server 2013 ハイブリッド環境を準備および展開する手順」および「Lync Server 2013 ハイブリッド展開の計画」の前提条件を満たしていることを前提としています。本資料では Lync Server の展開や構成のシナリオは説明していません。
現象
オンプレミスで展開された Microsoft Lync Server から Microsoft Office 365 Skype for Business Online (旧名称 Lync Online) に移行したユーザーは Skype for Business Online にサインインできません。
原因
以下の条件の 1 つ以上が該当する場合、この問題が発生する可能性があります。
-
シングル サインオン (SSO) が正しく設定されておらず、ユーザーが Microsoft Office 365 ポータルを含むどの Office 365 サービスにもサインインできない。
-
Lync Autodiscover のレコードがドメイン ネーム サービス (DNS) で正しく設定されていない。オンプレミスの Lync Server 及び Skype for Business Online とのハイブリッド展開では、Lync Autodiscover の DNS レコードはオンプレミスの Lync Server に向けられていなければならない。
-
ユーザーがオンプレミスの Lync プールから Skype for Business Online に移行していない。
-
ユーザーがオンプレミス展開の Lync で有効になっていない。
-
ユーザーが Office 365 ポータルで Skype for Business Online のライセンスを与えられていない。
-
Skype for Business Online でユーザー アカウントがプロビジョンされていない。
解決方法
この問題を解決するため以下の手順に従ってください。
-
Office 365 ポータルにサインインし、シングル サインオンが正常に機能していることを確認してください。ポータルへの認証が成功した場合、次の手順へ進んでください。
-
オンプレミスで展開された Lync Server の DNS レコードが正しく設定されていることを確認してください。以下のリソースを参考にしてください。
-
ユーザーが Skype for Business Online に移行したかどうかを知るための簡単な方法は、オンプレミスの Lync Server から Lync Server コントロール パネルをチェックすることです。移行済みであれば、ユーザーのホーム プールは LyncOnline です (以下 [Homed] 列参照)。
ハイブリッド展開されている Lync のユーザーを移行させる方法の詳細については、以下の TechNet の記事を参照してください。 -
オンプレミスの Lync Server から Skype for Business Online にユーザーを移行させる前に、Office 365 ポータルで Skype for Business Online のライセンスを付与する必要があります。ただし、何らかの理由でユーザーのライセンスが削除された場合は、Skype for Business Online にはサインインできません。次の手順に進む前に、ユーザーが有効な Skype for Business Online のライセンスを持っていることを確認してください。
-
Skype for Business Online Preview でプロビジョンが遅れ、新しいユーザー アカウントの有効化を妨げることがあります。ユーザーに有効な Skype for Business Online Preview ライセンスが割り当てられたとしても、プロビジョニングされていない場合もあります。Lync 管理センターで、ユーザーが Skype for Business Online Preview ユーザー一覧表に表示されていることを確認してください。
追加情報
ユーザーがハイブリッド展開を通じて Skype for Business Online へのサインインに成功すると、Skype for Business Online トポロジにおける最終的なホーム サーバに到達するまで、複数回リダイレクトされます。このログの例では、Skype for Business Online はまずオンプレミスの Lync Server へアクセスし、その後ユーザーのホスト プロバイダ (sipfed.online.lync.com) にリダイレクトされることが見てとれます。
ユーザーが Skype for Business Online のホスト プロバイダにリダイレクトされた後、クライアントは、ユーザーがホームとするプールを特定するための処理を行います。以下の例では、最初のリダイレクトから数行下でこの処理が行われています 。 Skype for Business Online のホスト プロバイダもしくはホーム プールへのリダイレクトが確認できない場合は以下をチェックしてください。-
Skype for Business Online のホスト プロバイダが、オンプレミスの Lync 展開において正しく設定、フェデレーションされていること。以下の TechNet 記事を参照してください。
-
ユーザーが Skype for Business Online にプロビジョンされライセンスを付与されていることを確認してください。